所属分类: 网络技术 整理: FengNet.Com 更新日期:2006/3/7 9:32:13 阅读次数:6439

配置示例:Catalyst与 CatOS 交换机之间的 ISL/802.1q 中继


介绍

本文提供Cisco Catalyst 5500与Catalyst 3500XL交换机之间InterSwitch Link (ISL)和802.1q中继的配置示例,执行命令时显示每个命令的结果。为了获得相同的结果,可在本文所说明的方案中使用Cisco Catalyst 4000和6000(运行CatOS)系列交换机或Catalyst 5000系列中的其他交换机以及任何 Catalyst 2900XL、3500XL或2950交换机。
所使用组件

在本文的示例中,我们在实验室环境中使用以下交换机和清除(缺省)配置:

*

运行Cisco IOS 12.0(5.x)XU的Catalyst 3524XL交换机
*

运行Catalyst OS 5.5(3)软件的Catalyst 5500交换机

本文所包含的信息基于特定 实验室环境 中的设备。 在使用任何配置或命令之前,您必须确保由此可能对网络带来的潜在影响。所有设备上的配置通过 clear config all 和 write erase 命令来清除,从而确保默认配置。
基础理论

中继是在两个设备之间点到点链路传输来自若干 VLAN的业务的一种方式。 执行以太网中继的方法有如下两种:

*

ISL (Cisco 专有 InterSwitch 链路协议)
*

802.1q (电气电子工程师协会 (IEEE) 标准)

我们将建立一条中继,通过 Catalyst 3500 和 Catalyst 5500 交换机之间的单一链路来传输来自2个VLAN (VLAN 1 和 VLAN 2) 的业务。如何在2个VLAN 之间选路由不属于本文讨论范围。
重要提示

对于 Catalyst 2900XL/3500XL/2950 交换机:

Catalyst 2950 系列交换机只支持802.1q中继,而不支持ISL中继。

Catalyst 2900XL/3500XL 交换机目前不支持动态中继协议 (DTP)。 因此,我们建议在中继链路的 other(另一端) 使用 nonegotiate 选项,如同 Catalyst 4000、5000 和 6000 交换机上的配置一样。这样,XL 交换机端口就不会接收不熟悉的 DTP 帧。

在 4MB DRAM Catalyst 2900XL 交换机上,只有配备以下具有中继功能的模块时才支持中继:

*

WS-X2914-XL-V
*

WS-X2922-XL-V
*

WS-X2924-XL-V
*

WS-X2931-XL
*

WS-X2932-XL

有关当前支持中继的交换型号,请参阅下表:

交换机型号

ISL中继所要求的最低版本

IEEE802.1q中继所要求的最低版本

中继(ISL/802.1q )所要求的当前版本

WS-C2916M-XL (4-Meg Switch)

11.2(8)SA4 (企业版)

11.2(8)SA5 (原始版本)

11.2(8.6)SA6 (原始版本)

WS-C2912-XL

11.2(8)SA4 (企业版)

11.2(8)SA5 (原始版本)

12.0(5)WC(1) 或更高版本

WS-C2924-XL

11.2(8)SA4 (企业版)

11.2(8)SA5 (原始版本)

12.0(5)WC(1) 或更高版本

WS-C2924C-XL

11.2(8)SA4 (Enterprise Edition)

11.2(8)SA5 (企业版)

12.0(5)WC(1) 或更高版本

WS-C2924M-XL

11.2(8)SA4 (企业版)

11.2(8)SA5 (原始版本)

12.0(5)WC(1) 或更高版本

WS-C2912MF-XL

11.2(8)SA4 (企业版)

11.2(8)SA5 (原始版本)

12.0(5)WC(1) 或更高版本

WS-C2924M-XL-DC

12.0(5)XU

12.0(5)XU

12.0(5)WC(1) 或更高版本

WS-C3508G-XL

11.2(8)SA4 (Enterprise Edition)

11.2(8)SA5 (企业版)

12.0(5)WC(1) 或更高版本

WS-C3512-XL

11.2(8)SA4 (企业版)

11.2(8)SA5 (原始版本)

12.0(5)WC(1) or later

WS-C3524-XL

11.2(8)SA4 (企业版)

11.2(8)SA5 (原始版本)

12.0(5)WC(1) 或更高版本

WS-C3548-XL

12.0(5)XP (企业版)

12.0(5)XP (企业版)

12.0(5)WC(1) 或更高版本

WS-C3524-PWR-XL

12.0(5)XU

12.0(5)XU

12.0(5)WC(1) 或更高版本

WS-C3524-PWR-XL

12.0(5)XU

12.0(5)XU

12.0(5)WC(1) 或更高版本

WS-C2950-12

不支持ISL

12.0(5)WC(1)

802.1Q 要求12.0(5)WC(1)或更高版本,不支持ISL

WS-C2950-24

不支持ISL

12.0(5)WC(1)

802.1Q 要求12.0(5)WC(1)或更高版本,不支持ISL

WS-C2950C-24

不支持ISL

12.0(5)WC(1)

802.1Q要求12.0(5)WC(1)或更高版本,不支持ISL

WS-C2950T-24

不支持ISL

12.0(5)WC(1)

802.1Q要求12.0(5)WC(1)或更高版本,不支持ISL

注意:?/B>在上表中,只有WS-C2916M-XL是4MB DRAM交换机。所列的所有其他交换机均为8MB DRAM 交换机。若要确定您的交换机的DRAM4为MB还是8 MB,请输入用户级 show version 命令。 有关更多信息,请参阅: 使用命令行界面(CLI)升级Catalyst 2900-XL/3500-XL 交换机软件 (CLI)一文的"如何通过命令行界面确定交换机内存容量"部分。

[page]

对于 Catalyst 4000, 5000, 6000 交换机:

*

Catalyst 4000系列(包括Catalyst 2948G和Catalyst 2980G)只支持802.1q中继,而不支持ISL中继。
*

Catalyst 6000系列交换机上的任何以太网端口支持802.1q或ISL封装。
*

具有中继能力的Catalyst 5000端口根据模块的不同只支持ISL封装或ISL和802.1q中的任意一个。检查这一项的最佳办法是使用 show port capabilities 命令;中继容量是明确规定的,例如:

cat5509 show port capabilities 3
Model WS-X5234
Port 3/1
Type 10/100BaseTX
Speed auto,10,100
Duplex half,full
Trunk encap type 802.1Q,ISL

!-- 该端口支持802.1Q 和ISL.

Trunk mode on,off,desirable,auto,nonegotiate
Channel 3/1-2,3/1-4
Broadcast suppression percentage(0-100)
Flow control receive-(off,on),send-(off,on)
Security yes
Membership static,dynamic
Fast start yes
QOS scheduling rx-(none),tx-(1q4t)
CoS rewrite yes
ToS rewrite IP-Precedence
Rewrite yes
UDLD yes
AuxiliaryVlan 1..1000,untagged,dot1p,none
SPAN source,destination

*

确保整个中继链路范围内的中继模式匹配。若链路的一端配置为ISL中继,则链路的另一端也应配置为ISL;同样,若链路的一端配置为802.1q,则链路的另一端也要配置为802.1q。

配置

本节说明如何配置本文描述的各种特性。

注意:?/B>若要了解有关本文中所使用命令的更多信息,请使用 Command Lookup 工具。
网络图

本文使用下图所示的网络设置。

43a.gif
配置

以下配置适用于这些交换机:

*

为交换机分配的名称
*

在交换机上设置的口令
*

通过快速以太网链路连接的交换机
*

只为了便于管理而向交换机分配的IP 地址
*

交换机上设置的VLAN 中继协议 (VTP) 模式
*

交换机上添加第二个 VLAN (VLAN 2) ;在这些 VLAN 上添加端口
*

在连接工作站的端口上激活Spanning-tree portfast (生成树 portfast),根据拓扑结构,启用Catalyst 5500 上端口 2/2, 2/3上的Spanning-tree portfast,以及Catalyst 3524XL上端口FastEthernet0/2 和端口FastEthernet0/3 上的Spanning-tree portfast

注意:?/B>下面屏幕内容显示了在3524XL 交换机上输入的命令。命令之间的评语以 blue italics(兰色斜体字) 添加进去的,以解释特定命令和步骤:

Catalyst 3524-XL


!--- 设置特权模式
!--- 和交换机的Telnet口令


switch#configure terminal
Enter configuration commands, one per line..End with CNTL/Z.
switch(config)#hostname 3524xl
3524xl(config)#enable password mysecret
3524xl(config)#line vty 0 4
3524xl(config-line)#login
3524xl(config-line)#password mysecret
3524xl(config-line)#exit
3524xl(config)#no logging console
3524xl(config)#^Z


!--- 为了管理,设置Vlan 1 的IP地址。


3524xl#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
3524xl(config)#int vlan 1
3524xl(config-if)#ip address 10.10.10.2 255.255.255.0
3524xl(config-if)#end


!--- 设置VTP 模式。
!--- 本例中,我们将该模式设置为透明。
!--- 根据您的网络来设置相应的VTP模式。
!--- VTP的详细信息,请参考以下文件:
!--- 在Catalyst 2900XL和3500XL交换机上配置VTP、VLANs和VLAN中继 。


3524xl#vlan database
3524xl(vlan)#vtp transparent
Setting device to VTP TRANSPARENT mode.


!--- 正在添加Vlan 2

3524xl(vlan)#vlan 2
VLAN 2 added:
Name: VLAN0002
3524xl(vlan)#exit
APPLY completed.
Exiting....


!--- 激活快速以太网接口 0/1上的中继.

3524xl#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
3524xl(config)#int fastEthernet 0/1
3524xl(config-if)#switchport mode trunk


!--- 输入isl 或dot1q中继封装。


3524xl(config-if)#switchport trunk encapsulation isl
3524xl(config-if)#switchport trunk encapsulation dot1q


!--- 在2950交换机中不能使用上述两个 switchport 命令。
!--- 2950交换机只支持802.1q封装,使用switchport mode trunk
!--- 命令激活接口上的中继之后,该封装将被自动配置。


!---在dot1q封装中,您需要确保
!--- 本地VLAN与该链路匹配。
!--- 对于3524XL,默认情况下其本地VLAN为1。
!--- 根据网络需要,您可以将
!--- 本地VLAN改成其它的VLAN,
!--- 不过,重要的是您必须在链路的另一端
!--- 相应地更改本地VLAN(本例中是cat5509)。
!--- 如果需要的话,您可以通过使用以下命令来更改本地VLAN:
!--- 3524xl(config-if)#switchport trunk native vlan <vlan ID> .




!--- 支持中继线上的所有VLAN

3524xl(config-if)#switchport trunk allowed vlan all
3524xl(config-if)#exit


!--- 以下这套命令将把FastEthernet 0/2接口 0/2
!--- 分配给vlan 2,并激活接口上的快速端口。


3524xl(config)#int fastEthernet 0/2
3524xl(config-if)#switchport access vlan 2
3524xl(config-if)#spanning-tree portfast
3524xl(config-if)#exit
3524xl(config)#int fastEthernet 0/3
3524xl(config-if)#spanning-tree portfast
3524xl(config-if)#^Z


!-- 在关 如何激活快速端口的详细信息,
!--- 请参考:使用 Portfast 和其它命令来解决工作站启动连接延迟问题
!--- 请记住保存配置
!--- (您不必在CatOS 交换机上保存配置)。


3524xl#write memory
Building configuration...

3524xl#

3524xl#show running-config
Building configuration...

Current configuration:

!
version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname 3524xl
!
no logging console
enable password mysecret
!
!
!
!
!
ip subnet-zero
!
!
!
interface FastEthernet0/1
switchport mode trunk
!

!--- 如果配置的是802.1q,
!--- 那么您将在FastEthernet0/1接口上
!--- 看到以下输出:
!--- interface FastEthernet0/1
!--- switchport trunk encapsulation dot1q
!--- switchport mode trunk



!
interface FastEthernet0/2
switchport access vlan 2
spanning-tree portfast
!
interface FastEthernet0/3
spanning-tree portfast
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface VLAN1
ip address 10.10.10.2 255.255.255.0
no ip directed-broadcast
no ip route-cache
!
!
line con 0
transport input none
stopbits 1
line vty 0 4
password mysecret
login
line vty 5 15
login
!
end

注意:?/B>以下屏幕内容显示了在5500交换机上输入的命令。为了说明某些命令和步骤,在命令之间用兰色斜体字添加了评语。

Catalyst 5500


!--- 设置交换机的系统名称和口令。

Console> (enable) set system name cat5509
System name set.
cat5509> (enable) set password
Enter old password:
Enter new password:
Retype new password:
Password changed.
cat5509> (enable) set enablepass
Enter old password:
Enter new password:
Retype new password:
Password changed.


!--- 给交换机分配IP地址。


cat5509> (enable) set int sc0 10.10.10.3/24
Interface sc0 IP address and netmask set.


!--- 设置VTP 模式。
!--- 在本例中,
!--- 我们将VTP模式设置为透明;
!--- 根据您的网络,
!--- 设置相应的VTP模式。


cat5509> (enable) set vtp mode transparent
VTP domain modified


!--- 有关VTP的详细信息,请参考以下文件:
!--- 在Catalyst 4000、 5000交换机上配置VLAN中继
!--- 添加Vlan 2,并给它分配端口。


cat5509> (enable) set vlan 2 3/2
Vlan 2 configuration successful
VLAN 2 modified.
VLAN 1 modified.
VLAN Mod/Ports
---- -----------------------
2 3/2


!--- 在连接到工作站的端口上激活快速端口。


cat5509> (enable) set spantree portfast 3/2 enable

warning

警告:?/B>应只在与单一主机相连的端口上激活
Spantree port fast start (Spantree端口快速启动)功能。
将集线器、集中器、交换机、网桥等与快速启动端口相连可引起暂时性的生成树环路,
因此要谨慎使用。

Spantree port 3/2 fast start enabled.
cat5509> (enable) set spantree portfast 3/3 enable

warning 警告:?/B>只应在与单一主机相连的端口上激活Spantree port fast start
(Spantree端口快速启动)功能。将集线器、集中器、交换机、
网桥等与快速启动端口相连可引起暂时性的生成树环路,因此要谨慎使用。

Spantree port 3/3 fast start enabled.



!--- 如何激活快速端口的详细信息,请参考以下文件:
!--- 使用 Portfast 和其它命令来解决工作站启动连接延迟问题

!--- 将中继封装设置为ISL或 802.1q。


cat5509> (enable) set trunk 3/1 nonegotiate isl
Port(s) 3/1 trunk mode set to nonegotiate.
Port(s) 3/1 trunk type set to Isl.
cat5509> (enable)


!--- 如果您想要配置802.1q中继,
!--- 则键入以下命令:


cat5509> (enable) set trunk 3/1 nonegotiate dot1q



!--- 在dot1q中,您需要确保
!--- 本地VLAN与该链路匹配。
!--- 对于cat5500,默认情况下其本地VLAN为1。
!--- 根据网络需要,您可以将
!--- 本地VLAN改成其它的VLAN,
!--- 不过,重要的是您必须在链路的另一端
!--- 相应地更改本地VLAN(本例中是3524xl)。
!--- 如果需要地话,您可以通过使用以下命令来更改本地VLAN:
!--- cat5509> (enable) set vlan <vlan ID> <mod/port>
!--- 这里 是新的本地Vlan , 是中继端口;本例是3/1。

注意:?/B>Catalyst 2900XL/3500XL 交换机目前不支持动态中继协议 (DTP)。
因此,我们建议在中继链路的 other(另一端) 使用 nonegotiate 选项,
如上面Catalyst 4000、5000 和 6000 交换机上的配置一样。
这样,XL 交换机端口就不会接收不熟悉的 DTP 帧。有关 DTP modes 的详细信息,
请参阅 DTP modes, refer to the DTP Modes sections of
使用802.1q 封装的Catalyst 4000、5000 和 6000 系列交换机间中继的DTP 模式。

cat5509> (enable) show config
This command shows non-default configurations only.
Use show config all to show both default and non-default
configurations.
........


..................

..

begin
!
# ***** NON-DEFAULT CONFIGURATION *****
!
!
#time: Sun Nov 26 2000, 18:19:45
!
#version 5.5(3)
!
set enablepass $2$FNl3$8MSzcpVMg1H2aWfll13aZ.
!
#system
set system name cat5509
!
#frame distribution method
set port channel all distribution mac both
!
#vtp
set vtp mode transparent
set vlan 1 name default type ethernet mtu 1500 said 100001 state active
set vlan 2 name VLAN0002 type ethernet mtu 1500 said 100002 state active
set vlan 1002 name fddi-default type fddi mtu 1500 said 101002 state active
set vlan 1004 name fddinet-default type fddinet mtu 1500 said 101004 state active stp ieee
set vlan 1005 name trnet-default type trbrf mtu 1500 said 101005 state active stp ibm
set vlan 1003 name token-ring-default type trcrf mtu 1500 said 101003 state acti
ve mode srb aremaxhop 7 stemaxhop 7 backupcrf off
!
#ip
set interface sc0 1 10.10.10.3/255.255.255.0 10.10.10.255

!
#set boot command
set boot config-register 0x2
set boot system flash bootflash:cat5000-sup3.5-5-2.bin
set boot system flash bootflash:cat5000-sup3.5-5-3.bin
!
#mls
set mls nde disable
!
# default port status is enable
!
!
#module 1 : 4-port 10/100BaseTX Supervisor
!
#module 2 : 3-port 1000BaseX Ethernet
!
#module 3 : 24-port 10/100BaseTX Ethernet
set vlan 2 3/2
set trunk 3/1 nonegotiate isl 1-1005


!--- 如果配置的是dot1q中继,
!--- 那么上一行将显示为:
!--- set trunk 3/1 nonegotiate dot1q 1-1005


set spantree portfast 3/2-3 enable
!
#module 4 empty
!
#module 5 empty
!
#module 6 : 24-port 10BaseF Ethernet
!
#module 7 empty
!
#module 8 : 24-port 10/100BaseTX Ethernet
!
#module 9 empty
end
cat5509> (enable)

[page]
检验
debug 和show 命令

本节所提供的信息可用于确认您的配置是否能正常运行。

Output Interpreter(输出翻译器)工具支持某些 show c命令,您可以通过这些工具查看 show 命令输出的分析信息。

在 Catalyst 2900XL/3500XL/2950 交换机上:

*

show int {FastEthernet | GigabitEthernet} <module/port> switchport
*

show vlan
*

show vtp status

在 Catalyst 5000 交换机上:

*

show port capabilities <module/port>
*

show port <module/port>
*

show trunk <module/port>
*

show vtp domain

Sample show 命令输出
Catalyst 3500XL 交换机

show int {FastEthernet | GigabitEthernet} <module/port> switchport

此命令用来检查端口的管理和运行状态,还用来保证中继两端的本地VLAN互相匹配。本地VLAN在端口处于802.1q中继模式时用于未标记业务。有关本地VLAN的更多信息请参阅 在Catalyst 2900XL和3500XL交换机上配置VTP、VLAN和VLAN中继。

3524xl#show int fastEthernet 0/1 switchport
Name: Fa0/1
Switchport: Enabled
Administrative mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: isl
Operational Trunking Encapsulation: isl
Negotiation of Trunking: Disabled
Access Mode VLAN: 0 ((Inactive))
Trunking Native Mode VLAN: 1 (default)
Trunking VLANs Enabled: ALL
Trunking VLANs Active: 1,2
Pruning VLANs Enabled: 2-1001

Priority for untagged frames: 0
Override vlan tag priority: FALSE
Voice VLAN: none
Appliance trust: none

注意:?/B>对于 802.1q 中继,上述命令的输出变化如下:

3524xl#show int fastEthernet 0/1 switchport
Name: Fa0/1
Switchport: Enabled
Administrative mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: Disabled
Access Mode VLAN: 0 ((Inactive))
Trunking Native Mode VLAN: 1 (default)
Trunking VLANs Enabled: ALL
Trunking VLANs Active: 1,2
Pruning VLANs Enabled: 2-1001

Priority for untagged frames: 0
Override vlan tag priority: FALSE
Voice VLAN: none

show vlan

此命令用于验证接口(端口)是否属于正确的VLAN。在该例中,只有接口Fa0/2属于VLAN 2,而其他接口属于VLAN 1。
3524xl#show vlan
VLAN Name Status Ports
---- ------------------------ --------- -------------------------------
1 default active Fa0/3, Fa0/4, Fa0/5, Fa0/6,
Fa0/7, Fa0/8, Fa0/9, Fa0/10,
Fa0/11, Fa0/12, Fa0/13,Fa0/14,
Fa0/15, Fa0/16, Fa0/17,Fa0/18,
Fa0/19, Fa0/20, Fa0/21,Fa0/22,
Fa0/23, Fa0/24, Gi0/1, Gi0/2
2 VLAN0002 active Fa0/2
1002 fddi-default active
1003 token-ring-default active
1004 fddinet-default active
1005 trnet-default active

...(output suppressed)

show vtp status

此命令用于验证交换机上的VTP配置。在该例中使用了 transparent mode。 正确的VTP模式取决于网络拓扑结构。有关VTP的详细信息,请参阅 在Catalyst 2900XL和3500XL交换机上配置VTP、VLAN和VLAN中继。
3524xl#show vtp status
VTP Version : 2
Configuration Revision : 0
Maximum VLANs supported locally : 254
Number of existing VLANs : 6
VTP Operating Mode : Transparent
VTP Domain Name :
VTP Pruning Mode : Disabled
VTP V2 Mode : Disabled
VTP Traps Generation : Disabled
MD5 digest : 0x74 0x79 0xD3 0x08 0xC0 0x82 0x68 0x63
Configuration last modified by 10.10.10.2 at 3-1-93 00:05:30
CatOS 交换机

show port capabilities <module/port>

此命令用于验证端口是否具有中继功能:
cat5509 show port capabilities 3/1
Model WS-X5234
Port 3/1
Type 10/100BaseTX
Speed auto,10,100
Duplex half,full
Trunk encap type 802.1Q,ISL
Trunk mode on,off,desirable,auto,nonegotiate
Channel 3/1-2,3/1-4
Broadcast suppression percentage(0-100)
Flow control receive-(off,on),send-(off,on)
Security yes
Membership static,dynamic
Fast start yes
QOS scheduling rx-(none),TX(1q4t)
COs rewrite yes
ToS rewrite IP-Precedence
Rewrite yes
UDLD yes
AuxiliaryVlan 1..1000,untagged,dot1p,none
SPAN source,destination

show port <module/port>
cat5509> (enable) show port 3/1

Port Name Status Vlan Level Duplex Speed Type
----- ----------- ---------- -------- ------ ------ ----- ----------
3/1 connected trunk normal a-full a-100 10/100BaseTX

Port AuxiliaryVlan AuxVlan-Status
----- ------------- --------------
3/1 none none


Port Security Violation Shutdown-Time Age-Time Max-Addr Trap IfIndex
----- -------- --------- ------------ -------- -------- -------- -------
3/1 disabled shutdown 0 0 1 disabled 12

Port Num-Addr Secure-Src-Addr Age-Left Last-Src-Addr Shutdown/Time-Left
----- -------- ----------- -------- ----------------- ------------------
3/1 0 - - - - -

...(output suppressed)

show trunk <module/port>

此命令用于验证中继状态和配置。
cat5509> (enable) show trunk
* - indicates vtp domain mismatch
Port Mode Encapsulation Status Native vlan
-------- ----------- ------------- ------------ -----------
3/1 nonegotiate isl trunking 1

Port Vlans allowed on trunk
-------- -----------------------------------------------------------
3/1 1-1005

Port Vlans allowed and active in management domain
-------- ----------------------------------------------------------
3/1 1-2

Port Vlans in spanning tree forwarding state and not pruned
-------- -----------------------------------------------------------
3/1 1-2

注意:?/B>对于802.1q中继,上述命令的输出变化如下:
cat5509> (enable) show trunk
* - indicates vtp domain mismatch
Port Mode Encapsulation Status Native vlan
-------- ----------- ------------- ------------ -----------
3/1 nonegotiate dot1q trunking 1

Port Vlans allowed on trunk
-------- ---------------------------------------------------------
3/1 1-1005

Port Vlans allowed and active in management domain
-------- ----------------------------------------------------------
3/1 1-2

Port Vlans in spanning tree forwarding state and not pruned
-------- ----------------------------------------------------------
3/1 1-2

show vtp domain
cat5509> (enable) show vtp domain
DomainName Domain Index VTP Version Local Mode Password
----------------------- ------------ ----------- ----------- ----------
1 2 Transparent -

Vlan-count Max-vlan-storage Config Revision Notifications
---------- ---------------- --------------- -------------
6 1023 0 disabled

Last Updater V2 Mode Pruning PruneEligible on Vlans
--------------- -------- -------- -------------------------
10.10.10.3 disabled disabled 2-1000

--------------------------------------------------------------------------------

相关文章
Cisco交换机链路聚合实例 2013/6/21 19:13:17
cisco交换机 端口速率限制实现实例 2013/6/21 19:11:57
Cisco交换机 DHCP Snooping功能 2013/4/27 10:42:57
Cisco 交换机与路由器故障处理方法分享 2013/4/27 10:41:58
Memcached 安装 2013/3/15 16:46:46
Web安全工具大汇聚 2012/3/20 9:27:50
inotify监控Linux文件系统的必备利器 2011/10/23 13:10:58
如何创建一个用于网络监控的网络性能基线 2011/9/19 15:45:13
如何预防由VMware驱动和后门程序导致的系统故障 2010/7/23 9:13:12
Cisco设备光模块解密方法 2010/5/20 9:57:00
光纤交换机密码重置 2010/5/19 15:20:46
思科Private VLAN与Switchport Protected 2010/3/17 12:30:45
BIOS自检与开机故障 2010/3/16 8:54:50
思科Private VLAN与Switchport Protected 2009/12/16 13:09:44
VMware ESX Server下的一些命令 2009/8/17 14:33:08
Cisco交换机端口ipmac绑定 2009/7/28 12:59:09
华为及H3C低端交换机MAC绑定 2008/7/16 8:18:59
Cisco(思科)路由器上如何防止DDoS 2008/6/7 11:24:30
cisco ASA防火墙配置笔记 2008/6/7 11:22:48
理解 DNS 2008/5/11 17:54:47
通过设置Cisco路由器D.D.O.S攻击手段的细节 2008/1/10 17:49:44
Cisco 2621 端口限速配置实例 2008/1/10 17:47:51
Cisco路由器上防止分布式拒绝服务(DDoS) 2008/1/10 9:07:50
基于ARP欺骗的TCP伪连接D.o.S 2008/1/10 8:49:43
NAC网络准入--整个初始化过程 2008/1/9 9:14:11
交换机出现err-disable的原因及解决方法 2007/11/19 13:42:35
路由技术 利用路由器防止DoS疯狂攻击 2007/11/19 13:36:33
路由器中的内存分类 2007/9/18 14:04:26
Cisco3550实现MAC和交换机端口绑定 2007/9/18 14:02:32
路由技术如何利用路由器防DoS疯狂攻击 2007/9/18 14:02:03
Cisco Switching Mode Discussion(五种交换模式辨析) 2007/8/30 10:43:57
Cisco的MAC地址与IP绑定 2007/7/19 8:46:45
交换机出现err-disable原因及解决方法 2007/6/20 17:16:56
Linux 2.6.19.x 内核编译配置选项简介 2007/5/29 7:55:59
Cisco路由器如何防止DDoS攻击 2007/5/10 14:47:23
Cisco IOS Cookbook 中文精简版第二十七章安全 2007/5/9 10:09:28
Cisco IOS Cookbook 中文精简版第二十六章MPLS 2007/5/9 9:54:50
Cisco IOS Cookbook 中文精简版第二十四章移动IP 2007/4/3 9:02:55
Cisco IOS Cookbook 中文精简版第二十三章 IP组播 2007/4/2 10:09:08
Cisco IOS Cookbook 中文精简版第十六章路由器接口 2007/4/2 9:21:05
Cisco IOS Cookbook 中文精简版第十三章拨号备份 2007/3/28 9:07:17
Cisco IOS Cookbook 中文精简版第十一章队列和拥塞 2007/3/28 9:05:25
Cisco IOS Cookbook 中文精简版第十章 帧中继 2007/3/28 9:02:55
Cisco IOS Cookbook 中文精简版第八章OSPF 2007/3/28 9:00:40
NE40/NE80在VRP3.10上的防病毒控制列表 2007/3/22 13:46:57
Catalsty 4908G-L3 VLAN间的路由和桥接 2007/3/14 8:55:01
华为各种型号交换机端口镜像配置方法 2007/3/7 12:38:04
Cisco 3550速率限制的详细配置过程 2007/1/24 8:46:39
Catalyst 2950-实现端口与IP绑定典型配置 2007/1/24 8:45:22
VLAN之间ACL和VACL的区别 2007/1/24 8:43:59
加速cisco交换机初始化过程 2006/12/27 9:20:45
Cisco交换机接口模式精解 2006/12/25 9:47:10
mpls vpn故障排除 2006/12/11 10:57:08
Cisco交换机接口模式精解 2006/12/11 10:55:30
镜像端口建立方法 2006/12/11 10:54:50
交换网络中的嗅探和ARP欺骗 2006/12/4 16:48:30
关于IP-MAC地址绑定的交换机设置 2006/11/28 9:19:13
对目标进行ARP欺骗 2006/11/27 15:04:33
论广播风暴的成因、预防及排障 2006/11/14 8:23:37
Cisco IOS防火墙的安全规则和配置方案 2006/10/28 10:07:06
交换机出现err-disable的原因及解决方法 2006/10/28 10:00:22
冲突域、广播域的通俗讲解 2006/10/28 9:57:41
Catalyst 4006交换机的配置实例 2006/10/28 9:56:03
关于IP-MAC地址绑定的交换机设置 2006/10/28 9:52:06
抵御DDoS攻击 2006/10/28 9:46:05
PVLAN技术应用 2006/10/25 14:10:37
Alteon WebSwitch 的口令恢复 2006/9/14 8:35:56
MAC地址的访问控制 2006/9/13 19:28:58
VRF Selection using by source ip 2006/9/13 19:25:53
交换机接口出现err-disable的几个常见原因 2006/9/13 19:17:58
7200路由模拟器使用手册 2006/8/20 19:58:24
配置思科三层交换的综合案例 2006/8/9 17:07:03
Catalyst 4006交换机的配置实例 2006/8/9 17:01:46
PVLAN技术应用,网络管理员的新宠 2006/8/8 19:01:16
8016DHCP配置 2006/8/4 7:17:15
NAT+DHCP+HSRP+ACL+NTP配置实例 2006/8/4 7:02:10
解决在DHCP环境下私自指定IP和私自搭建DHCP服务器的方法 2006/8/4 7:00:32
Cisco实战:配置三层交换的综合案例 2006/8/2 14:30:15
网络故障处理手册 2006/7/25 14:09:43
华为交换机交换机端口镜像配置 2006/7/25 14:05:43
设置交换机span以进行侦听 2006/7/22 17:24:20
Cisco配置手记 2006/7/17 10:08:27
关于IP-MAC绑定的交换机设置 2006/7/14 9:41:11
Alteon WebSwitch 的口令恢复 2006/7/11 14:46:12
Cisco交换机POST过程排错 2006/7/4 19:51:10
交换机 VLAN配置基础及实例 2006/7/4 19:48:33
路由器默认密码 2006/6/28 23:05:49
路由器交换机配置信息及口令的清除 2006/6/28 23:01:47
网线的制作与连接 2006/6/26 11:05:54
用snort和空IP做一个安全的log纪录服务器 2006/6/17 11:09:10
Linux下软件RAID的实现 2006/6/14 19:20:39
关于IP-MAC地址绑定的交换机设置 2006/6/13 8:42:28
工作中处理交换机频繁吊死故障实例 2006/6/13 8:41:14
在Cisco交换机上实现隔离访问 2006/6/13 8:36:02
第1章 MPLS简介 2006/6/3 12:45:55
MPLS VPN 路由器与交换机选购指南 2006/5/30 14:27:52
核心 MPLS IP VPN 体系结构 2006/5/30 14:04:49
NetFlow交换及其在网络管理中的应用 2006/5/28 17:22:00
SysAdmin Commands 2006/5/25 16:06:54
网络安全讲座之七:IDS系统 2006/5/24 19:45:52
网络专业人士笔记 2006/5/22 10:06:48
用Cisco产品和功能构建安全的网络 2006/5/10 10:37:05
vlan间dhcp配置 2006/5/10 10:35:15
三层MPLS VPN及其故障处理 2006/5/8 19:45:11
在Cisco设备上实现IOS DHCP Server的功能 2006/4/30 12:31:15
MPLS经典问题:利用MPLS解决和避免bgp路由黑洞问题 2006/4/26 17:21:23
LAN多层交换技术以及其应用的发展 2006/4/9 14:05:16
如何利用负载均衡来提升网络性能 2006/4/6 19:57:30
LAN多层交换技术以及其应用的发展 2006/4/4 23:14:16
利用MPLS解决和避免bgp路由黑洞问题 2006/3/30 22:17:03
关于IP-MAC地址绑定的交换机设 2006/3/30 22:12:32
基于MPLS的流量工程要求(RFC2702) 2006/3/30 21:57:05
核心 MPLS IP VPN 体系结构(RFC2917) 2006/3/30 21:56:34
MPLS标记栈编码(RFC3032) 2006/3/30 21:54:27
IP VPN的框架体系(RFC2764) 2006/3/30 21:52:32
BGP MPLS VPNs(RFC2547) 2006/3/30 21:50:22
典型局域网多VLAN配置实例 2006/3/28 13:12:03
在Cisco交换机上实现隔离访问 2006/3/20 12:55:26
配置三层交换的综合事例 2006/3/6 8:36:39
常用品牌交换机端口镜像(Port Mirroring)配置 2006/2/23 14:08:02
Cisco设备做流量监控得方法 2006/2/23 14:06:53
Catalyst3550的三层交换与VLAN 2006/2/14 15:24:44
Cisco产品采用的网络协议总结 2006/1/12 14:15:24
Cisco Catalyst 2950 配置-实现端口与IP的绑定 2006/1/9 8:56:17
用Cisco产品和功能构建安全的网络 2006/1/4 13:46:58
Cisco Catalyst 2950 配置-实现端口与IP的绑定 2005/12/25 14:51:46
关于IP-MAC绑定的交换机设置 2005/12/13 14:48:09
Cisco IOS命名规则 2005/11/26 20:11:25
Configuring Dynamic VLANs 2005/11/24 14:05:15
Catalyst5500交换机 VLAN设置 2005/11/24 10:25:33
《网络基础学习之十八》主要路由器技术 2005/11/11 10:00:42
《网络基础学习之十五》交换机VLAN的配置 2005/11/11 9:57:10
《网络基础学习之十四》交换机配置全接触 2005/11/11 9:56:00
《网络基础学习之十一》走近交换机 2005/11/11 9:51:45
《网络基础学习之三》认识网线制作工具 2005/11/11 9:39:24
《网络基础学习之一》计算机网络分类 2005/11/11 9:35:48
Sniff网络基础原理和软件实现技巧详解 2005/11/5 21:15:12
2900XL VLAN config 2005/11/5 20:51:25
交换机ACL配置实战 2005/11/4 11:18:08
以太网络建立多个VLAN典型案例 2005/11/3 14:32:24
Cisco ios 软件的安装升级方法 2005/9/20 14:09:04
内存技术术语不完全手册 2005/9/5 16:35:54
ARP地址解析协议详解及其漏洞分析 2005/8/19 8:29:37
思科认证的36个热门考点 2005/8/11 14:16:05
CISCO交换机的数据监控 2005/8/4 13:00:36
Cisco交换机实现端口安全的方法及事项 2005/8/4 12:54:23
Cisco路由器的备份配置方法 2005/8/4 12:53:32
在思科交换机上防范典型的欺骗和二层攻击 2005/8/4 12:50:32
How to Determine Which Switch and Port You are Connected To 2005/7/28 8:34:13
2005年网络工程师考试题目预测(1) 2005/7/6 20:54:53
2005年网络工程师考试题目预测(2) 2005/7/6 20:53:26
CCNP-CIT中文笔记 完整版 2005/6/24 15:31:49
交换机(Switch)工作原理 2005/6/22 7:57:16
网络流量监控器mrtg全攻略 2005/6/17 15:03:36
流量检测的几种方案 2005/6/17 14:59:54
冲突域,冲突,广播域,广播 2005/6/17 14:56:27
教你识别思科交换机型号 2005/6/11 21:49:53
交换机的种类 2004/11/9 14:19:33
CCNA考试命令集 2004/11/9 10:47:49
Cisco常见配置 2004/11/9 10:04:39
各种交换机的镜像配置(cicsoc、华为、3com、Avaya、Intel) 2004/11/9 9:55:40
POST自检测代码含义 2004/10/21 8:53:10
内存介绍 2004/10/21 8:52:01
系统安全名词列表(1) 2004/10/8 9:38:02
配置三层交换的综合范例 2004/9/1 11:20:39
怎样在Cisco设备上实现IOS DHCP Server的功能 2004/9/1 11:19:27
HTTP 1.1状态代码 2004/9/1 10:20:46
常见的CatcOs错误消息在Cisco Catalyst 交换机 2004/8/29 12:29:00
配置和排除以太网10/100/1000Mb Half/Full双工自动协商故障 2004/8/29 12:23:23
CISCO的快速转发 2004/8/29 12:19:05
4000 6500交换引擎配置注解 2004/8/29 12:05:09
29&3548配置注解 2004/8/29 12:03:32
29&3548配置方法 2004/8/29 12:02:51
网络流量监控器mrtg全攻略 2004/8/21 10:14:35
网络设备中常见术语含义及故障分析 2004/8/21 9:50:16
CISCO交换机的数据监控 2004/8/19 15:07:34
深入浅出了解交换机是怎么工作的 2004/8/16 8:21:07
Cisco 路由配置语句汇总 2004/8/10 12:26:42
CCNA专业词汇全集 2004/8/10 7:50:25
开机,没反应,这时慌了,你不防看上一下这篇文章 2004/7/29 17:52:51
NAT的原理及其注意事项 2004/7/23 10:19:21
CIT中文笔记 2004/7/15 11:52:42
三层MPLS VPN及其故障处理 2004/7/1 13:08:35
第四层交换 2004/6/18 8:07:38
理解接口类型 2004/6/10 16:50:57
cisco 未公开的命令 2004/6/7 8:00:17
华为的产品分类 2004/6/7 7:57:52
路由器原理及常用的路由协议、路由算法 2004/6/2 15:05:54
根据IP查端口 2004/6/1 8:50:32
常用网络缩略语 2004/5/27 14:07:37
CISCO部分命令全集 2004/5/27 14:03:51
Linux一句话精彩问答-网络无关篇 2004/5/26 13:43:14
Top Ten Tips for Secure Testing 2004/5/13 7:59:22
使用路由器作流量检测的几个手段 2004/4/9 13:17:44
Ghost V8.0 使用详解 2004/3/30 14:52:47
CCIE之建立详细的故障检测检查表 2004/2/26 8:59:12
网络端口及其详解分页 2004/2/17 9:03:12
在接入服务器上使用Cisco IOS DHCP服务器 2004/2/4 8:31:10
如何升级软件 图像在Catalyst 交换机第三层模块 2004/2/4 8:27:28
U盘上的LINUX 2004/1/29 11:49:46
安全的log纪录服务器 2004/1/24 19:17:43
c3550配置作为dhcp服务器工程实例 2003/12/27 20:52:25
cisco3640路由器设置(祥) 2003/12/27 20:43:07
网桥与路由器的区别 2003/12/20 23:32:06
交换机性价比基准测试 2003/12/20 23:23:14
CCNP课堂---交换(Switch)篇 2003/12/2 10:45:32
switch命令大全 2003/11/25 9:06:50
Symantec.Ghost.8.0企业版使用全攻略 2003/11/4 8:57:43
SQL病毒CISCO完全解决方案 2003/11/3 8:43:44
通过设置Cisco路由器防止分布式D.O.S攻击手段的细节 2003/10/30 16:56:20
linux经典问题==基础篇 2003/10/30 11:19:02
LINUX 常见问题1000个详细解答 2003/10/29 14:13:25
CatOS下定义VLAN 2003/10/23 14:54:21
Switching 命令大全 2003/10/13 17:59:51
Window 服务全功略 2003/10/10 12:09:28
关于路由器cpu利用率过高的解决 2003/9/9 10:43:07
华为s系列手册(连载6) 2003/9/8 16:45:07
华为s系列手册(连载5) 2003/9/8 16:37:32
华为s系列手册(连载4) 2003/9/8 16:17:08
华为s系列手册(连载3) 2003/9/8 16:15:55
华为s系列手册(连载2) 2003/9/8 16:15:07
华为s系列手册(连载1) 2003/9/8 16:07:14
CISCO 技术大集合 2003/9/8 7:46:34
贴一个外资银行的路由器配置 2003/9/8 7:41:37
常见端口表汇总 2003/9/1 10:31:24
20%的SOLARIS知识解决80%的问题 2003/8/29 15:16:51
新版CCNA 640-801考试IOS命令大全(ZT) 2003/8/27 17:39:13
Catalyst5500交换机 VLAN设置 2003/8/26 10:54:04
局域网实现VLAN实例 2003/8/15 10:37:16
Linux系统命令分类详解(1) 2003/8/12 9:22:30
在RedHat下建立群集 2003/8/12 9:13:09
Redhat advance server 2.1集群的安装与管理 2003/8/12 8:21:31
双机热备的全面配置示例 2003/8/6 14:45:05
网络词汇大全 2003/7/31 8:45:22
linux常见问题FAQ 2003/7/30 18:01:57
思科产品常见问题一百问 2003/7/30 14:17:30
系统安全名词列表 2003/7/29 10:27:02
4006交换机(IOS版)简明配置维护手册 2003/7/28 18:02:12
CISCO配置命令大全 2003/7/28 17:58:33
vlan 配置思路 2003/7/28 15:36:02
CISCO交换机概览 2003/7/28 15:14:40
solaris常用命令及简单解释[推荐] 2003/7/19 19:24:27
Solaris 问答集 2003/7/19 19:06:09
如何配置DNS Server(附详细实例) 2003/7/15 8:45:49
[转帖]solaris常用命令及简单解释[推荐] 2003/7/15 8:41:27
安装完系统后需要做的一些事 2003/7/15 8:37:58
系统平台安装操作手册 SUN Fire 280安装配置手册 2003/7/15 8:36:18
网络工程师必懂的专业术语 2003/7/14 16:54:43
网络流量监控器mrtg全攻略 2003/7/14 9:37:34
Installing Oracle 9i R2 (9.2.0.1.0) on Red Hat 9 2003/7/14 8:31:06
Switching 命令大全-转 2003/7/13 19:06:01
[精华手册]CISCO路由器配置手册 2003/7/13 19:01:40
虚拟局域网(VLAN)路由实例 2003/7/13 19:00:04
Cisco IOS 基本命令集 2003/7/13 18:57:34
XX校校园网实现(VLAN及策略路由的实现) 2003/7/13 17:53:32
转载cisco3524的管理vlan配置 2003/7/11 22:16:09
RedHat Linux 8.0基本服务的配置手册 2003/5/25 21:09:24
Linux新手入门教程 2003/5/16 23:18:21
Linux 学习手册--linux命令大全 2003/5/14 10:04:59
Linux 指令大全 2003/5/5 13:29:23
PHP新手上路 2003/4/27 11:50:38
网络技术常用术语汉语对照 2003/3/31 17:34:50
linux命令大全 2003/3/31 10:49:22
自己动手写操作系统(三) 2003/3/25 10:20:23
路由器/交换机/集线器缺省口令 2002/11/9 9:54:21


感性空间
设计&运维
网络技术
休闲娱乐
NetFilter
linux&Unix
网络安全
程序空间
软件考试
RFC&ISO
规划&规范
虚拟&存储
Apple技巧
云计算&大数据



文章搜索



站内搜索