所属分类: 网络技术 整理: FengNet.Com 更新日期:2003/7/28 18:02:12 阅读次数:13664

4006交换机(IOS版)简明配置维护手册



目录
说明 3
产品特性 3
配置端口 5
配置一组端口 5
配置二层端口 7
配置端口速率及双工模式 8
端口描述 8
配置三层口 10
监控及维护端口 12
监控端口和控制器的状态 12
刷新、重置端口及计数器 13
关闭和打开端口 14
配置VLAN 15
理解VLAN 15
可支持的VLAN 15
配置正常范围的VLAN 16
生成、修改以太网VLAN 16
删除VLAN 18
将端口分配给一个VLAN 18
配置VLAN Trunks 19
使用STP实现负载均衡 22
配置EtherChannel 27
三层以太通道配置 27
三层物理端口配置 28
二层以太通道配置 29
配置以太通道负载均衡 31
配置SPAN 32
理解SPAN 32
SPAN会话 32
目标端口 33
源端口 33
流量类型 33
基于VLAN的SPAN 33
SPAN流量 34
配置SPAN 34
指定源 34
指定目标 35
监视一个trunk接口上的源VLAN 35


说明
本手册只包括日常使用的有关命令及特性,其它未涉及的命令及特性请参考英文的详细配置手册。
产品特性
Cisco Catalyst 4006 Supervisor Engine III将非阻塞的第2/3/4层交换与增强的控制结合在一起,从而让企业和城域以太网用户在部署基于互联网的应用时具有业务灵活性。作为Cisco AVVID(融合语音、视频和集成数据的网络体系架构)的一个关键性组件,Cisco Catalyst 4000利用智能化的网络服务,将控制从网络骨干扩展到了网络边缘,这些服务包括先进的服务质量(QoS)、可扩展的性能、全面的安全性和简便的管理功能。
第2层特性
· 第2层硬件数据包转发率可达48Mpps
· 第2层交换端口和VLAN中继
· IEEE 802.1Q VLAN封装
· ISL VLAN封装(不包括 WS-X4418-GB 和WS-X4412-2GB-T 中的阻塞端口)
· 动态中继协议(DTP)
· VLAN中继协议(VTP)和VTP域
· 每个交换机支持4096个VLAN(将来的软件版本)
· 每个VLAN的生成树(PVST)和PVST+
· STP PortFast和PortFast防护措施
· STP UplinkFast和BackboneFast
· STP根段防护措施
· Cisco搜索协议
· IGMP侦听v1和v2
· 在线路卡中集成Cisco以太通道、快速以太通道、千兆位以太通道技术
· 端口集中协议(PAgP)
· 单向链路检测(UDLD)和主动型UDLD
第3层特性
· IP Cisco快速传送(CEF)路由速度可达48Mpps
· 静态IP路由
· IP路由协议(内部网关路由协议[IGRP]、增强型IGRP[EIGRP]、开放式最短路径优先[OSPF]、路由信息协议[RIP]、RIP2)
· 边界网关协议[BGP4]和多播边界网关协议[MBGP]
· 热待机路由协议(HSRP)
· IGMP v1、v2和v3
· IP多播路由协议(距离向量多播路由协议[DVMRP]、PIM、SSM)
· 多播源发现协议(MSDP)
· Cisco群组多播协议(CGMP)服务器
· 完全支持互联网控制消息协议(ICMP)
· ICMP路由器发现协议
先进的服务质量和成熟流量管理
· 针对每个端口的QoS配置
· 硬件上支持每个端口四个队列
· 严格优先级排序
· IP DSCP和IP 优先权
· 基于IP服务类型(ToS)或者DSCP进行分类和标记
· 基于完整的第3/4层报头(只限于IP)进行分类和标记
· 基于完整的第3/4层报头(只限于IP)制定输入和输出策略
· 能够集中或者单独在出口或者入口分别配置1024种监管器
· 整形和共享输出队列管理
· 细微的QoS功能不会影响正常的交换性能
扩展性能
· 64Gbps交换矩阵
· 第2层硬件数据包转发率可达48Mpps
· 第3层IP Cisco 快速转发路由速率可达48Mpps
· 第4层(TCP/UDP)基于硬件的过滤速率可达48Mpps
· 实现先进的第3/4层服务不会造成任何性能上的损失
· 持续以每秒1000台主机的速度进行基于软件的查询
· 支持32768个MAC地址
· 在路由表(由单点播送和多播共享)中支持131072个记录
· 可以扩展到2000个虚拟端口(VLAN端口)
· 利用Cisco千兆位以太通道技术,可以汇聚高达16Gbps的带宽
· 基于硬件的多播管理
· 基于硬件的ACL
简便的可管理性
· 只需一个控制台端口和IP地址,来管理系统中的所有功能
· 软件配置管理,包括本地和远程的存储
· 可选的闪存卡,可以用于存储软件影像,进行备份和方便的软件升级
· 通过CiscoWorks Windows网络管理软件,对每个端口、每个交换机进行管理,为Cisco的路由器、交换机和集线器提供一个统一的管理接口
· SNMP v1、v2和v3检测,提供全面的带内管理功能
· 基于命令行界面(CLI)的管理控制台,提供详细的带外管理
· 远程监控(RMON)软件代理,可以支持四个RMON群组(历史、统计、警报和事件),从而可以增强对流量的管理、监控和分析
· 利用一个Cisco SwitchProbe Analyzer(交换端口分析器[SPAN]端口支持所有九个RMON群组,这个端口可以通过一个单一的网络分析器或者RMON探测器对一个端口、一组端口或者整个交换机进行流量监控)
· 分析支持,包括入口、出口和VLAN SPAN
全面的安全性
· TACACS+和RADIUS,它们可以对交换机进行集中控制,并防止未经授权的用户更改配置
· 在所有端口上的标准和扩展ACL
· 在所有端口上(没有性能损失)采用路由器访问控制列表(RACL)
· 专用VLAN(PVLAN),可以在一个交换机的两个端口之间提供安全性和独立性

指示灯和端口规格
· 系统状态:绿色(正常)/红色(故障)
· 交换机负载利用率:总交换使用率在1%到100%之间
· 控制端口:RJ-45凹式端口
· 重启(交换机隐含保护)
· 管理端口:10/100BASE-TX(RJ-45凹式)数据终端设备(DTE);绿色(工作正常)/橙色(禁用)/关闭(没有连接)
其它功能:
支持以下的GBIC模块:
· 1000BASE-SX GBIC: 光纤最长1804 feet (550 m)
· 1000BASE-LX/LH GBIC: 光纤最长32,808 feet (6 miles or 10 km)
· 1000BASE-ZX GBIC: 光纤最长328,084 feet (62 miles or 100 km)
配置端口
配置一组端口
命令 目的
Step 1 configure terminal 进入配置状态
Step 2 Switch(config)# interface range {vlan vlan_ID - vlan_ID} | {{fastethernet | gigabitethernet } slot/interface - interface} [, {vlan vlan_ID - vlan_ID} {{fastethernet | gigabitethernet } slot/interface - interface}] 进入组配置状态
Step 3 可以使用平时的端口配置命令进行配置
Step 4 end 退回
Step 5 show interfaces [interface-id] 验证配置
Step 6 copy running-config startup-config 保存

当使用interface range命令时有如下的规则:
· 有效的组范围:
o vlan从1 到4094
o fastethernet 槽位/{first port} - {last port}
o gigabitethernet槽位/{first port} - {last port}
· 端口号之间需要加入空格,如:interface range fastethernet 2/1 – 5 是有效的,而interface range fastethernet 2/1-5 是无效的.
· interface range 命令只能配置已经存在的interface vlan
· 所有在同一组的端口必须是相同类别的。
见以下例子:
4006# configure terminal

4006(config)# interface range fastethernet2/1 - 5

4006(config-if-range)# no shutdown
40065(config-if-range)#
*Oct 6 08:24:35: %LINK-3-UPDOWN: Interface FastEthernet2/1, changed state to up
*Oct 6 08:24:35: %LINK-3-UPDOWN: Interface FastEthernet2/2, changed state to up
*Oct 6 08:24:35: %LINK-3-UPDOWN: Interface FastEthernet2/3, changed state to up
*Oct 6 08:24:35: %LINK-3-UPDOWN: Interface FastEthernet2/4, changed state to up
*Oct 6 08:24:35: %LINK-3-UPDOWN: Interface FastEthernet2/5, changed state to up
*Oct 6 08:24:36: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet2/05,
changed state to up
*Oct 6 08:24:36: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet2/3, changed
state to up
*Oct 6 08:24:36: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet2/4, changed
state to up

以下的例子显示使用逗号来配置不同类型端口的组:
4006# configure terminal

4006(config)# interface range fastethernet2/1 – 3, gigabitethernet3/1 - 2

4006(config-if-range)# no shutdown
4006(config-if-range)#
*Oct 6 08:29:28: %LINK-3-UPDOWN: Interface FastEthernet2/1, changed state to up
*Oct 6 08:29:28: %LINK-3-UPDOWN: Interface FastEthernet2/2, changed state to up
*Oct 6 08:29:28: %LINK-3-UPDOWN: Interface FastEthernet2/3, changed state to up
*Oct 6 08:29:28: %LINK-3-UPDOWN: Interface GigabitEthernet3/1, changed state to up
*Oct 6 08:29:28: %LINK-3-UPDOWN: Interface GigabitEthernet3/2, changed state to up
*Oct 6 08:29:29: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/ 1,
changed state to up
*Oct 6 08:29:29: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/ 2,
changed state to up
*Oct 6 08:29:29: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/ 3,
changed state to up

配置二层端口
4006的所有端口缺省的端口都是二层口,如果此端口已经配置成三层端口的话,则需要用switchport来使其成为二层端口。
配置端口速率及双工模式
可以配置快速以太口的速率为10/100Mbps及千兆以太口的速率为10/100/1000 -Mbps; 但对于GBIC端口则不能配置速率及双工模式,有时可以配置nonegotiate, 当需要联接不支持自适应的其它千兆端口时
命令 目的
Step 1 configure terminal 进入配置状态.
Step 2 interface interface-id 进入端口配置状态.
Step 3 speed {10 | 100 | 1000 | auto | nonegotiate} 设置端口速率 注 1000 只工作在千兆口. GBIC模块只工作在1000 Mbps下. nonegotiate 只能在这些GBIC上用 1000BASE-SX, -LX, and -ZX GBIC.
Step 4 duplex {auto | full | half} 设置全双工或半双工.
Step 5 end 退出
Step 6 show interfaces interface-id 显示有关配置情况
Step 7 copy running-config startup-config 保存


Switch# configure terminal

Switch(config)# interface fastethernet2/3

Switch(config-if)# speed 10

Switch(config-if)# duplex half
端口描述

命令 目的
Step 1 configure terminal 进入配置模式
Step 2 interface interface-id 进入要加入描述的端口
Step 3 description string 加入描述 (最多240个字符).
Step 4 end 退回.
Step 5 show interfaces interface-id descriptionorshow running-config 验证.
Step 6 copy running-config startup-config 保存

Use the no description interface configuration command to delete the description.
This example shows how to add a description on Fast Ethernet interface 0/4 and to verify the description:
4006# config terminal

Enter configuration commands, one per line. End with CNTL/Z.
4006(config)# interface fastethernet2/4

4006(config-if)# description Connects to Marketing

4006(config-if)# end

4006# show interfaces fastethernet2/4 description

Interface Status Protocol Description
Fa2/4 up down Connects to Marketing
配置三层口
Catalyst 4006支持三种类型的三层端口:
· SVIs: 即interface vlan

Note 当生成一个interface Vlan时,只有当把某一物理端口分配给它时才能被激活

· 三层以太网通道口(EtherChannel)
· .路由口:路由口是指某一物理端口在端口配置状态下用no switchport命令生成的端口
所有的三层都需要IP地址以实现路由交换
配置步骤如下:
命令 目的
Step 1 configure terminal 进入配置状态
Step 2 interface {{fastethernet | gigabitethernet} interface-id} | {vlan vlan-id} | {port-channel port-channel-number} 进入端口配置状态
Step 3 no switchport 把物理端口变成三层口
Step 4 ip address ip_address subnet_mask 配置IP地址和掩码
Step 5 no shutdown 激活端口
Step 6 end 退出
Step 7 show interfaces [interface-id]show ip interface [interface-id]show running-config interface [interface-id] 验证配置
Step 8 copy running-config startup-config 保存配置

配置举例如下:
4006# configure terminal

Enter configuration commands, one per line. End with CNTL/Z.
4006(config)# interface gigabitethernet3/2

4006(config-if)# no switchport

4006(config-if)# ip address 192.20.135.21 255.255.255.0

4006(config-if)# no shutdown

4006(config-if)# end


show ip interface命令:
4006# show ip interface gigabitethernet3/2

GigabitEthernet3/2 is up, line protocol is up
Internet address is 192.20.135.21/24
Broadcast address is 255.255.255.255
Address determined by setup command
MTU is 1500 bytes
Helper address is not set
Directed broadcast forwarding is disabled

<output truncated>
监控及维护端口
监控端口和控制器的状态
主要命令见下表:
Show Commands for Interfaces Command 目的
show interfaces [type slot/interface] 显示所有端口或某一端口的状态和配置.
show interfaces interface-id status [err-disabled] 显示一系列端口的状态或错误-关闭的状态
show interfaces [interface-id] switchport 显示二层端口的状态,可以用来决定此口是否为二层或三层口。
show interfaces [interface-id] description 显示端口描述
show protocols [type slot/interface] 显示在任何已配置协议下全局和接口的状态
show running-config interface [interface-id] 显示当前配置中的端口配置情况
show version 显示软硬件等情况

举例如下:
Switch#show interfaces status
Port Name Status Vlan Duplex Speed Type
Gi1/1 notconnect 1 auto auto No Gbic
Gi1/2 notconnect 1 auto auto No Gbic
Gi5/1 notconnect 1 auto auto 10/100/1000-TX
Gi5/2 notconnect 1 auto auto 10/100/1000-TX
Gi5/3 notconnect 1 auto auto 10/100/1000-TX
Gi5/4 notconnect 1 auto auto 10/100/1000-TX
Fa6/1 connected 1 a-full a-100 10/100BaseTX
Fa6/2 connected 2 a-full a-100 10/100BaseTX
Fa6/3 notconnect 1 auto auto 10/100BaseTX
Fa6/4 notconnect 1 auto auto 10/100BaseTX
Switch#
This example shows how to display the status of interfaces in error-disabled state:
Switch# show interfaces status err-disabled
Port Name Status Reason
Fa9/4 err-disabled link-flap
informational error message when the timer expires on a cause
--------------------------------------------------------------
5d04h:%PM-SP-4-ERR_RECOVER:Attempting to recover from link-flap err-disable state on Fa9/4
Switch#

Switch# show protocols fastethernet 5/5
FastEthernet5/5 is up, line protocol is up
Switch#

刷新、重置端口及计数器
Clear命令 目的
clear counters {type slot/interface} 清除端口计数器.
clear interface {type slot/interface} 重置某一端口的硬件逻辑
clear line [number | console 0 | vty number] 重置异步串口的硬件逻辑


Note clear counters 命令只清除用show interface所显示的计数,不影响用snmp得到的计数

举例如下:
Switch# clear counters fastethernet 5/5
Clear "show interface" counters on this interface [confirm] y
Switch#
*Sep 30 08:42:55: %CLEAR-5-COUNTERS: Clear counter on interface FastEthernet5/5
by vty1 (171.69.115.10)
Switch#
可使用clear interface 或 clear line 命令来清除或重置某一端口或串口,在大部分情况下并不需要这样做:
Switch# clear interface fastethernet0/5

关闭和打开端口
命令 目的
Step 1 configure terminal 进入配置状态
Step 2 interface {vlan vlan-id} | {{fastethernet | gigabitethernet} slot/port} | {port-channel port-channel-number} 选择要关闭的端口
Step 3 shutdown 关闭
Step 4 end 退出
Step 5 show running-config 验证

使用 no shutdown 命令重新打开端口.
举例如下:
Switch# configure terminal

Switch(config)# interface fastethernet2/5
Switch(config-if)# shutdown
Switch(config-if)#
*Sep 30 08:33:47: %LINK-5-CHANGED: Interface FastEthernet2/5, changed state to a
administratively down

Switch# configure terminal

Switch(config)# interface fastethernet2/5
Switch(config-if)# no shutdown
Switch(config-if)#
*Sep 30 08:36:00: %LINK-3-UPDOWN: Interface FastEthernet2/5, changed state to up

配置VLAN
理解VLAN
一个VLAN就是一个交换网,其逻辑上按功能、项目、应用来分而不必考虑用户的物理位置。任何交换口都可以属于某一VLAN, IP包、广播包及组播包均可以发送或广播给在此VLAN内的最终用户。每一个VLAN均可看成是一个逻辑网络,发往另一VLAN的数据包必须由路由器或网桥转发(如下图)。由于VLAN被看成是一个逻辑网络,其具有自己的网桥管理信息庫 (MIB) 并可支持自己的生成树

VLAN作为逻辑定义的网络示意图


VLAN常常与IP子网相联系,同一IP子网属于同一VLAN。在3550上VLAN之间的数据包可以由VLAN端口进行转发。
可支持的VLAN
Catalyst 4006交换机将来的版本可支持4096个VLAN,可以分别是VTP client, server, 及 transparent modes. VLAN号可以从1到4094. VLAN号1002到1005保留给令牌环及FDDI VLAN. VTP只能学习到普通范围的VLAN, 即从VLAN到1到1005; VLAN号大于1005属于扩展VLAN,不存在VLAN数据庫中。 交换机必须配置成VTP透明模式当需要生成VLAN 号从1006到4094.
本交换机支持基于每一VLAN的生成树(PVST),最多支持128个生成树。本交换机支持ISL及IEEE 802.1Q trunk二种封装。
配置正常范围的VLAN
VLAN号1, 1002到1005是自动生成的不能被去掉。
生成、修改以太网VLAN

命令 目的
Step 1 configure terminal 进入配置状态
Step 2 vlan vlan-id 输入一个VLAN号, 然后进入vlan配置状态,可以输入一个新的VLAN号或旧的来进行修改。
Step 3 name vlan-name (可选)输入一个VLAN名,如果没有配置VLAN名,缺省的名字是VLAN号前面用0填满的4位数,如VLAN0004是VLAN4的缺省名字
Step 4 mtu mtu-size (可选) 改变MTU大小
Step 5 end 退出
Step 6 show vlan {name vlan-name | id vlan-id} 验证
Step 7 copy running-config startup config (可选) 保存配置
用no vlan name 或 no vlan mtu 退回到缺省的vlan配置状态
举例如下:
Switch# configure terminal

Switch(config)# vlan 20

Switch(config-vlan)# name test20

Switch(config-vlan)# end

也可以在enable状态下,进行VLAN配置:
命令 目的
Step 1 vlan database 进入VLAN配置状态
Step 2 vlan vlan-id name vlan-name 加入VLAN号及VLAN名
Step 3 vlan vlan-id mtu mtu-size (可选) 修改MTU大小
Step 4 exit 更新VLAN数据庫并退出
Step 5 show vlan {name vlan-name | id vlan-id} 验证配置
Step 6 copy running-config startup config 保存配置(可选)

举例如下:
Switch# vlan database

Switch(vlan)# vlan 20 name test20

Switch(vlan)# exit

APPLY completed.
Exiting....
Switch#
删除VLAN
当删除一个处于VTP服务器的交换机上删除VLAN时,则此VLAN将在所有相同VTP的交换机上删除。当在透明模式下删除时,只在当前交换机上删除。
注意 当删除一个VLAN时,原来属于此VLAN的端口将处于非激活的状态,直到将其分配给某一VLAN。

命令 目的
Step 1 configure terminal 进入配置状态
Step 2 no vlan vlan-id 删除某一VLAN.
Step 3 end 退出
Step 4 show vlan brief 验证
Step 5 copy running-config startup config 保存

也可用vlan database 进入VLAN配置状态,用no vlan vlan-id 来删除。
将端口分配给一个VLAN

命令 目的
Step 1 configure terminal 进入配置状态
Step 2 interface slot/port 进入要分配的端口
Step 3 switchport mode access 定义二层口
Step 4 switchport access vlan vlan-id 把端口分配给某一VLAN
Step 5 end 退出
Step 6 show running-config interface slot/port 验证端口的VLAN号
Step 7 show interfaces slot/port switchport 验证端口的管理模式和VLAN情况
Step 8 copy running-config startup-config 保存配置

使用 default interface slot/port还原到缺省配置状态。
举例如下:
Switch# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)# interface fastethernet2/1

Switch(config-if)# switchport mode access

Switch(config-if)# switchport access vlan 2

Switch(config-if)# end
Switch#
配置VLAN Trunks

命令 目的
Step 1 configure terminal 进入配置状态
Step 2 interface interface-id 进入端口配置状态
Step 3 switchport trunk encapsulation {isl | dot1q | negotiate} 配置trunk封装ISL 或 802.1Q 或自动协商
Step 4 switchport mode {dynamic {auto | desirable} | trunk} 配置二层trunk模式。· dynamic auto—自动协商是否成为trunk· dynamic desirable—把端口设置为trunk如果对方端口是trunk, desirable, 或自动模式· trunk—设置端口为强制的trunk方式,而不理会对方端口是否为trunk
Step 5 switchport access vlan vlan-id (可选) 指定一个缺省VLAN, 如果此端口不再是trunk
Step 6 switchport trunk native vlan vlan-id 指定802.1Q native VLAN号
Step 7 end 退出
Step 8 show interfaces interface-id switchport 显示有关switchport 的配置
Step 9 show interfaces interface-id trunk 显示有关trunk的配置
Step 10 copy running-config startup-config 保存配置
举例:
Switch# configure terminal

Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)# interface fastetherne2/4

Switch(config-if)# switchport mode trunk

Switch(config-if)# switchport trunk encapsulation dot1q

Switch(config-if)# end
定义trunk允许的VLAN
缺省情况下trunk允许所有的VLAN通过。可以使用 switchport trunk allowed vlan remove vlan-list 来去掉某一VLAN
Command Purpose
Step 1 configure terminal 进入配置状态
Step 2 interface interface-id 进入端口配置
Step 3 switchport mode trunk 配置二层口为trunk
Step 4 switchport trunk allowed vlan {add | all | except | remove} vlan-list (可选) 配置trunk允许的VLAN. 使用add, all, except, remove关健字
Step 5 end 退出
Step 6 show interfaces interface-id switchport 验证VLAN配置情况.
Step 7 copy running-config startup-config 保存配置

回到允许所有VLAN通过时, 可用no switchport trunk allowed vlan 端口配置命令.
举例如下:
Switch(config)# interface fastethernet2/1

Switch(config-if)# switchport trunk allowed vlan remove 2

Switch(config-if)# end

配置Native VLAN(802.1q)
封装802.1q的trunk端口可以接受带有标签和不带标签的数据流,交换机向native vlan传送不带标签的数据流,缺省情况下native VLAN是1。

命令 目的
Step 1 configure terminal 进入配置状态
Step 2 interface interface-id 进入配置成802.1qtrunk的端口
Step 3 switchport trunk native vlan vlan-id 配置native VLAN号
Step 4 end 退出
Step 5 show interfaces interface-id switchport 验证native VLAN配置
Step 6 copy running-config startup-config 保存配置
使用no switchport trunk native vlan 端口配置命令回到缺省的状态
使用STP实现负载均衡
负载均衡可以使用流量分流到其它平行的trunks上去. 交换机为了避免环路, STP通常是阻断所有端口交换机之间只留一条链路 。使用负载均衡后, 可以把不同VLAN的流量分配到不同的trunk上。
可以通过配置STP端口权值STP路径值来实现负载均衡. 如果使用STP端口权值来配置那么二条负载均衡的trunk必须联同一交换机上。使用路径值则即可以联相同的交换机与可以联不同的交换机。
使用STP端口权值的负载均衡
当同一台交换机的二个口形成环路时, STP端口权值用来决定那个口是enable的,那个口是阻断的。 可以通过配置端口权值来决定二对trunk各走那些VLAN, 有较高权值的端口(数字较小的)vlan, 将处于转发状态,同一个VLAN在另一个trunk有较低的权值(数字较大)则将处在阻断状态。 即同一VLAN只在一个trunk上发送接受。

基于端口权值的负载均衡示意图
trunk1将发送和接收VLAN8-10的数据,trunk2将发送和接收VLAN3-6的数据

配置如下:
Command Purpose
Step 1 configure terminal 进入Switch 1配置状态
Step 2 vtp domain domain-name 配置VTP域
Step 3 vtp mode server 将Switch 1配置成VTP server.
Step 4 end 退出
Step 5 show vtp status 验证VTP的配置
Step 6 show vlan 验证VLAN
Step 7 configure terminal 进入配置状态
Step 8 interface fastethernet 0/1 进入F0/1端口
Step 9 switchport trunk encapsulation {isl | dot1q | negotiate} 配置trunk封装
Step 10 switchport mode trunk 配置成trunk
Step 11 end 退出
Step 12 show interfaces fastethernet0/1 switchport 验证VLAN配置
Step 13 在switch1上的F0/2上重复7到11步骤
Step 14 在Switch 2的F0/1,F0/2上重复7到11步骤。
Step 15 show vlan 当trunk已经起来,在switch2上验证已经学到相关的vlan配置
Step 16 configure terminal 在Switch 1上进入配置状态
Step 17 interface fastethernet0/1 进入要配置的端口
Step 18 spanning-tree vlan 8 port-priority 10 将端口权值10赋与VLAN 8.
Step 19 spanning-tree vlan 9 port-priority 10 将端口权值10赋与VLAN 9.
Step 20 spanning-tree vlan 10 port-priority 10 将端口权值10赋与VLAN 10.
Step 21 exit 退回.
Step 22 interface fastethernet0/2 进入F0/2
Step 23 spanning-tree vlan 3 port-priority 10 将端口权值10赋与VLAN 3.
Step 24 spanning-tree vlan 4 port-priority 10 将端口权值10赋与VLAN 4.
Step 25 spanning-tree vlan 5 port-priority 10 将端口权值10赋与VLAN 5.
Step 26 spanning-tree vlan 6 port-priority 10 将端口权值10赋与VLAN 10.
Step 27 end 退出
Step 28 show running-config 验证配置
Step 29 copy running-config startup-config 保存配置

配置STP路径值的负载均衡
也可以通过配置配置STP路径值来实现负载均衡,如下图所示
Trunk1走VLAN8-10,Trunk2走VLAN2-4

命令 目的
Step 1 configure terminal 进入 Switch 1配置状态
Step 2 interface fastethernet 0/1 进入F0/1
Step 3 switchport trunk encapsulation {isl | dot1q | negotiate} 配置封装
Step 4 switchport mode trunk 配置Trunk,缺省是ISL封装
Step 5 exit 退回
Step 6 在F0/2口上重复2-4步骤
Step 7 end 退出
Step 8 show running-config 验证配置
Step 9 show vlan 验证switch1已经学到Vlan
Step 10 configure terminal 进入配置状态
Step 11 interface fastethernet 0/1 进入F0/1
Step 12 spanning-tree vlan 2 cost 30 设置Vlan2生成树路径值为30
Step 13 spanning-tree vlan 3 cost 30 设置Vlan3生成树路径值为30
Step 14 spanning-tree vlan 4 cost 30 设置Vlan4生成树路径值为30
Step 15 end 退出
Step 16 在switch1的F0/2上重复9-11步骤设置VLAN8,9,10生成树路径值为30
Step 17 exit 退出
Step 18 show running-config 验证配置
Step 19 copy running-config startup-config 保存配置

配置EtherChannel
以太通道捆绑几个以太端口为一个独立的逻辑链路。在三代引擎的确4006与其它交换机之间,可提供达1600Mbps(百兆双工以太通道)或16Gbps(千兆以太通道)的带宽。一台4006交换机最多可支持64个以太通道。
你可以捆绑在4006任何模块上最多8个兼容的具有相同速率的端口。
每个以太通道具有一个port-channel端口号。要捆绑一个以太通道时,会产生一个逻辑port-channel端口,逻辑端口下的配置可影响与之捆绑的物理端口,但物理端口下的配置不能影响逻辑端口的配置。
三层以太通道配置
Command Purpose
Step 1 configure terminal 进入Switch 1配置状态
Step 2 Switch(config)# interface port-channelport_channel_number 产生一个逻辑端口
Step 3 Switch(config-if)# ip address ip_address mask 配置IP地址
Step 4 end 退出
Step 5 Switch# show running-config interfaceport-channel port_channel_number 确认配置
例子:
Switch# configure terminal
Switch(config)# interface port-channel 1
Switch(config-if)# ip address 172.32.52.10 255.255.255.0
Switch(config-if)# end
Switch# show running-config interface port-channel 1
Building configuration...
Current configuration:
!
interface Port-channel1
ip address 172.32.52.10 255.255.255.0
no ip directed-broadcast
end
Switch#
三层物理端口配置
Command Purpose
Step 1 configure terminal 进入Switch 1配置状态
Step 2 Switch(config)# interface {fastethernet |gigabitethernet} slot/port 进入物理端口配置模式
Step 3 Switch(config-if)# no switchport 改变该端口为三层接口
Step 4 Switch(config-if)# no ip address 确认接口没有配置IP地址
Step 5 Switch(config-if)# channel-group port_channel_numbermode {auto | desirable | on} 将该物理端口加入一个以太通道中,并确定PagP模式
Step 6 end 退出
Step 7 Switch# show running-config interface port-channelport_channel_numberSwitch# show running-config interface {fastethernet| gigabitethernet} slot/portSwitch# show interfaces {fastethernet |gigabitethernet} slot/port etherchannelSwitch# show etherchannel 1 port-channel 确认配置
例子:
Switch# configure terminal
Switch(config)# interface range fastethernet 5/4 - 5 (Note: Space is mandatory.)
Switch(config-if)# no switchport
Switch(config-if)# no ip address
Switch(config-if)# channel-group 1 mode desirable
Switch(config-if)# end
二层以太通道配置
Command Purpose
Step 1 configure terminal 进入Switch 1配置状态
Step 2 Switch(config)# interface {fastethernet | gigabitethernet}slot/port 进入物理端口
Step 3 Switch(config-if)# channel-group port_channel_numbermode {auto | desirable | on} 将该物理端口加入一个以太通道中,并确定PagP模式
Step 4 end 退出
Step 5 Switch# show running-config interface {fastethernet |gigabitethernet} slot/portSwitch# show interface {fastethernet | gigabitethernet}slot/port etherchannel 确认配置

例子:
Switch# configure terminal
Switch(config)# interface range fastethernet 5/6 - 7 (注意: 空格是必需的)
Switch(config-if-range)# channel-group 2 mode desirable
Switch(config-if-range)# end
Switch# show running-config interface port-channel 2
Building configuration...
Current configuration:
!
interface Port-channel2
switchport access vlan 10
switchport mode access
end
Switch#
下面两个例子是如何确认Fast Ethernet interface 5/6的配置的:
Switch# show running-config interface fastethernet 5/6
Building configuration...
Current configuration:
!
interface FastEthernet5/6
switchport access vlan 10
switchport mode access
channel-group 2 mode desirable
end
Switch# show interfaces fastethernet 5/6 etherchannel
Port state = EC-Enbld Up In-Bndl Usr-Config
Channel group = 1 Mode = Desirable Gcchange = 0
Port-channel = Po1 GC = 0x00010001
Port indx = 0 Load = 0x55
Flags: S - Device is sending Slow hello. C - Device is in Consistent state.
A - Device is in Auto mode. P - Device learns on physical port.
Timers: H - Hello timer is running. Q - Quit timer is running.
S - Switching timer is running. I - Interface timer is running.
Local information:
Hello Partner PAgP Learning Group
Port Flags State Timers Interval Count Priority Method Ifindex
Fa5/6 SC U6/S7 30s 1 128 Any 56
Partners information:
Partner Partner Partner Partner Group
Port Name Device ID Port Age Flags Cap.
Fa5/6 JAB031301 0050.0f10.230c 2/47 18s SAC 2F
Age of the port in the current state: 00h:10m:57s
下面例子显示如何确认接口配置后的port-channel interface 2 配置的:
Switch# show etherchannel 2 port-channel
Port-channels in the group:
----------------------
Port-channel: Po2
------------
Age of the Port-channel = 00h:23m:33s
Logical slot/port = 10/2 Number of ports in agport = 2
GC = 0x00020001 HotStandBy port = null
Port state = Port-channel Ag-Inuse
Ports in the Port-channel:
Index Load Port
-------------------
1 00 Fa5/6
0 00 Fa5/7
Time since last port bundled: 00h:23m:33s Fa5/6
Switch#

配置以太通道负载均衡
Command Purpose
Step 1 configure terminal 进入Switch 1配置状态
Step 2 Switch(config)# [no] port-channel load-balance {src-mac | dst-mac | src-dst-mac | src-ip |dst-ip | src-dst-ip | src-port | dst-port |src-dst-port} 配置以太通道负载均衡。使用no的命令使负载均衡变回缺省状态
Step 3 end 退出
Step 4 Switch# show etherchannel load-balance 确认配置

负载均衡关键字表示如下:
• src-mac—源MAC地址
• dst-mac—目标MAC地址
• src-dst-mac—源和目标MAC地址
• src-ip—源IP地址
• dst-ip—目标IP地址
• src-dst-ip—源和目标IP地址 (缺省)
• src-port—源第四层端口
• dst-port—目标第四层端口
• src-dst-port—源和目标第四层端口

例子:
Switch(config)# port-channel load-balance src-dst-ip
Switch(config)# end
Switch(config)#
This example shows how to verify the configuration:
Switch# show etherchannel load-balance
Source XOR Destination IP address
Switch#
配置SPAN
理解SPAN
SPAN通过诸如SwitchProbe设备或其它Remote Monitoring (RMON) probe等的网络分析仪来选择分析网络流量。SPAN从任意VLAN上的一个或多个源端口来镜像流量作为分析。如下图所示:所有从E5(源端口)的流量被镜像到E10。在E10上的一个网络分析仪可以在没有与E5端直接物理互连的情况接受到它的所有网络流量。对于进行SPAN配置,所有的源和目标端口必须在同一个交换机上。SPAN不影响源端口的网络流量的交换;一个由源接口接收或传输的复制会送到目标接口。


SPAN会话
一个SPAN会话是指一个目标端口与一组源端口的联系。你可以使用指定网络流量监控类型的参数来配置SPAN会话。SPAN会话允许你在监视一个或多个接口,或一个或多个VLAN,发送进来流量,出去流量,或进出两种流量到目标端口。你最多可以用独立或重复使用的SPAN源接口组或者VLAN来配置6个独立的SPAN会话(2个进,4个出)。双向SPAN会话指一个进和一个出会话。交换端口和可路由接口都可以作为SPAN的源接口。SPAN会话不会妨碍交换机的正常操作,当它启动时,一个SPAN会话基于不同的事件或活动而活跃或不活跃,一个syslog信息可以显示它的活动情况。show monitor session命令显示一个SPAN会话的操作状态。一个SPAN会话在系统重启后处于不活跃状态,直到目标端口可以进行操作后才会活跃。
目标端口
目标端口(监视端口)送包来进行分析的可交换或可路由端口。一旦一个接口成为活动的目标端口,该端将不会接收进入该端口的包。你不能配置一个SPAN目标端口来接收外来的包。除了SPAN会话需要的包,该接口不会转发任何其它的流量。一个被指定来作为目标端口的接口只 存在于一个SPAN会话中,不能再用于其它会话,而且不能再作为源端口。以太通道逻辑端口不能作为SPAN目标端口。指定一个trunk接口作为目标端口会断掉接口上的trunk通道。
源端口
源端口是指被用来进行监视流量的接口。在一个独立的,基于用户指定应用于源端口的流量类型(进,出或两者的流量)的SPAN会话中可监视一个或多个源端口。一个特定SPAN会话中所有的源端口会被统计分析到同一个目的地去。你可以给任意VLAN配置源端口,你也可配置VLAN作为源端口,这意味着所有在指定VLAN下的接口都是SPAN会话的源端口。Trunk接口也可以配置为源端口,同时也可以混同非trunk源接口使用。然而目标端口是不能进行封装的,因此你不可能在SPAN目标端口看到封装。
流量类型
进入的SPAN (Rx) 复制网络流量是由源端口接收的流量,给目标端口进行分析。出口SPAN (Tx) 复制网络流量是由源端口发送出去的流量。指定“both”配置选项,是指定进入和出去的流量送去目标端口进行分析。
基于VLAN的SPAN
基于VLAN的SPAN分析一个或多个VLAN的网络流量。你可以基于VLAN的SPAN作为进入SPAN,出去SPAN或同时两者均存在。所有属于源VLAN的接口将作为基于VLAN的SPAN会话的源端口。
使用以下向导来配置基于VLAN的SPAN会话:
• Trunk接口可包括于基于VLAN的SPAN会话的源端口中。
• 对于具有进出SPAN的基于VLAN SPAN的配置,如果包在同一个VLAN中交换,那它将转发到目标端口。
• 当清掉一个VLAN后,它会从基于VLAN的SPAN的源列表中清除掉。
• 不活跃的VLAN不允许进行基于VLAN的SPAN配置。
• 如果一个VLAN用来进行进入流量监视,那么从其它VLAN进入被监视VLAN来的交换路由流量不会被监视到-它不会被目标端口看到。另外,从一个监视出去流量的VLAN路由到其它LAN的流量也不会被看到。基于VLAN的SPAN仅监视离开和进入该交换的流量,而不是在VLAN之间路由的流量。
SPAN流量
所有网络流量,包括多播和桥协议数据单元(BPDU)包,都可以使用SPAN来进行监视。在一些SPAN配置中,同一个源端口的多个复制都可以发送到SPAN端口。例如,一个双向的SPAN会话配置源a1和a2到目标端口d1,如果一个通过a1进入交换机,到达a2进行交换的包,那么进来和出去的包同时将被发送到目标端口d1,两个包将是相同的包(除非产生三层的重写,那么包可能会不同)。
配置SPAN
指定源
Command Purpose
Step 1 configure terminal 进入Switch 1配置状态
Step 2 Switch(config)# [no] monitor session{session_number} {source {interfacetype/num} | {vlan vlan_ID}} [, | - | rx | tx| both] 指定SPAN会话号(1到6),源端口(以太或千兆口),或者VLAN,同时指定监视的流量方向。使用no关键字来恢复缺省配置。
Step 3 end 退出
例子:
Switch(config)# monitor session 1 source interface fastethernet 5/1

指定目标
Command Purpose
Step 1 configure terminal 进入Switch 1配置状态
Step 2 Switch(config)# [no] monitor session{session_number} {destination {interfacetype/num} } 指定SPAN会话号(1到6)和目标端口,或者VLAN,同时指定监视的流量方向。使用no关键字来恢复缺省配置。
Step 3 end 退出
例子:
Switch(config)# monitor session 1 destination interface fastethernet 5/48

监视一个trunk接口上的源VLAN
Command Purpose
Step 1 configure terminal 进入Switch 1配置状态
Step 2 Switch(config)# [no] monitor session{session_number} {filter vlan {vlan_ID}[, | - ]} 当一个SPAN源是trunk接口时监视指定VLAN,filter过滤关键字限制监视在指定VLAN上的流量,一般用于监视trunk接口。监视是通过在指定VLAN上的所有端口进行的。使用no关键字来恢复缺省配置。
Step 3 end 退出
例子:
Switch(config)# monitor session 2 filter vlan 1 - 5 , 9

--------------------------------------------------------------------------------

相关文章
趣谈大数据【华为内部狂转的想象力惊人的好文】 2014/4/21 10:23:16
Cisco路由器故障诊断技术详解 2014/2/8 23:20:14
cisco交换机 端口速率限制实现实例 2013/6/21 19:11:57
TCP/UDP常见端口参考 2013/5/23 15:26:35
Cisco交换机 DHCP Snooping功能 2013/4/27 10:42:57
Cisco 交换机与路由器故障处理方法分享 2013/4/27 10:41:58
将物理数据中心向云计算迁移的四大步骤 2012/3/19 9:42:19
防恶意扫描 PortSentry保护Linux服务器 2011/10/23 13:08:21
如何创建一个用于网络监控的网络性能基线 2011/9/19 15:45:13
Cisco IOS Site-to-Site Vpn配置案例 2011/7/14 15:47:14
23道思科网络面试题及解答 2011/3/22 12:58:43
Cisco设备光模块解密方法 2010/5/20 9:57:00
安全审计自己动手 2010/4/14 11:12:19
化解网络安全风险从设置交换机开始 2010/4/5 11:57:46
如何让Cisco路由器远离DoS攻击 2010/4/5 11:53:38
NetEye防火墙与Cisco路由器的安全问题 2010/4/5 11:50:04
思科Private VLAN与Switchport Protected 2010/3/17 12:30:45
如何让Cisco路由器远离DoS攻击 2010/3/17 12:28:38
管理思科路由器的十大蠢事 2009/12/16 13:13:32
思科Private VLAN与Switchport Protected 2009/12/16 13:09:44
cisco设备大全 2009/12/16 13:08:34
Cisco交换机端口ipmac绑定 2009/7/28 12:59:09
服务器虚拟化对网络配置的影响 2009/4/21 12:56:09
思科IOS文件管理命令 2009/3/13 21:15:53
怎样使用NetFlow分析网络异常流量 2009/3/13 21:13:48
路由器崩溃故障排除 2009/2/2 12:44:19
理解掌握Cisco错误消息 2009/2/2 12:42:44
vrrp简介 2008/8/20 14:46:21
loopback具体作用 2008/8/20 14:45:14
带外网管:小成本管理大网络 2008/8/20 14:42:00
熟悉ROM Monitor维护路由器 2008/8/7 14:18:42
教你如何防范服务器缓存投毒和域名劫持 2008/7/30 16:53:23
Priority VS Bandwidth 2008/7/16 8:24:52
怎样使用NetFlow分析网络异常流量 2008/6/7 11:27:29
Cisco(思科)路由器上如何防止DDoS 2008/6/7 11:24:30
cisco ASA防火墙配置笔记 2008/6/7 11:22:48
cisco PIX防火墙的配置及注解完全手册 2008/6/7 11:21:40
EzVPN Client 完整配置 2008/6/7 11:19:48
电信运营商使用rate-limte 限制速度方法 2008/1/10 17:57:09
通过设置Cisco路由器D.D.O.S攻击手段的细节 2008/1/10 17:49:44
Cisco 2621 端口限速配置实例 2008/1/10 17:47:51
为基于类的策略选择突发数据量和超额突发数据量 2008/1/10 17:44:44
限制BT下载的QOS配置实例 2008/1/10 17:43:47
Cisco路由器上防止分布式拒绝服务(DDoS) 2008/1/10 9:07:50
NAC网络准入--整个初始化过程 2008/1/9 9:14:11
在思科路由器上确定和跟踪DoS攻击源 2007/12/24 14:38:56
Cisco路由器IOS系统升级方法总结 2007/11/19 13:53:18
交换机出现err-disable的原因及解决方法 2007/11/19 13:42:35
路由技术 利用路由器防止DoS疯狂攻击 2007/11/19 13:36:33
路由器中的内存分类 2007/9/18 14:04:26
路由技术如何利用路由器防DoS疯狂攻击 2007/9/18 14:02:03
Cisco Switching Mode Discussion(五种交换模式辨析) 2007/8/30 10:43:57
Cisco的MAC地址与IP绑定 2007/7/19 8:46:45
如何进行SPF解析-SPF是国际知名的反垃圾标准 2007/7/4 13:29:45
用Cisco IOS阻止访问特定网站具体步骤 2007/6/30 14:28:09
电信网通双出口负载分担配置指导 2007/6/30 14:24:58
Cisco PIX inside、outside和dmz之间的访问 2007/6/30 14:19:37
交换机出现err-disable原因及解决方法 2007/6/20 17:16:56
NTP网络时钟协议的实现 2007/6/6 15:43:49
AR系列路由器两种ACL匹配规则的介绍 2007/5/21 17:21:34
Cisco路由器如何防止DDoS攻击 2007/5/10 14:47:23
Cisco IOS Cookbook 中文精简版第二十七章安全 2007/5/9 10:09:28
故障检测检查表 2007/5/5 14:55:08
Cisco IOS Cookbook 中文精简版第二十四章移动IP 2007/4/3 9:02:55
Cisco IOS Cookbook 中文精简版第十七章 SNMP 2007/4/2 9:22:27
Cisco IOS Cookbook 中文精简版第十六章路由器接口 2007/4/2 9:21:05
Cisco IOS Cookbook 中文精简版第十三章拨号备份 2007/3/28 9:07:17
Cisco IOS Cookbook 中文精简版第十二章隧道和VPN 2007/3/28 9:06:30
Cisco IOS Cookbook 中文精简版第十章 帧中继 2007/3/28 9:02:55
Cisco IOS Cookbook 中文精简版第八章OSPF 2007/3/28 9:00:40
Cisco IOS Cookbook 中文精简版第二章路由器管理 2007/3/28 8:54:38
Cisco IOS Cookbook 中文精简版第一章路由器配置和文件管理 2007/3/28 8:53:46
Catalsty 4908G-L3 VLAN间的路由和桥接 2007/3/14 8:55:01
JUNOS、IOS、VRP对比 2007/3/7 12:27:38
Cisco 3550速率限制的详细配置过程 2007/1/24 8:46:39
VLAN之间ACL和VACL的区别 2007/1/24 8:43:59
加速cisco交换机初始化过程 2006/12/27 9:20:45
Cisco交换机接口模式精解 2006/12/25 9:47:10
让路由器成为你防范的堡垒 2006/12/14 13:58:13
mpls vpn故障排除 2006/12/11 10:57:08
Cisco交换机接口模式精解 2006/12/11 10:55:30
镜像端口建立方法 2006/12/11 10:54:50
L2与L3 VPN的详细介绍与对比 2006/12/4 16:54:19
新一代网络安全接入技术对比分析 2006/12/4 16:40:41
IP网限制p2p应用流量的qos策略 2006/12/4 12:55:03
理解Cisco错误消息 2006/11/28 9:14:05
Cisco 路由器语句汇总 2006/11/28 9:12:36
IP网限制p2p应用流量的qos策略 2006/11/27 15:06:01
使用Cisco命令阻止访问特定网站 2006/11/14 8:26:00
基于路由器网络诊断步骤和故障排除技巧 2006/11/14 8:24:45
论广播风暴的成因、预防及排障 2006/11/14 8:23:37
解决实际维护网络过程故障的五个盲点 2006/11/10 9:00:29
分析CISCO与华为3COM路由器配置差别 2006/10/31 8:27:54
思科站点大集合 2006/10/31 8:26:52
Cisco IOS防火墙的安全规则和配置方案 2006/10/28 10:07:06
交换机出现err-disable的原因及解决方法 2006/10/28 10:00:22
排除路由器崩溃故障 2006/10/28 9:59:03
三层交换机技术中常提到的TRUNK 2006/10/28 9:57:02
Catalyst 4006交换机的配置实例 2006/10/28 9:56:03
Cisco防火墙技术汇总 2006/10/28 9:50:56
抵御DDoS攻击 2006/10/28 9:46:05
帧中继故障的诊断与排除 2006/10/16 11:12:00
用命令行在设备上查看机框序列号 2006/10/10 12:59:24
保护路由器的十四招 2006/9/27 17:33:41
MAC地址的访问控制 2006/9/13 19:28:58
VRF Selection using by source ip 2006/9/13 19:25:53
华为Display interface的显示信息详解 2006/9/13 19:21:44
交换机接口出现err-disable的几个常见原因 2006/9/13 19:17:58
针对目前出现的ARP欺骗攻击行为,提出Cisco的解决方案 2006/8/30 16:33:25
六大步骤顺利排除计算机网络连接故障 2006/8/29 10:37:25
华为Display interface的显示信息详解 2006/8/28 13:01:16
配置思科三层交换的综合案例 2006/8/9 17:07:03
Catalyst 4006交换机的配置实例 2006/8/9 17:01:46
网络路由安全攻防对策分析及实践 2006/8/8 18:55:12
核心网络设备配置及参数如何备份 2006/8/8 18:53:00
配置cisco vpn client使用scep从ios router ca获取证书 2006/8/4 7:46:25
NAT+DHCP+HSRP+ACL+NTP配置实例 2006/8/4 7:02:10
解决在DHCP环境下私自指定IP和私自搭建DHCP服务器的方法 2006/8/4 7:00:32
用ACL构建防火墙体系 2006/8/2 14:43:20
Cisco 网际操作系统(IOS)命名规范(图) 2006/8/2 14:33:02
Cisco实战:配置三层交换的综合案例 2006/8/2 14:30:15
网络故障处理手册 2006/7/25 14:09:43
设置交换机span以进行侦听 2006/7/22 17:24:20
交换机升级排障 2006/7/18 17:57:24
Cisco配置手记 2006/7/17 10:08:27
ASA 5520配置例子 2006/7/14 9:47:04
思科路由器全局、接口、协议调试 2006/7/14 9:45:18
Cisco路由器故障诊断技术(重新编辑) 2006/7/14 9:42:38
关于IP-MAC绑定的交换机设置 2006/7/14 9:41:11
如何使用Cisco IOS文件系统命令 2006/7/13 8:14:53
rate-limit 使用方法 2006/7/11 14:50:13
用Xmodem的方式升级IOS 2006/7/10 14:27:22
Cisco交换机POST过程排错 2006/7/4 19:51:10
交换机 VLAN配置基础及实例 2006/7/4 19:48:33
轻松玩转Cisco路由器密码 2006/7/4 19:22:38
路由器默认密码 2006/6/28 23:05:49
路由器交换机配置信息及口令的清除 2006/6/28 23:01:47
用snort和空IP做一个安全的log纪录服务器 2006/6/17 11:09:10
工作中处理交换机频繁吊死故障实例 2006/6/13 8:41:14
在Cisco交换机上实现隔离访问 2006/6/13 8:36:02
多VLAN环境下DHCP服务的实现 2006/6/12 9:12:24
路由器网络接口字段详细解析 2006/6/12 9:09:43
小议TCP的MSS(最大分段)以及MTU 2006/6/9 21:06:48
一些有关网络的故障案例 2006/6/9 20:36:48
入侵检测系统逃避技术和对策的介绍 2006/6/7 9:25:12
网络流量监控的常用方法 2006/6/3 12:47:41
MPLS-VPN的最佳解决方案 2006/6/3 12:43:30
MPLS VPN 路由器与交换机选购指南 2006/5/30 14:27:52
思科路由器常用配置命令大全(A-X) 2006/5/29 9:21:21
TRUNK”的三个意思,不要混淆 2006/5/29 9:19:29
NetFlow交换及其在网络管理中的应用 2006/5/28 17:22:00
网络安全讲座之八:审计结果 2006/5/24 19:46:24
网络安全讲座之七:IDS系统 2006/5/24 19:45:52
网络安全讲座之六:侦察与工具 2006/5/24 19:43:53
Cisco VPN连接配置实例 2006/5/24 11:36:31
网络专业人士笔记 2006/5/22 10:06:48
用Cisco产品和功能构建安全的网络 2006/5/10 10:37:05
三层MPLS VPN及其故障处理 2006/5/8 19:45:11
路由器网络服务安全配置 2006/5/8 19:37:22
vsftp配置大全 2006/5/6 18:17:32
防黑全攻略——端口扫描技术 2006/4/30 13:24:46
在Cisco设备上实现IOS DHCP Server的功能 2006/4/30 12:31:15
RFC2328 OSPF V2 中文版 2006/4/27 20:40:32
透视网络管理技术 (网络管理、网络维护) 2006/4/6 20:01:31
负载均衡技术的三种实现方法 2006/4/6 19:53:21
基于路由器的网络诊断技术 2006/4/6 19:35:16
网络故障诊断初探 2006/4/6 19:27:33
网络分析监听技术之原理、应用与防范 2006/4/6 19:22:39
向P2P通信宣战(关于封BT下载软件) 2006/4/4 8:07:19
边界网关协议版本4(BGP-4) RFC1771 2006/3/30 22:30:28
故障检测检查表 2006/3/30 22:09:03
基于MPLS的流量工程要求(RFC2702) 2006/3/30 21:57:05
MPLS标记栈编码(RFC3032) 2006/3/30 21:54:27
IP VPN的框架体系(RFC2764) 2006/3/30 21:52:32
BGP团体属性(RFC1997) 2006/3/30 21:51:35
BGP路由反射(RFC2796) 2006/3/30 21:51:06
BGP MPLS VPNs(RFC2547) 2006/3/30 21:50:22
典型局域网多VLAN配置实例 2006/3/28 13:12:03
利用Catalyst交换机防范蠕虫病毒 2006/3/28 13:00:21
cisco四种类型的网络防火墙技术汇总 2006/3/20 12:59:53
在Cisco交换机上实现隔离访问 2006/3/20 12:55:26
让路由器远离字典DoS攻击 2006/3/8 11:21:00
策略路由概览 2006/3/8 11:15:41
802.1x:老根发新芽 2006/3/8 10:55:52
配置示例:Catalyst与 CatOS 交换机之间的 ISL/802.1q 中继 2006/3/7 9:32:13
用route map实现多ISP Internet接入工程实例 2006/3/6 8:39:09
配置三层交换的综合事例 2006/3/6 8:36:39
Cisco交换机集群技术 2006/3/1 8:39:10
排除路由故障 2006/3/1 8:37:26
访问控制列表使用原则 2006/3/1 8:34:49
常用品牌交换机端口镜像(Port Mirroring)配置 2006/2/23 14:08:02
Catalyst3550的三层交换与VLAN 2006/2/14 15:24:44
Cisco产品采用的网络协议总结 2006/1/12 14:15:24
Cisco Catalyst 2950 配置-实现端口与IP的绑定 2006/1/9 8:56:17
auto secure命令的使用 2006/1/4 13:48:11
用Cisco产品和功能构建安全的网络 2006/1/4 13:46:58
Cisco Catalyst 2950 配置-实现端口与IP的绑定 2005/12/25 14:51:46
关于IP-MAC绑定的交换机设置 2005/12/13 14:48:09
Cisco IOS访问列表的应用 2005/11/26 20:17:04
Cisco IOS进程调试 2005/11/26 20:15:38
掌握Cisco IOS测试命令的多种用法 2005/11/26 20:13:12
Cisco IOS命名规则 2005/11/26 20:11:25
Configuring Dynamic VLANs 2005/11/24 14:05:15
Catalyst5500交换机 VLAN设置 2005/11/24 10:25:33
思科IOS 12.3新特性 2005/11/21 9:32:14
《网络基础学习之二十》路由器的配置 2005/11/11 10:03:00
《网络基础学习之十九》路由器的硬件连接 2005/11/11 10:01:42
《网络基础学习之十八》主要路由器技术 2005/11/11 10:00:42
《网络基础学习之十七》路由器原理、分类和选购 2005/11/11 9:59:28
《网络基础学习之十六》路由器基础 2005/11/11 9:58:20
《网络基础学习之十五》交换机VLAN的配置 2005/11/11 9:57:10
《网络基础学习之十四》交换机配置全接触 2005/11/11 9:56:00
《网络基础学习之九》集线器的安装与连接 2005/11/11 9:48:54
《网络基础学习之六》初识网络体系结构与协议 2005/11/11 9:42:59
VPN实例配置方案-中文注解 2005/11/5 21:42:09
IPSEC 安全架构、应用及展望 2005/11/5 20:58:28
用ACL构建防火墙体系 2005/11/4 11:16:35
华为路由器与CISCO路由器在配置上的差别 2005/11/3 14:40:32
以太网络建立多个VLAN典型案例 2005/11/3 14:32:24
系统入侵者攻击企业或敏感数据网络方法白皮书 2005/10/11 10:52:53
AAA之配置授权 2005/9/20 15:20:29
Cisco ios 软件的安装升级方法 2005/9/20 14:09:04
VPN 配置之一:vpn access server 2005/9/7 16:33:42
Cisco 路由器 VPN典型配置 2005/9/7 16:08:09
负载均衡技术全攻略 2005/8/19 8:33:25
思科认证的36个热门考点 2005/8/11 14:16:05
网络使用的学习总结 2005/8/10 8:27:09
一块网卡绑定多IP与多网卡使用一个IP 2005/8/8 9:38:37
如何利用Catalyst交换机及时发现、追踪和缓解蠕虫病毒的入侵? 2005/8/4 13:31:23
CISCO交换机的数据监控 2005/8/4 13:00:36
在Catalyst 2948G-L3交换机上使用BVI配置IP上行链路重定向功能 2005/8/4 12:58:24
Cisco交换机实现端口安全的方法及事项 2005/8/4 12:54:23
Cisco路由器的备份配置方法 2005/8/4 12:53:32
路由选择原理 2005/8/4 12:49:14
How to Determine Which Switch and Port You are Connected To 2005/7/28 8:34:13
基于路由器网络诊断步骤和故障排除技巧 2005/7/25 10:13:25
利用Catalyst交换机防范蠕虫病毒的入侵 2005/7/8 8:32:43
3种方法封锁BT下载 2005/6/28 10:26:26
CCNP-CIT中文笔记 完整版 2005/6/24 15:31:49
用NBAR来防止红色代码(Code Red)和尼姆达(Nimda)蠕虫病毒 2005/6/22 10:13:20
细讲解第三层交换技术 2005/6/22 8:16:10
路由器(Router)原理介绍 2005/6/22 7:58:05
交换机(Switch)工作原理 2005/6/22 7:57:16
网络流量监控器mrtg全攻略 2005/6/17 15:03:36
流量检测的几种方案 2005/6/17 14:59:54
教你识别思科交换机型号 2005/6/11 21:49:53
多个网卡绑定一个IP地址(bonding) 2005/6/10 21:18:12
如何删除IOS--CISCO IFS简介 2005/6/10 21:05:56
软件vpn与硬件的优势对比 2005/6/3 12:14:03
把linux配置成pix 的日志主机 2005/6/3 12:07:51
通俗易懂的《路由和交换》 2004/11/19 9:24:31
CCNA考试命令集 2004/11/9 10:47:49
如何配置Cisco PIX防火墙 2004/11/9 10:11:50
Cisco常见配置 2004/11/9 10:04:39
各种交换机的镜像配置(cicsoc、华为、3com、Avaya、Intel) 2004/11/9 9:55:40
多个网卡绑定一个IP地址(bonding) 2004/10/19 8:41:07
系统安全名词列表(2) 2004/10/8 9:40:16
系统安全名词列表(1) 2004/10/8 9:38:02
华为、Intel与Cisco的交换机产品使用感受 2004/9/13 8:29:36
配置三层交换的综合范例 2004/9/1 11:20:39
怎样在Cisco设备上实现IOS DHCP Server的功能 2004/9/1 11:19:27
show controller e1(带注释) 2004/8/29 12:32:50
常见的CatcOs错误消息在Cisco Catalyst 交换机 2004/8/29 12:29:00
配置和排除以太网10/100/1000Mb Half/Full双工自动协商故障 2004/8/29 12:23:23
CISCO的快速转发 2004/8/29 12:19:05
4000 6500交换引擎配置方法. 2004/8/29 12:04:24
29&3548配置方法 2004/8/29 12:02:51
网络流量监控器mrtg全攻略 2004/8/21 10:14:35
CISCO交换机的数据监控 2004/8/19 15:07:34
深入浅出了解交换机是怎么工作的 2004/8/16 8:21:07
让路由器成为你防范的堡垒 2004/8/13 12:54:21
Cisco路由器及交换机安全加固 2004/8/13 12:51:44
Cisco路由器的安全配置简易方案 2004/8/10 12:28:09
Cisco 路由配置语句汇总 2004/8/10 12:26:42
CCNA专业词汇全集 2004/8/10 7:50:25
计算机端口介绍[详细列表] 2004/8/9 8:02:50
路由器NAT功能配置简介(知识点讲解,bsci必考) 2004/7/27 17:11:46
CISCO网络安全 2004/7/26 8:42:25
根据ip地址查交换机端口 2004/7/23 10:16:41
路由器测试的类型和方法 2004/7/23 10:04:30
CIT中文笔记 2004/7/15 11:52:42
Cisco路由器及交换机安全加固 2004/7/14 16:21:36
交换机口令恢复的步骤 2004/7/9 10:09:20
三层MPLS VPN及其故障处理 2004/7/1 13:08:35
Cisco路由器的安全配置简易方案 2004/6/10 16:47:41
CISCO路由器基于时间的访问列表的应用 2004/6/10 16:44:06
cisco 未公开的命令 2004/6/7 8:00:17
根据IP查端口 2004/6/1 8:50:32
CISCO部分命令全集 2004/5/27 14:03:51
Cisco路由器故障诊断技术 2004/5/26 14:16:19
使用路由器作流量检测的几个手段 2004/4/9 13:17:44
用xmodem重新快速灌IOS- 2004/2/27 14:01:52
CCIE之建立详细的故障检测检查表 2004/2/26 8:59:12
网络端口及其详解分页 2004/2/17 9:03:12
100分钟教你配CISCO RIP 2004/2/11 8:18:25
在接入服务器上使用Cisco IOS DHCP服务器 2004/2/4 8:31:10
Cisco路由器由Windows 2000 CA中心登记证书 2004/2/4 8:30:02
如何升级软件 图像在Catalyst 交换机第三层模块 2004/2/4 8:27:28
安全的log纪录服务器 2004/1/24 19:17:43
CCNP路由部分精华 2004/1/6 11:10:54
-- E1知识点总结 -- 2004/1/6 10:30:00
LINUX新手入门及安装配置faq200(下) 2003/12/31 20:54:57
用route map实现多ISP Internet接入工程实例 2003/12/31 9:19:10
cisco3640路由器设置(祥) 2003/12/27 20:43:07
在CISCO设备上用FTP传IOS文件 2003/12/27 1:31:14
SSH在Cisco设备上设置实例 2003/12/20 23:29:24
CCNP课堂---交换(Switch)篇 2003/12/2 10:45:32
Cisco路由器故障诊断技术 2003/12/2 10:37:30
用 Linux 打造路由器 2003/11/25 9:55:06
switch命令大全 2003/11/25 9:06:50
组播协议和组播路由 2003/11/19 10:41:40
Cisco路由器的安全配置简易方案 2003/11/11 8:05:48
IS-IS路由协议学习总结 2003/11/4 9:53:23
局域网交换机维护 2003/11/3 8:45:18
通过设置Cisco路由器防止分布式D.O.S攻击手段的细节 2003/10/30 16:56:20
CatOS下定义VLAN 2003/10/23 14:54:21
Cisco路由器是怎样被攻陷的------SolarWinds2002的简单使用 2003/10/23 10:42:37
Switching 命令大全 2003/10/13 17:59:51
路由器故障解决 2003/9/17 8:26:49
关于路由器cpu利用率过高的解决 2003/9/9 10:43:07
网络层访问权限控制技术 ACL详解 2003/9/9 8:49:02
CISCO 技术大集合 2003/9/8 7:46:34
SSH实现Cisco路由器登录 2003/9/8 7:39:57
最佳的75个安全工具 2003/9/5 15:18:38
某大型企业局域网安全解决方案 2003/9/2 9:14:09
常见端口表汇总 2003/9/1 10:31:24
新版CCNA 640-801考试IOS命令大全(ZT) 2003/8/27 17:39:13
Catalyst5500交换机 VLAN设置 2003/8/26 10:54:04
局域网实现VLAN实例 2003/8/15 10:37:16
Redhat advance server 2.1集群的安装与管理 2003/8/12 8:21:31
双机热备的全面配置示例 2003/8/6 14:45:05
用 Linux 打造路由器 2003/8/5 7:33:33
Cisco 路由配置语句汇总 2003/7/31 9:08:50
网络词汇大全 2003/7/31 8:45:22
思科产品常见问题一百问 2003/7/30 14:17:30
系统安全名词列表 2003/7/29 10:27:02
CISCO配置命令大全 2003/7/28 17:58:33
基于路由器的网络诊断 2003/7/28 17:57:02
CISCO交换机概览 2003/7/28 15:14:40
Cisco路由器的安全配置简易方案 2003/7/19 19:08:47
Cisco 路由配置语句汇总 2003/7/14 16:59:32
网络工程师必懂的专业术语 2003/7/14 16:54:43
网络流量监控器mrtg全攻略 2003/7/14 9:37:34
Switching 命令大全-转 2003/7/13 19:06:01
路由器故障解决 2003/7/13 19:05:03
[精华手册]CISCO路由器配置手册 2003/7/13 19:01:40
虚拟局域网(VLAN)路由实例 2003/7/13 19:00:04
XX校校园网实现(VLAN及策略路由的实现) 2003/7/13 17:53:32
转载cisco3524的管理vlan配置 2003/7/11 22:16:09
在win2000中使用mrtg进行实时流量监测 2003/7/11 22:14:10
路由的中文笔记 2003/7/8 12:22:30
Cisco路由器的安全配置简易方案 2003/7/2 9:03:54
电脑书籍下载网站集锦 2003/6/27 8:18:43
局域网中代理服务器、路由器的配置案例 2003/3/23 21:47:36
某大型企业局域网安全解决方案 2003/3/17 22:44:09
某大型局域网安全解决方案 2003/2/21 22:13:18
理解防火墙及防火墙实例系列: 第一部分 防火墙基本类型、概念以及各类防火墙的主要优缺点 2003/1/12 15:45:24


感性空间
设计&运维
网络技术
休闲娱乐
NetFilter
linux&Unix
网络安全
程序空间
软件考试
RFC&ISO
规划&规范
虚拟&存储
Apple技巧
云计算&大数据



文章搜索



站内搜索