所属分类: 网络技术 整理: FengNet.Com 更新日期:2003/12/2 10:45:32 阅读次数:12959

CCNP课堂---交换(Switch)篇


Cisco交换机集群技术

对于交换机之间的连接,比较熟悉的应该有两种:一、是堆叠,二、是级连。对于级连的方式比较容易造成交换机之间的瓶颈,而虽然堆叠技术可以增加背板速率,能够消除交换机之间连接的瓶颈问题,但是,受到距离等的限制很大,而且对交换机数量的限制也比较严格。
Cisco公司推出的交换机集群技术,可以看成是堆叠和级连技术的综合。这种技术可以将分布在不同地理范围内的交换机逻辑地组合到一起,可以进行统一的管理。具体的实现方式就是在集群之中选出一个Commander,而其他的交换机处于从属地位,由Commander统一管理。对于新的Catalyst 3500 XL系列中的 Catalyst 3512XL、Catalyst 3524XL和Catalyst 3508G XL三个型号均可以成为Commander,而对于被管理者2900和1900系列均可以加入交换机集群,使用Cisco最新的交换集群技术将传统的堆叠技术提高到新的水平。据说对于2900XL系列也可以成为Commander。

该系列产品面向中型企事业单位,在提供高性能和低成本的同时,降低了复杂度,并易于集成到已有的网络上。它允许网络管理员使用标准的Web 测览器。通过单一的IP地址从 网络上的任何地方管理地理上分散的交换机。

具体举例如下:

假设网络中心采用Cisco 的 Catalyst 6506交换机,而集群的Commander 采用Catalyst 3508 GXL 在集群的Commander与中心交换机之间,可以通过千兆连接或者通过GEC实现4千兆的连接,而在集群内部采用3500、2900、1900的组合,之间通过FEC等方式相连接。然后为集群分配独立的Ip地址就可以对整个集群进行管理了。

交换机集群技术最多支持16台交换机,可以提供多达16*48个端口。
交换机背板带宽

背板带宽,是交换机接口处理器或接口卡和数据总线间所能吞吐的最大数据量。一台交换机的背板带宽越高,所能处理数据的能力就越强,但同时设计成本也会上去。
但是,我们如何去考察一个交换机的背板带宽是否够用呢?显然,通过估算的方法是没有用的,我认为应该从两个方面来考虑:
1、)所有端口容量X端口数量之和的2倍应该小于背板带宽,可实现全双工无阻塞交换,证明交换机具有发挥最大数据交换性能的条件。
2、)满配置吞吐量(Mpps)=满配置GE端口数×1.488Mpps其中1个千兆端口在包长为64字节时的理论吞吐量为1.488Mpps。例如,一台最多可以提供64个千兆端口的交换机,其满配置吞吐量应达到 64×1.488Mpps = 95.2Mpps,才能够确保在所有端口均线速工作时,提供无阻塞的包交换。如果一台交换机最多能够提供176个千兆端口,而宣称的吞吐量为不到261.8Mpps(176 x 1.488Mpps = 261.8),那么用户有理由认为该交换机采用的是有阻塞的结构设计。
一般是两者都满足的交换机才是合格的交换机。

背板相对大,吞吐量相对小的交换机,除了保留了升级扩展的能力外就是软件效率/专用芯片电路设计有问题;背板相对小。吞吐量相对大的交换机,整体性能比较高。不过背板带宽是可以相信厂家的宣传的,可吞吐量是无法相信厂家的宣传的,因为后者是个设计值,测试很困难的并且意义不是很大。
交换机的背版速率一般是:Mbps,指的是第二层,对于三层以上的交换才采用Mpps

三层交换机与路由器的比较

为了适应网络应用深化带来的挑战,网络在规模和速度方向都在急剧发展,局域网的速度已从最初的10Mbit/s 提高到100Mbit/s,目前千兆以太网技术已得到普遍应用。在网络结构方面也从早期的共享介质的局域网发展到目前的交换式局域网。交换式局域网技术使专用的带宽为用户所独享,极大的提高了局域网传输的效率。可以说,在网络系统集成的技术中,直接面向用户的第一层接口和第二层交换技术方面已得到令人满意的答案。但是,作为网络核心、起到网间互连作用的路由器技术却没有质的突破。在这种情况下,一各新的路由技术应运而生,这就是第三层交换技术:说它是路由器,因为它可操作在网络协议的第三层,是一种路由理解设备并可起到路由决定的作用;说它是交换器,是因为它的速度极快,几乎达到第二层交换的速度。二层交换机、三层交换机和路由器这三种技术究竟谁优谁劣,它们各自适用在什么环境?为了解答这问题,我们先从这三种技术的工作原理入手
1.二层交换技术

二层交换机是数据链路层的设备,它能够读取数据包中的MAC地址信息并根据MAC地址来进行交换。交换机内部有一个地址表,这个地址表标明了MAC地址和交换机端口的对应关系。当交换机从某个端口收到一个数据包,它首先读取包头中的源MAC地址,这样它就知道源MAC地址的机器是连在哪个端口上的,它再去读取包头中的目的MAC地址,并在地址表中查找相应的端口,如果表中有与这目的MAC地址对应的端口,则把数据包直接复制到这端口上,如果在表中找不到相应的端口则把数据包广播到所有端口上,当目的机器对源机器回应时,交换机又可以学习一目的MAC地址与哪个端口对应,在下次传送数据时就不再需要对所有端口进行广播了。二层交换机就是这样建立和维护它自己的地址表。由于二层交换机一般具有很宽的交换总线带宽,所以可以同时为很多端口进行数据交换。如果二层交换机有N个端口,每个端口的带宽是M,而它的交换机总线带宽超过N×M,那么这交换机就可以实现线速交换。二层交换机对广播包是不做限制的,把广播包复制到所有端口上。
二层交换机一般都含有专门用于处理数据包转发的ASIC (Application specific Integrated Circuit)芯片,因此转发速度可以做到非常快。

2.路由技术

路由器是在OSI七层网络模型中的第三层——网络层操作的。路由器内部有一个路由表,这表标明了如果要去某个地方,下一步应该往哪走。路由器从某个端口收到一个数据包,它首先把链路层的包头去掉(拆包),读取目的IP地址,然后查找路由表,若能确定下一步往哪送,则再加上链路层的包头(打包),把该数据包转发出去;如果不能确定下一步的地址,则向源地址返回一个信息,并把这个数据包丢掉。
路由技术和二层交换看起来有点相似,其实路由和交换之间的主要区别就是交换发生在OSI参考模型的第二层(数据链路层),而路由发生在第三层。这一区别决定了路由和交换在传送数据的过程中需要使用不同的控制信息,所以两者实现各自功能的方式是不同的。
路由技术其实是由两项最基本的活动组成,即决定最优路径和传输数据包。其中,数据包的传输相对较为简单和直接,而路由的确定则更加复杂一些。路由算法在路由表中写入各种不同的信息,路由器会根据数据包所要到达的目的地选择最佳路径把数据包发送到可以到达该目的地的下一台路由器处。当下一台路由器接收到该数据包时,也会查看其目标地址,并使用合适的路径继续传送给后面的路由器。依次类推,直到数据包到达最终目的地。
路由器之间可以进行相互通讯,而且可以通过传送不同类型的信息维护各自的路由表。路由更新信息主是这样一种信息,一般是由部分或全部路由表组成。通过分析其它路由器发出的路由更新信息,路由器可以掌握整个网络的拓扑结构。链路状态广播是另外一种在路由器之间传递的信息,它可以把信息发送方的链路状态及进的通知给其它路由器。
3.三层交换技术
一个具有第三层交换功能的设备是一个带有第三层路由功能的第二层交换机,但它是二者的有机结合,并不是简单的把路由器设备的硬件及软件简单地叠加在局域网交换机上。
从硬件上看,第二层交换机的接口模块都是通过高速背板/总线(速率可高达几十Gbit/s)交换数据的,在第三层交换机中,与路由器有关的第三层路由硬件模块也插接在高速背板/总线上,这种方式使得路由模块可以与需要路由的其他模块间高速的交换数据,从而突破了传统的外接路由器接口速率的限制。在软件方面,第三层交换机也有重大的举措,它将传统的基于软件的路由器软件进行了界定,
其做法是:
对于数据包的转发:如IP/IPX包的转发,这些规律的过程通过硬件得以高速实现。
对于第三层路由软件:如路由信息的更新、路由表维护、路由计算、路由的确定等功能,用优化、高效的软件实现。

假设两个使用IP协议的机器通过第三层交换机进行通信的过程,机器A在开始发送时,已知目的IP地址,但尚不知道在局域网上发送所需要的MAC地址。要采用地址解析(ARP)来确定目的MAC地址。机器A把自己的IP地址与目的IP地址比较,从其软件中配置的子网掩码提取出网络地址来确定目的机器是否与自己在同一子网内。若目的机器B与机器A在同一子网内,A广播一个ARP请求,B返回其MAC地址,A得到目的机器B的MAC地址后将这一地址缓存起来,并用此MAC地址封包转发数据,第二层交换模块查找MAC地址表确定将数据包发向目的端口。若两个机器不在同一子网内,如发送机器A要与目的机器C通信,发送机器A要向“缺省网关”发出ARP包,而“缺省网关”的IP地址已经在系统软件中设置。这个IP地址实际上对应第三层交换机的第三层交换模块。所以当发送机器A对“缺省网关”的IP地址广播出一个ARP请求时,若第三层交换模块在以往的通信过程中已得到目的机器C的MAC地址,则向发送机器A回复C的MAC地址;否则第三层交换模块根据路由信息向目的机器广播一个ARP请求,目的机器C得到此ARP请示后向第三层交换模块回复其MAC地址,第三层交换模块保存此地址并回复给发送机器A。以后,当再进行A与C之间数据包转发进,将用最终的目的机器的MAC地址封装,数据转发过程全部交给第二层交换处理,信息得以高速交换。既所谓的一次选路,多次交换。

第三层交换具有以下突出特点:

有机的硬件结合使得数据交换加速;

优化的路由软件使 得路由过程效率提高;

除了必要的路由决定过程外,大部分数据转发过程由第二层交换处理;

多个子网互连时只是与第三层交换模块的逻辑连接,不象传统的外接路由器那样需增加端口,保护了用户的投资。


4.三种技术的对比


可以看出,二层交换机主要用在小型局域网中,机器数量在二、三十台以下,这样的网络环境下,广播包影响不大,二层交换机的快速交换功能、多个接入端口和低谦价格为小型网络用户提供了很完善的解决方案。在这种小型网络中根本没必要引入路由功能从而增加管理的难度和费用,所以没有必要使用路由器,当然也没有必要使用三层交换机。

  三层交换机是为IP设计的,接口类型简单,拥有很强二层包处理能力,所以适用于大型局域网,为了减小广播风暴的危害,必须把大型局域网按功能或地域等因素划他成一个一个的小局域网,也就是一个一个的小网段,这样必然导致不同网段这间存在大量的互访,单纯使用二层交换机没办法实现网间的互访而单纯使用路由器,则由于端口数量有限,路由速度较慢,而限制了网络的规模和访问速度,所以这种环境下,由二层交换技术和路由技术有机结合而成的三层交换机就最为适合。

  路由器端口类型多,支持的三层协议多,路由能力强,所以适合于在大型网络之间的互连,虽然不少三层交换机甚至二层交换机都有异质网络的互连端口,但一般大型网络的互连端口不多,互连设备的主要功能不在于在端口之间进行快速交换,而是要选择最佳路径,进行负载分担,链路备份和最重要的与其它网络进行路由信息交换,所有这些都是路由完成的功能。在这种情况下,自然不可能使用二层交换机,但是否使用三层交换机,则视具体情况而下。影响的因素主要有网络流量、响应速度要求和投资预算等。三层交换机的最重要目的是加快大型局域网内部的数据交换,揉合进去的路由功能也是为这目的服务的,所以它的路由功能没有同一档次的专业路由器强。在网络流量很大的情况下,如果三层交换机既做网内的交换,又做网间的路由,必然会大大加重了它的负担,影响响应速度。在网络流量很大,但又要求响应速度很高的情况下由三层交换机做网内的交换,由路由器专门负责网间的路由工作,这样可以充分发挥不同设备的优势,是一个很好的配合。当然,如果受到投资预算的限制,由三层交换机兼做网间互连,也是个不错的选择。

低端交换机的选购

当前,国内市场上的低端交换机产品涵盖了从思科等国外网络巨头到华为、TCL等国内厂商的众多品牌,价格也自平均每端口50元左右到数百、上千元不等,选择余地极大。因此,如何选择一台适用的交换机产品就成为不少用户面临的一大难题。尤其是低端交换机产品主要面向小型商业和家庭用户,而这些用户通常又不具备专业的网络技术人员,因此选择的难度更大一些。

  实际上,在选购低端交换机产品时,用户只要从自身需求、供应商情况及产品本身等三个方面入手,认真加以权衡,就不难选择到合适的产品。


  ① 看自己


  这是选购交换机产品的最基本、也是最重要的一步。用户应在了解自己的网络节点数等基本网络环境的基础上,对需要的交换机产品的诸如端口数、交换速率以及自己可以承受的价格范围等有一个明晰的目标。只有这样,才能够在琳琅满目的产品中正确选择符合自己需求的产品。


  ② 看品牌


  在选择低端交换机产品时,要注意了解产品供应商的品牌号召力、用户口碑、产品质量认证情况、研发能力与核心技术实力,同时,仔细研究供应商提供的解决方案与自己实际应用环境之间的差异。有些情况下,通过供应商的具体成功案例来了解产品在市场上的成熟程度也不失为一种行之有效的简单途径。另外,还要认真了解供应商的售后服务情况,以减少后顾之忧。在很多情况下,优秀的客户服务的价值远远胜于采购中节约的金钱。


  ③ 看速率


  交换机的交换速率是决定网络传输性能的重要因素。虽然在今天的低端交换机产品市场上,百兆交换机仍占据着主流地位,但千兆交换机市场正在迅速崛起,尤其是“千兆到桌面”的网络应用新理念的提出,更推动了对千兆交换机产品的需求。因此,用户在选购交换机产品时,也必须顺应这一新的网络发展潮流,尽量选择具备千兆端口或能够升级的产品,以适应未来网络升级的需要。


  ④ 看端口数


  低端交换机产品的端口数量一般有8、12、16、24及48端口等几 种,就目前市场的销售情况来看,在低端交换机产品市场上,24端口的产品销售最为看好。这是由于对于不足百人的小型企业或校园网络环境而言,24端口交换机既可作为工作组交换机,也可作为企业骨干交换机使用;同时,就实际应用方面而言,24端口交换机较8端口与16端口产品有更多的扩展空间,能够更好地满足用户未来网络扩展的需要。因此,用户在选择低端交换机产品时,如无明确的端口要求,应以选择24端口交换机为宜。


  ⑤ 看管理性能


  过去低端交换机产品多是非管理型交换机,这类产品易于配置并且只能使用ASIC解决方案。由于这类交换机不配备处理器,因而售价相对低廉,但这类交换机配置灵活性不高,不能满足有特定要求的用户。近年来,随着低端交换机产品市场竞争的加剧,配备有处理器的管理型交换机也在市场中大量涌现。由于这类交换机产品具备包括远程管理、安全管理在内的多种控制与管理功能,因此配置灵活,能够适合多种不同的网络环境需求。因此这类交换机近年来在低端交换机产品市场也占据了很大的市场份额。用户在选购时可以根据自已实际需求选择可管理型或非管理型产品。


  ⑥ 看伸缩性


  交换机的可伸缩性直接决定着网络内各信息点传输速率的升级能力。因此,可伸缩性也是用户在选择交换机产品时需要考虑的一个重要方面。这主要包括交换机的内部可伸缩性、外部可伸缩性以及交换机的最高级联速率等几个方面。


  ⑦ 看价格


  在价格方面,有道是“一分钱一分贸”。因此,在经济实力允许的情况下,应尽可能选择知名供应商的主流产品,切不可一味追求低价位产品。当然,也不可盲目选择高性能、高价位的产品,造成产品功能的闲置浪费。


  ⑧ 还有看


  另外,交换机产品本身的情况还包括虚拟LAN支持、Mac地址列表数量、QoS服务质量等相关技术指标,在这些方面用户可根据自己的实际需求情况加以衡量和取舍,在此就不再一一赘述了。

低端交换机性能指标(部分)一览表

厂商名称 华为 港湾网络 迈普 明基 全向 实达网络 博达 上海广电
应确信 世纪
大吉 清华
同方 龙维 联创通信 华旗
产品型号 qui
dway hammer my
power sm2
224 qs8
224i star- bd
com infi
nite dgc tfs5
124ei en23
09sg light
speed patriot
s3526e 1024 s30
26g s18
24f s22
243 switch sf35
32d 2024m s0802
最小/最大100m
以太网
端口数 24 24 24 24 24 24 24 32 32 24 8/9 24 8
最小/最大1000m
以太网
端口数 2 2 1/2 2 2 1
扩展槽数 2 1 2 4 2 1 2 2 1 2
最大可
堆叠数 16
支持网
络类型
(10/100 base-tx之外) 1000
base
-tx
1000
base
-lx
1000
base
-sx 100
base-
fx 1000
base-
sx/lx
1000
base-t 100
base-
fx 100
base
-fx 100
base-
fx 1000
bas
e-t 100b
ase
-fx
100
base
-fs
1000
base sx/lx
支持mdi/x   √ √ √ √ √
背板吞
吐量(bps) 8.8g 5.2g 12.8g 8.8g 9.6g 4.8g 6.4g 4.8g 4.8g 9.6g 12g
缓冲区
大小 6m 2m 8m 6m 6m 16m 64m 512k 4m 6m 256k
最大mac
地址表 16k 8k 32k 32k 3k 4k 4k 4k 2k 8k 4k
支持trunking √ √ √ √ √ √ √ √
支持vlan √ √ √ √ √ √ √ √
端口镜像 √ √ √
支持网
管类型 telnet
snmp
rmon
web
  h.
link
snmp
hammer
view shell
nmp
tel
enet
web console
telenet
web
cli con
sole
snmp
tel
enet
web con
sole
snmp
tel
enet
web con
sole
snmp cli /web
telenet
snmp rmon
speedview

交换机的重要技术参数

下面我将对交换机的重要技术参数作一一介绍,方便网友在选购交换机时比较不同厂商的不同产品。每一个参数都影响到交换机的性能、功能和不同集成特性。
 1、转发技术:交换机采用直通转发技术或存储转发技术?

 2、延时:交换机数据交换延时多少?

 3、管理功能:交换机提供给拥护多少可管理功能?

 4、单/多MAC地址类型:每个端口是单MAC地址,还是多MAC地址?

 5、外接监视支持:交换机是否允许外接监视工具管理端口、电路或交换机所有流量?

 6、扩展树:交换机是否提供扩展树算法或其他算法,检测并限制拓扑环?

 7、全双工:交换机是否允许端口同时收/发,全双工通讯?

 8、高速端口集成:交换机是否提供高速端口连接关键业务服务器或上行主干?

 下面逐项讨论各项参数:

 1) 转发技术:(Forwarding Technologies)

 转发技术是指交换机所采用的用于决定如何转发数据包的转发机制。各种转发技术各有优缺点。

直通转发技术:(Cut-through)

交换机一旦解读到数据包目的地址,就开始向目的端口发送数据包。通常,交换机在接收到数据包的前6个字节时,就已经知道目的地址,从而可以决定向哪个端口转发这个数据包。直通转发技术的优点是转发速率快、减少延时和提高整体吞吐率。其缺点是交换机在没有完全接收并检查数据包的正确性之前就已经开始了数据转发。这样,在通讯质量不高的环境下,交换机会转发所有的完整数据包和错误数据包,这实际上是给整个交换网络带来了许多垃圾通讯包,交换机会被误解为发生了广播风暴。总之,直通转发技术适用与网络链路质量较好、错误数据包较少的网络环境。

存储转发技术:(Store-and-Forward)

存储转发技术要求交换机在接收到全部数据包后再决定如何转发。这样一来,交换机可以在转发之前检查数据包完整性和正确性。其优点是:没有残缺数据包转发,减少了潜在的不必要数据转发。其缺点是:转发速率比直接转发技术慢。所以,存储转发技术比较适应与普通链路质量的网络环境。

碰撞逃避转发技术:(Collision-avoidance)

某些厂商(3Com)的交换机还提供这种厂商特定的转发技术。碰撞逃避转发技术通过减少网络错误繁殖,在高转发速率和高正确率之间选择了一条折衷的解决办法。

 2) 延时:(Latency)

 交换机延时是指从交换机接收到数据包到开始向目的端口复制数据包之间的时间间隔。有许多因素会影响延时大小,比如转发技术等等。采用直通转发技术的交换机有固定的延时。因为直通式交换机不管数据包的整体大小,而只根据目的地址来决定转发方向。所以,它的延时是固定的,取决于交换机解读数据包前6个字节中目的地址的解读速率。采用存储转发技术的交换机由于必须要接收完了完整的数据包才开始转发数据包,所以它的延时与数据包大小有关。数据包大,则延时大;数据包小,则延时小。

 3) 管理功能:(Management)

 交换机的管理功能是指交换机如何控制用户访问交换机,以及用户对交换机的可视程度如何。通常,交换机厂商都提供管理软件或满足第三方管理软件远程管理交换机。一般的交换机满足SNMP MIB I / MIB II统计管理功能。而复杂一些的交换机会增加通过内置RMON组(mini-RMON)来支持RMON主动监视功能。有的交换机还允许外接RMON探监视可选端口的网络状况。

 4) 单/多MAC地址类型:(Single- versus Multi-MAC)

 单MAC交换机的每个端口只有一个MAC硬件地址。多MAC交换机的每个端口捆绑有多个MAC硬件地址。单MAC交换机主要设计用于连接最终用户、网络共享资源或非桥接路由器。它们不能用于连接集线器或含有多个网络设备的网段。多MAC交换机在每个端口有足够存储体记忆多个硬件地址。多MAC交换机的每个端口可以看作是一个集线器,而多MAC交换机可以看作是集线器的集线器。每个厂商的交换机的存储体Buffer的容量大小各不相同。这个Buffer容量的大小限制了这个交换机所能够提供的交换地址容量。一旦超过了这个地址容量,有的交换机将丢弃其它地址数据包,有的交换机则将数据包复制到各个端口不作交换。

 5) 外接监视支持:(Extendal Monitoring)

 一些交换机厂商提供“监视端口”(monitoring port),允许外接网络分析仪直接连接到交换机上监视网络状况。但各个厂商的实现方法各不相同。

 6) 扩展树:(Spanning Tree)

 由于交换机实际上是多端口的透明桥接设备,所以交换机也有桥接设备的固有问题—“拓扑环”问题(Topology Loops)。当某个网段的数据包通过某个桥接设备传输到另一个网段,而返回的数据包通过另一个桥接设备返回源地址。这个现象就叫“拓扑环”。一般,交换机采用扩展树协议算法让网络中的每一个桥接设备相互知道,自动防止拓扑环现象。交换机通过将检测到的“拓扑环”中的某个端口断开,达到消除“拓扑环”的目的,维持网络中的拓扑树的完整性。在网络设计中,“拓扑环”常被推荐用于关键数据链路的冗余备份链路选择。所以,带有扩展树协议支持的交换机可以用于连接网络中关键资源的交换冗余。

 7) 全双工:(Full Duplex)

 全双工端口可以同时发送和接收数据,但这要交换机和所连接的设备都支持全双工工作方式。具有全双工功能的交换机具有以下优点:

1、高吞吐量(Throughput):两倍于单工模式通信吞吐量。

2、避免碰撞(Collision Avoidance):没有发送/接收碰撞。

3、突破长度限制(Improved Distance Limitation):由于没有碰撞,所以不受CSMA/CD链路长度的限制。通信链路的长度限制只与物理介质有关。

 现在支持全双工通信的协议有:快速以太网、千兆以太网和ATM。

 8) 高速端口集成:(High-Speed Intergration)

交换机可以提供高带宽“管道”(固定端口、可选模块或多链路隧道)满足交换机的交换流量与上级主干的交换需求。防止出现主干通信瓶颈。常见的高速端口有:

FDDI:应用较早,范围广。但有协议转换花费。

Fast Ethernet / Gigabit Ethernet:连接方便,协议转换费用少;但受到网络规模限制。

ATM:可提供高速交换端口;但协议转换费用大。

ATM交换(ATM Switch)

 随着ATM交换技术的发展,现在企业网络中越来越多在高速网络主干或边缘网络采用ATM交换技术。根据现有企业计算的发展要求,适应数据网络交换的技术趋势,我们有必要了解ATM。ATM的数据交换由一个一个固定长度的ATM信元组成。每个ATM信元都是53字节长(5个字节长的信头和48字节长的信体)。信头包括虚拟通路(VP)和虚拟电路(VC)标识等地址信息。ATM根据VP和VC来确定信元的发送源地址和接收目的地址。

ATM交换机中的连接分为永久虚拟电路(PVC)和交换虚拟电路(SVC)两种。PVC是在源地址与目的地址之间的永久性硬件电路连接。SVC是根据实时交换要求建立的临时交换电路连接。两者的最大区别是:PVC不论是否有数据传输,它都保持连接;而SVC在数据传输完成后就自动断开。两者的应用区别是:在通常的ATM交换中,有一些PVC用于保持信号和管理信息通 讯,保持永久连接;而SVC主要用于大量的具体数据的传输。

 ATM交换另一个特点是:ATM本身就是全双工的。发送数据和接收数据在不同虚拟电路中同时进行,保持双向高速通讯。为了满足以太网帧(Frames)与ATM信元(Cells)的相互通讯要求,ATM协议标准规定了针对数据应用的ATM适配层(ATM Adaption Layer),它工作在帧交换和信元交换之间,将以太帧的逻辑电路层的地址信息对应得转换为虚拟电路VC、虚拟通路VP地址信息,完成帧-信元转换和信元-帧转换工作。

 ATM交换的广泛应用,也给交换网络的网络监视和管理带来了新的挑战。

 

虚拟局域网(VLAN)

 交换技术的发展,也加快了新的交换技术(VLAN)的应用速度。通过将企业网络划分为虚拟网络VLAN网段,可以强化网络管理和网络安全,控制不必要的数据广播。在共享网络中,一个物理的网段就是一个广播域。而在交换网络中,广播域可以是有一组任意选定的第二层网络地址(MAC地址)组成的虚拟网段。这样,网络中工作组的划分可以突破共享网络中的地理位置限制,而完全根据管理功能来划分。这种基于工作流的分组模式,大大提高了网络规划和重组的管理功能。

 在同一个VLAN中的工作站,不论它们实际与哪个交换机连接,它们之间的通讯就好象在独立的集线器上一样。同一个VLAN中的广播只有VLAN中的成员才能听到,而不会传输到其他的 VLAN中去,这样可以很好的控制不必要的广播风暴的产生。同时,若没有路由的话,不同VLAN之间不能相互通讯,这样增加了企业网络中不同部门之间的安全性。网络管理员可以通过配置VLAN之间的路由来全面管理企业内部不同管理单元之间的信息互访。交换机是根据用户工作站的MAC地址来划分VLAN的。所以,用户可以自由的在企业网络中移动办公,不论他在何处接入交换网络,他都可以与VLAN内其他用户自如通讯。

 VLAN可以是有混合的网络类型设备组成,比如:10M以太网、100 M以太网、令牌网、FDDI、CDDI等等,可以是工作站、服务器、集线器、网络上行主干等等。

 VLAN的管理需要比较复杂的专门软件,它通过对用户、MAC地址、交换机端口号、VLAN号等管理对象的综合管理,来满足整个网络的VLAN划分、监视等功能,以及其他扩展管理功能。现在比较通用的VLAN的划分方法是基于MAC地址。但也有一些厂商的交换机提供更多的VLAN划分方法:MAC地址、协议地址、交换机端口、网络应用类型和用户权限等等。

 用户在选择交换机的同时,应当仔细考察选购的交换机的VLAN功能,根据自己企业的实际需要,选择满足要求而且管理方便的交换机。同时,应当特别注意现在不同厂商的交换机的VLAN之间大多数是不兼容的。
ATM交换机通讯管理basic

1.为何需要通讯管理? 实现通讯策略:a.将线路划分为小的通道 b.避免一个VC占用整个带宽,影响其它VC上的通讯 c.控制某一应用所能利用的带宽范围 d.匹配本地端口速率与远端端口速率,避免过载或负载不足
2.Cisco 8540 MSR与 8510 MSR (需加FC-PFQ或FC-PCQ特性卡)支持的通讯业务类型:
CBR(固定速率服务): 固定速率服务,始终工作于信元峰值速率(PCR: Peak Cell Rate),网络已为之按PCR预留了带宽,应用于需要恒定带宽,延时要求高的应用,如未压缩的音视频流
VBR(可变比特速率服务): 分为两种 VBR-RT和VBR-NRT:实时/非实时可变比特速率服务。前者适用于压缩后的音视频流,因为它们具有可变流量,要求时延小的特点; 后者适用于要求较高的非实时数据传输。
ABR(可用比特速率服务):ABR服务的速率由端节点与ATM网络通过RM(Resource Management)信元协商,可以随时增减,但一旦链路建立,将保证一个最低的速率(MCR)。
UBR(未确定比特速率服): 适用于对时延和抖动要求不太严格的数据通信业务。网络不保证传输信元的带宽,而只是尽最大努力来尝试传送。在cisco的扩展版本UBR+中,ATM网络试图保证一个最低传送速率(MCR),但当网络阻塞严重时,MCR仍然不被保证。
上述业务类型之间的区别:传送时的优先级别不同的业务各不相同;保证的(预留的)带宽不同。例如VBR-NRT比UBR优先级高,前者有SCR保证而后者无。
每一种服务都有自已的特性从而适用于不同的场合,例如UBR虽然延时大,无最低速率保证,与此时却保证了最大程序的统计复用(全部带宽由各种应用共享),且可以为它分配更长的队列。队列技术将丢包率降到最低,代价是增加了延时。
3. 配置方法:
a. 在全局配置模式下定义一个服务类
Switch(config)#atm connection-traffic-table-row index 333 ?
abr abr service category
cbr cbr service category
ubr ubr service category
vbr-nrt vbr-nrt service category
vbr-rt vbr-rt service category
Switch(config)#atm connection-traffic-table-row ubr pcr 20000 mcr 8000 cdvt 1024 ?
以上命令在全局模试下用上述命令定义一个序号为333的服务类,参数见后面的说明。
出厂时已经预定义了六个服务类:
Switch#show atm connection-traffic-table
Row Service-category pcr scr/mcr mbs cdvt
1 ubr 7113539 none none
2 cbr 424 none
3 vbr-rt 424 424 50 none
4 vbr-nrt 424 424 50 none
5 abr 424 0 none
6 ubr 424 none none
b. 在端口配置模式下,建立一个PVC并指定其服务类
Switch(config-if)#atm pvc 0 256 ?
cast-type Connection cast type
interface Interface name
pd Packet discard options
rx-cttr Receive connection traffic table row index
tx-cttr Transmit connection traffic table row index
upc Usage Paramter Control options
wrr-weight WRR weight applied for the output leg
通过rx-cttr和tx-cttr指定一个上文已定义的服务类,分别应用于发送和接收的情况。
例:
atm pvc 0 256 rx-cttr 333 tx-cttr 333
c. 具体参数:
I) CBR:有两个参数,第一个是PCR,单位:KBPS; 另一个是cdvt(Cell Delay Variation Tolerance ):指出可以在多久时间内连续转送信元,而无需严格按照时间间隙。命令:
atm connection-traffic-table-row [index row-index] cbr pcr rate [cdvt cdvt]
II) VBR-RT与VBR-NRT:用三个参数来描述:SCR 信元基本速率: 预计VC传送数据所需要的大致速率; PCR 信元峰值速率: VC可以达到的最高速率; MBS最大突发转输量: 设定VC会需要以最速率PCR传送多少KBPS后放缓。当通讯的速率在SCR以下时正常发送;超过SCR但小于PCR且不超过MBS的量也正常发送;超过PCR或突发超过MBS的量被视为违规的,按UPC(利用率参数控制)则处理。UPC有三种处理方法:drop (丢弃) tag (加标记) 或 pass (转发)。命令:
atm connection-traffic-table-row [index row-index] {vbr-rt | vbr-nrt} pcr rate {scr0 | scr10} scrval [mbs mbsval] [cdvt cdvtval]
scr0: 所有信元的CLP(cell loss priority)设为0,设为1时更可能被丢弃
scr10: 通讯流中的信元的CLP可以根据情况设为0或1
III) UBR:标准的UBR只有PCR参数,MCR是cisco的扩展(UBR+)。命令:
atm connection-traffic-table-row [index row-index] ubr pcr rate [cdvt cdvtval] [mcr mcrval]
IV) ABR:有个参数,分别是PCR和MCR。命令:
atm connection-traffic-table-row [index row-index] abr pcr rate [cdvt cdvtval] [mcr mcrval]
参考: Configuring Resource Management

Catalyst 4000, Catalyst 2948G, Catalyst 2980G升级

Step 1:
rommon 1 > show interface
me1: inet 172.20.58.227 netmask 255.255.255.0 broadcast 172.20.58.255
rommon 2 > show ip route
Destination Gateway Interface
----------------------- ----------------------- ---------
default 0.0.0.0 me1
Step 2: Set the default gateway, if needed.
rommon 3 > set ip route default 172.20.58.1

Step 3:
rommon 5 > set
PS1=rommon ! >
AutobootStatus=success
MemorySize=32
DiagBootMode=post
?=0
ROMVERSION=4.4(1)
WHICHBOOT=bootflash:cat4000.4-4-1.bin
BOOT=bootflash:cat4000.4-4-1.bin,1;

rommon 6 > Tftpserver=172.20.59.67
!--- Setting TFTP server variable.
rommon 7 > set
!---Verifying the setting.
PS1=rommon ! >
AutobootStatus=success
MemorySize=32
DiagBootMode=post
Tftpserver=172.20.59.67
?=0
ROMVERSION=4.4(1)
WHICHBOOT=bootflash:cat4000.4-4-1.bin
BOOT=bootflash:cat4000.4-4-1.bin,1;

Step 4: Netboot the system.
rommon 9 > boot cat4000.4-4-1.bin

Step 5: After netbooting the system, you will get the switch console. Use the copy tftp Flash command to copy the valid image to the Flash

Cisco交换机设置点滴

Catalyst 1924/2820软件升级
一、使用TFTP server安装软件

通过网络为交换机更新软件,在服务器和交换机之间必须经由IP连接.

1.必须具有一台TFTP server(如运行TFTP server软件的PC机)和一台管理工作站(如一台PC机),并且可以通过console口管理交换机:
使用终端仿真程序(如win95的HyperTerminal)和RJ-45-to-RJ-45的连接电缆和适配器:
RJ-45-to-DB-9 female DTE 适配器(标记"Terminal"
RJ-45-to-DB-25 female DTE 适配器(标记"Terminal"
RJ-45-to-DB-25 male DCE 适配器(标记"Modem"
2.以下是通过TFTP server更新软件的步骤:
1)将Cisco Catalyst 1900/2820 软件存于管理工作站.
2)将TFTP根目录设置为软件所在目录.
3)打开交换机,交换机正常启动.
4)在终端窗口显示管理菜单画面(以下为管理菜单).
Management Console Main Menu
Catalyst 1900 - Main Menu
[C] Console Settings
[S] System
[N] Network Management
[P] Port Configuration
[A] Port Addressing
[D] Port Statistics Detail
[M] Monitoring
Bridge Group
[R] Multicast Registration
[F] Firmware
RS-232 Interface
Usage Summaries
[H] Help
[X] Exit Management Console
Enter Selection:
5)如交换机未赋予IP地址,应该使用菜单赋予交换机IP addresss, subnet mask, 和default gateway.
6)确认交换机和TFTP server之间的连接正常. 例如:从服务器PING交换机.
7)进入Firmware配置菜单, 选择[S]选项,并键入TFTP server的IP地址.
Catalyst 1900 - Firmware Configuration
-----------------System Information------------
FLASH: 1024K bytes
V6.00
Upgrade status:
No upgrade currently in progress.
--------------------Settings------------------
[S] Server: IP address of TFTP server 0.0.0.0
[F] Filename for firmware upgrades
[A] Accept upgrade transfer from other hosts Enabled
--------------------Actions-------------------
System XMODEM upgrade [D] Download test subsystem (XMODEM)
[T] System TFTP upgrade [X] Exit to Main Menu
Enter Selection:

8)选择[F]选项,键入TFTP server上的交换机软件的名称.
9)选择[T]选项执行 TFTP进行软件更新.
10)在菜单的系统信息区检查更新状态显示验证软件更新过程.
当软件更新完毕后,交换机大约有1分钟不响应命令,然后交换机重新启动并使用新的软件.

二、使用XMODEM协议安装软件
你可以通过通过XMODEM协议使用管理站为交换机更新软件.
软件安装的过程依靠你使用的modem软件.

1.你必须具有一台管理工作站(如一台PC机),并且可以通过console口管理交换机:
使用终端仿真程序(如win95的HyperTerminal)和RJ-45-to-RJ-45的连接电缆和适配器:
RJ-45-to-DB-9 female DTE 适配器(标记"Terminal"
RJ-45-to-DB-25 female DTE 适配器(标记"Terminal"
RJ-45-to-DB-25 male DCE 适配器(标记"Modem"
你可以使用win95的HyperTerminal(支持XMODEM协议).
2.以下是通过XMODEM协议更新软件的步骤:
1)打开交换机,交换机正常启动.
2)启动终端仿真程序,显示管理菜单.
3)从控制台显示RS-232 Interface 配置菜单,输入波特率(2400, 9600, 19200, 38400, 57600), data bits=8, stop bits=1, parity=none
使用57600波特率安装软件大约花10分钟时间.
4)从RS-232 Interface菜单,选择[G]选项激活组设置用于console口.
5)管理站要匹配console口的设置.
6)进入Firmware配置菜单,选择选项使用XMODEM协议去安装软件.
7)在提示符下,选择Y启动软件安装过程.
8)在菜单的系统信息区检查更新状态显示验证软件更新过程.
当软件更新完毕后,交换机大约有1分钟不响应命令,然后交换机重新启动并使用新的软件.


--------------------------------------------------------------------------------
努力做一名真正拥有丰富实践经验和理论知识的互联网专家!
交换机虚拟网(Virtual LANs)的设置:
Catalyst 5000上实现VLAN划分及外部VLAN路由设置
分配VTP域(a VTP Domain)
将Cat5000加入域
指定中继端口(a Trunk)
Dynamic ISL
分配VLAN到端口
设置VLAN 20
配置Router
-------------------------------------------------------------------

注:存在三个VLAN,在VLAN之间通过Router做路由.
-----------------------------------------------------------------
分配VTP域
什么是VTP?
VTP是VLAN Trunk Protocol的简写,它提供每个设备 (router 或 LAN-switch)在中继端口(trunk ports)发送广播. 这些广播被发送到一个组播地址,并被所有相邻设备接收. 这些广播列出了发送设备的管理域,它的配置修订号,已知的VLAN, 及已知VLAN的确定参数.通过听这些广播,在相同管理域的所有设备都可以学习到在发送设备上配置的新的VLAN.使用这种方*,新的 VLAN只需要在管理域内的一台设备上建立和配置.信息会自动被相同管理域内的其它设备学到.
分配VTP域
首先分配VTP域名(a VTP domain name),在相同管理域内的交换机可以通过VTP协议互相学习VTP信息.

Cat5001> (enable) sho vtp domain
Domain Name Domain Index VTP Version Local Mode
-------------------------------- ------------ ----------- -----------
1 1 server
Advt Interval Vlan-count Max-vlan-storage Config Revision SNMP Traps
------------- ---------- ---------------- --------------- -----------
300 5 256 0 disabled
Last Updater
---------------
0.0.0.0
Cat5001> (enable)
Cat5001> (enable) set vtp domain cisco
VTP domain cisco modified
Cat5001> (enable) sho vtp domain
Domain Name Domain Index VTP Version Local Mode
-------------------------------- ------------ ----------- -----------
cisco 1 1 server
Advt Interval Vlan-count Max-vlan-storage Config Revision SNMP Traps
------------- ---------- ---------------- --------------- -----------
300 5 256 0 disabled
Last Updater
---------------
0.0.0.0
Cat5001> (enable)

--------------------------------------------------------------------------------
将Catalyst 5002加入域
需要将Catalyst 5002加入名为cisco的VTP管理域, 并设为VTP client,它将接收来自VTP server 的VTP配置及更新.
注意:Catalyst 5000系列交换机默认为VTP server.

cat5002> (enable)
cat5002> set vtp domain cisco mode client

指定中继端口(Trunk ports)
VLAN Trunk协议(VTP)只在中继口(ISL , LANE 和802.10)上传输,应在二个Catalyst5000
交换机间定义哪个口作为中继端口(Trunk port).
Inter-Switch Link (ISL) 中继用于Fast Ethernet和Gigabit Ethernet端口
IEEE 802.10中继用于FDDI/CDDI端口
LAN Emulation (LANE) 中继用于ATM 端口
Cat5001> (enable) set trunk 1/1 on
Port 1/1 mode set to on.
Cat5001> (enable)
Wed Jun 19 1996, 15:00:02 Port 1/1 has become trunk.

--------------------------------------------------------------------------------
Dynamic ISL
有了DISL(Dynamic ISL), 你不需要修改远端的Catalyst 5000;以下信息将显示在远端的Catalyst 5000.

Wed Jun 19 1996, 15:51:59 Port 1/2 has become trunk.
Cat5001> (enable) sho trunk
Port Mode Status
------- --------- ------------
1/1 on trunking
1/2 auto not-trunking
2/1-2 off not-trunking
5/1 auto not-trunking
5/2 auto not-trunking
5/3 auto not-trunking
5/4 auto not-trunking
5/5 auto not-trunking
5/6 auto not-trunking
5/7 auto not-trunking
5/8 auto not-trunking
5/9 auto not-trunking
5/10 auto not-trunking
5/11 auto not-trunking
5/12 auto not-trunking
Port Vlans allowed
------- ---------------------------------------------------------------------
1/1 1-1000
1/2 1-1000
2/1-2 1-1000
5/1 1-1000
5/2 1-1000
5/3 1-1000
5/4 1-1000
5/5 1-1000
5/6 1-1000
5/7 1-1000
5/8 1-1000
5/9 1-1000
5/10 1-1000
5/11 1-1000
5/12 1-1000
Port Vlans active
------- ---------------------------------------------------------------------
1/1 1
1/2 1
2/1-2 1
5/1 1
5/2 1
5/3 1
5/4 1
5/5 1
5/6 1
5/7 1
5/8 1
5/9 1
5/10 1
5/11 1
5/12 1

注意: DISL在Cisco IOS软件中不支持.

--------------------------------------------------------------------------------
分配VLAN到端口
Cat5001> (enable) set vlan 2 3/2-20
VLAN 2 modified.
VLAN 1 modified.
VLAN Mod/Ports
---- -----------------------
2 1/1
3/2-20

Cat5001> (enable) set vlan 20 5/1-6
VLAN 20 modified.
VLAN 1 modified.
VLAN Mod/Ports
---- -----------------------
20 1/1
5/1-6

Configure additional information for VLAN 20.
On the other Catalyst 5000 :

Cat5002> (enable) set vlan 2 4/1-2,5/6-12
VLAN 2 modified.
VLAN 1 modified.
VLAN Mod/Ports
---- -----------------------
2 1/2
4/1-3,4/5-23
5/6-12

Configure additional information for VLAN 20.

Cat5002> (enable) set vlan 20 5/1-5
VLAN 20 modified.
VLAN 1 modified.
VLAN Mod/Ports
---- -----------------------
20 1/2
5/1-5

Configure VLAN 20 on a VTP server.

--------------------------------------------------------------------------------
显示端口配置
Cat5001> (enable) show port
Port Name Status Vlan Level Duplex Speed Type
---- -------------------- ---------- ---------- ------ ------ ----- -----------
1/1 connected 1 normal half 100 100BaseTX
1/2 connected trunk normal half 100 100BaseTX
2/1 connecting 1 normal half 100 FDDI
2/2 connected 1 normal half 100 FDDI
4/1 inactive 2 normal half 10 10BaseT
4/2 inactive 2 normal half 10 10BaseT
4/3 inactive 2 normal half 10 10BaseT
4/4 notconnect 1 normal half 10 10BaseT
4/5 inactive 2 normal half 10 10BaseT
4/6

此时, VLAN 2 和VLAN 20 还未激活.所以在VLAN 2和VLAN 20的端口是inactive状态.

--------------------------------------------------------------------------------
设置VLAN 20
如果在网络里有VTP server和VTP clent,请在VTP server上设置VLAN 20

Cat5001> (enable) set vlan 20
VLAN 20 modified

这将激活在所有管理域cisco内的VLAN 20

Cat5001> (enable) sho vlan 20
VLAN Name Status Mod/Ports
---- -------------------------------- --------- ----------------------------
20 VLAN0020 active 1/1
5/1-6

VLAN Type SAID MTU Parent RingNo BridgeNo Stp Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- ------ ------
20 enet 100020 1500 - - - - 0 0

--------------------------------------------------------------------------------
配置Router
conf t
interface FastEthernet0/0.1 <-- you need to create a sub-interface by vlan.
encapsulation isl 20 <-- 20 is the vlan number.
ip address 1.1.1.1 255.255.255.0
interface FastEthernet0/0.2
encapsulation isl 2
ip address 2.2.2.1 255.255.255.0
interface FastEthernet0/0.3
encapsulation isl 1
ip address 172.16.80.1 255.255.255.0
Router eigrp 666
network 1.0.0.0
network 2.0.0.0
network 172.16.80.0
end
writ mem

DHCP SERVER迁移到6509交换机的MSFC

一位客户想把DHCP SERVER迁移到6509交换机的MSFC上,要求还挺复杂:
1.同时为多个VLAN的客户机分配地址
2.VLAN内有部分地址采用手工分配的方式
3.为客户指定网关、Wins服务器等
4.VLAN 2的地址租用有效期限为1天,其它为3天
5.按MAC地址为特定用户分配指定的IP地址
最终配置如下:
ip dhcp excluded-address 10.1.1.1 10.1.1.19 //不用于动态地址分配的地址
ip dhcp excluded-address 10.1.1.240 10.1.1.254
ip dhcp excluded-address 10.1.2.1 10.1.2.19
!
ip dhcp pool global //global是pool name, 由用户指定
network 10.1.0.0 255.255.0.0 //动态分配的地址段
domain-name client.com //为客户机配置域后缀
dns-server 10.1.1.1 10.1.1.2 //为客户机配置dns服务器
netbios-name-server 10.1.1.5 10.1.1.6 //为客户机配置wins服务器
netbios-node-type h-node //为客户机配置节点模式(影响名称解释的顺利,如h-node=先通过wins服务器解释...)
lease 3 //地址租用期限: 3天
ip dhcp pool vlan1
network 10.1.1.0 255.255.255.0 //本pool是global的子pool, 将从global pool继承domain-name等option
default-router 10.1.1.100 10.1.1.101 //为客户机配置默认网关
!
ip dhcp pool vlan2 //为另一VLAN配置的pool
network 10.1.2.0 255.255.255.0
default-router 10.1.2.100 10.1.2.101
lease 1
!
ip dhcp pool vlan1_john //总是为MAC地址为...的机器分配...地址
host 10.1.1.21 255.255.255.0
client-identifier 010050.bade.6384 //client-identifier=01加上客户机网卡地址
!
ip dhcp pool vlan1_tom
host 10.1.1.50 255.255.255.0
client-identifier 010010.3ab1.eac8

相关的DHCP调试命令:
no service dhcp //停止DHCP服务[默认为启用DHCP服务]
sh ip dhcp binding //显示地址分配情况
show ip dhcp conflict //显示地址冲突情况
debug ip dhcp server {events | packets | linkage} //观察DHCP服务器工作情况

如果DHCP客户机分配不到IP地址,常见的原因有两个。第一种情况是没有把连接客户机的端口设置为Portfast方式。MS客户机开机后检查网卡连接正常,Link是UP的,就开始发送DHCPDISCOVER请求,而此时交换机端口正在经历生成树计算,一般需要30-50秒才能进入转发状态。MS客户机没有收到DHCP SERVER的响应就会给网卡设置一个169.169.X.X的IP地址。解决的方法是把交换机端口设置为Portfast方式:CatOS(4000/5000/6000): set spantree portfast mod_num/port_num enable; IOS(2900/3500): interface ... ; spanning-tree portfast。

另外一种情况是DHCP服务器和DHCP工作站不在同一个VLAN,这时候通常通过设置ip helper-address来解决:

interface vlan1
ip address 10.1.1.254 255.255.255.0 //假设DHCP服务器地址为10.1.1.8
interface Vlan2
ip address 10.1.2.254 255.255.255.0
ip helper-address 10.1.1.8 //假设这是DHCP客户机所在的VLAN
第三层交换建设企业VLAN

虚拟局域网(VLAN)的出现打破了传统网络的许多固有观念,使网络结构变得灵活、方便、随心所欲。VLAN就是不考虑用户的物理位置而根据功能、应用等因素将用户逻辑上划分为一个个功能相对独立的工作组,每个用户主机都连接在一个支持VLAN的交换机端口上并属于一个VLAN。同一个VLAN中的成员都共享广播,而不同VLAN之间广播信息是相互隔离的。这样,将整个网络分割成多个不同的广播域。
传统的路由器在网络中有路由转发、防火墙、隔离广播等作用,而在一个划分了VLAN以后的网络中,逻辑上划分的不同网段之间通信仍然要通过路由器转发。由于在局域网上,不同VLAN之间的通信数据量是很大的,这样,如果路由器要对每一个数据包都路由一次,随着网络上数据量的不断增大,路由器将不堪重负,路由器将成为整个网络的瓶颈。

在这种情况下,出现了第三层交换技术,通俗地讲,就是将路由技术与交换技术合二为一的技术。路由器在对第一个数据流进行路由后,将会产生一个MAC地址与IP地址的映射表,当同样的数据流再次通过时,将根据此表直接从二层通过而不是再次路由,从而消除了路由器进行路由选择而造成网络的延迟,提高了数据包转发的效率,消除了路由器可能产生的网络瓶颈问题。

配置VLAN

(1) VLAN的工作模式:

静态VLAN:管理员针对交换机端口指定VLAN。

动态VLAN:通过设置VMPS(VLAN Membership Policy Server),包含了一个MAC地址与VLAN号的映射表,当数据帧到达交换机后,交换机会查询VMPS获得相应MAC地址的VLAN ID。

(2) ISL标签:ISL(Inter-Switch Link)是一个在交换机之间、交换机与路由器之间及交换机与服务器之间传递多个VLAN信息及VLAN数据流的协议,通过在交换机直接相连的端口配置ISL封装,即可跨越交换机进行整个网络的VLAN分配和进行配置。

VLAN封装的国际标准为IEEE 802.1Q。

(3) VTP(VLAN Trunking Protocol):它是一个在交换机之间同步及传递VLAN配置信息的协议。一个VTP Server上的配置将会传递给网络中的所有交换机,VTP通过减少手工配置而支持较大规模的网络。VTP有三种模式:


Server模式:允许创建、修改、删除VLAN及其他一些对整个VTP域的配置参数,同步本VTP域中其他交换机传递来的最新的VLAN信息。

Client模式:在Client模式下,一台交换机不能创建、删除、修改VLAN配置,也不能在NVRAM中存储VLAN配置,但可以同步由本VTP域中其他交换机传递来的VLAN信息。

Transparent模式:可以进行创建、修改、删除,也可以传递本VTP域中其他交换机送来的VTP广播信息,但并不参与本VTP域的同步和分配,也不将自己的VLAN配置传递给本VTP域中的其他交换机,它的VLAN配置只影响到它自己。

交换机在默认情况下为Server模式。

(4) 创建VLAN,默认情况下交换机只有VLAN 1,可以通过命令增加所需的VLAN。

(5) 将VLAN指定给交换机的各个端口。默认情况下交换机所有端口均属于VLAN 1,可以通过全局命令修改交换机各端口的VLAN ID,但交换机每个端口只能属于一个VLAN。

配置三层交换

配置MLSP协议,使RP与SE之间可以交换信息。

配置管理端口,MLSP通过这个端口收发RP与SE之间的通信。

针对不同的VLAN分配不同的VLAN网关地址。

启动路由器的路由功能。

根据需要,可以定义VLAN虚网间的访问策略,可通过定义访问列表来实现。



--------------------------------------------------------------------------------

相关文章
趣谈大数据【华为内部狂转的想象力惊人的好文】 2014/4/21 10:23:16
Cisco路由器故障诊断技术详解 2014/2/8 23:20:14
cisco交换机 端口速率限制实现实例 2013/6/21 19:11:57
TCP/UDP常见端口参考 2013/5/23 15:26:35
Cisco交换机 DHCP Snooping功能 2013/4/27 10:42:57
Cisco 交换机与路由器故障处理方法分享 2013/4/27 10:41:58
将物理数据中心向云计算迁移的四大步骤 2012/3/19 9:42:19
防恶意扫描 PortSentry保护Linux服务器 2011/10/23 13:08:21
如何创建一个用于网络监控的网络性能基线 2011/9/19 15:45:13
Cisco IOS Site-to-Site Vpn配置案例 2011/7/14 15:47:14
23道思科网络面试题及解答 2011/3/22 12:58:43
Cisco设备光模块解密方法 2010/5/20 9:57:00
安全审计自己动手 2010/4/14 11:12:19
化解网络安全风险从设置交换机开始 2010/4/5 11:57:46
如何让Cisco路由器远离DoS攻击 2010/4/5 11:53:38
NetEye防火墙与Cisco路由器的安全问题 2010/4/5 11:50:04
思科Private VLAN与Switchport Protected 2010/3/17 12:30:45
如何让Cisco路由器远离DoS攻击 2010/3/17 12:28:38
管理思科路由器的十大蠢事 2009/12/16 13:13:32
思科Private VLAN与Switchport Protected 2009/12/16 13:09:44
cisco设备大全 2009/12/16 13:08:34
Cisco交换机端口ipmac绑定 2009/7/28 12:59:09
服务器虚拟化对网络配置的影响 2009/4/21 12:56:09
思科IOS文件管理命令 2009/3/13 21:15:53
怎样使用NetFlow分析网络异常流量 2009/3/13 21:13:48
路由器崩溃故障排除 2009/2/2 12:44:19
理解掌握Cisco错误消息 2009/2/2 12:42:44
vrrp简介 2008/8/20 14:46:21
loopback具体作用 2008/8/20 14:45:14
带外网管:小成本管理大网络 2008/8/20 14:42:00
熟悉ROM Monitor维护路由器 2008/8/7 14:18:42
教你如何防范服务器缓存投毒和域名劫持 2008/7/30 16:53:23
Priority VS Bandwidth 2008/7/16 8:24:52
怎样使用NetFlow分析网络异常流量 2008/6/7 11:27:29
Cisco(思科)路由器上如何防止DDoS 2008/6/7 11:24:30
cisco ASA防火墙配置笔记 2008/6/7 11:22:48
cisco PIX防火墙的配置及注解完全手册 2008/6/7 11:21:40
EzVPN Client 完整配置 2008/6/7 11:19:48
电信运营商使用rate-limte 限制速度方法 2008/1/10 17:57:09
通过设置Cisco路由器D.D.O.S攻击手段的细节 2008/1/10 17:49:44
Cisco 2621 端口限速配置实例 2008/1/10 17:47:51
为基于类的策略选择突发数据量和超额突发数据量 2008/1/10 17:44:44
限制BT下载的QOS配置实例 2008/1/10 17:43:47
Cisco路由器上防止分布式拒绝服务(DDoS) 2008/1/10 9:07:50
NAC网络准入--整个初始化过程 2008/1/9 9:14:11
在思科路由器上确定和跟踪DoS攻击源 2007/12/24 14:38:56
Cisco路由器IOS系统升级方法总结 2007/11/19 13:53:18
交换机出现err-disable的原因及解决方法 2007/11/19 13:42:35
路由技术 利用路由器防止DoS疯狂攻击 2007/11/19 13:36:33
路由器中的内存分类 2007/9/18 14:04:26
路由技术如何利用路由器防DoS疯狂攻击 2007/9/18 14:02:03
Cisco Switching Mode Discussion(五种交换模式辨析) 2007/8/30 10:43:57
Cisco的MAC地址与IP绑定 2007/7/19 8:46:45
如何进行SPF解析-SPF是国际知名的反垃圾标准 2007/7/4 13:29:45
用Cisco IOS阻止访问特定网站具体步骤 2007/6/30 14:28:09
电信网通双出口负载分担配置指导 2007/6/30 14:24:58
Cisco PIX inside、outside和dmz之间的访问 2007/6/30 14:19:37
交换机出现err-disable原因及解决方法 2007/6/20 17:16:56
NTP网络时钟协议的实现 2007/6/6 15:43:49
AR系列路由器两种ACL匹配规则的介绍 2007/5/21 17:21:34
Cisco路由器如何防止DDoS攻击 2007/5/10 14:47:23
Cisco IOS Cookbook 中文精简版第二十七章安全 2007/5/9 10:09:28
故障检测检查表 2007/5/5 14:55:08
Cisco IOS Cookbook 中文精简版第二十四章移动IP 2007/4/3 9:02:55
Cisco IOS Cookbook 中文精简版第十七章 SNMP 2007/4/2 9:22:27
Cisco IOS Cookbook 中文精简版第十六章路由器接口 2007/4/2 9:21:05
Cisco IOS Cookbook 中文精简版第十三章拨号备份 2007/3/28 9:07:17
Cisco IOS Cookbook 中文精简版第十二章隧道和VPN 2007/3/28 9:06:30
Cisco IOS Cookbook 中文精简版第十章 帧中继 2007/3/28 9:02:55
Cisco IOS Cookbook 中文精简版第八章OSPF 2007/3/28 9:00:40
Cisco IOS Cookbook 中文精简版第二章路由器管理 2007/3/28 8:54:38
Cisco IOS Cookbook 中文精简版第一章路由器配置和文件管理 2007/3/28 8:53:46
Catalsty 4908G-L3 VLAN间的路由和桥接 2007/3/14 8:55:01
JUNOS、IOS、VRP对比 2007/3/7 12:27:38
Cisco 3550速率限制的详细配置过程 2007/1/24 8:46:39
VLAN之间ACL和VACL的区别 2007/1/24 8:43:59
加速cisco交换机初始化过程 2006/12/27 9:20:45
Cisco交换机接口模式精解 2006/12/25 9:47:10
让路由器成为你防范的堡垒 2006/12/14 13:58:13
mpls vpn故障排除 2006/12/11 10:57:08
Cisco交换机接口模式精解 2006/12/11 10:55:30
镜像端口建立方法 2006/12/11 10:54:50
L2与L3 VPN的详细介绍与对比 2006/12/4 16:54:19
新一代网络安全接入技术对比分析 2006/12/4 16:40:41
IP网限制p2p应用流量的qos策略 2006/12/4 12:55:03
理解Cisco错误消息 2006/11/28 9:14:05
Cisco 路由器语句汇总 2006/11/28 9:12:36
IP网限制p2p应用流量的qos策略 2006/11/27 15:06:01
使用Cisco命令阻止访问特定网站 2006/11/14 8:26:00
基于路由器网络诊断步骤和故障排除技巧 2006/11/14 8:24:45
论广播风暴的成因、预防及排障 2006/11/14 8:23:37
解决实际维护网络过程故障的五个盲点 2006/11/10 9:00:29
分析CISCO与华为3COM路由器配置差别 2006/10/31 8:27:54
思科站点大集合 2006/10/31 8:26:52
Cisco IOS防火墙的安全规则和配置方案 2006/10/28 10:07:06
交换机出现err-disable的原因及解决方法 2006/10/28 10:00:22
排除路由器崩溃故障 2006/10/28 9:59:03
三层交换机技术中常提到的TRUNK 2006/10/28 9:57:02
Catalyst 4006交换机的配置实例 2006/10/28 9:56:03
Cisco防火墙技术汇总 2006/10/28 9:50:56
抵御DDoS攻击 2006/10/28 9:46:05
帧中继故障的诊断与排除 2006/10/16 11:12:00
用命令行在设备上查看机框序列号 2006/10/10 12:59:24
保护路由器的十四招 2006/9/27 17:33:41
MAC地址的访问控制 2006/9/13 19:28:58
VRF Selection using by source ip 2006/9/13 19:25:53
华为Display interface的显示信息详解 2006/9/13 19:21:44
交换机接口出现err-disable的几个常见原因 2006/9/13 19:17:58
针对目前出现的ARP欺骗攻击行为,提出Cisco的解决方案 2006/8/30 16:33:25
六大步骤顺利排除计算机网络连接故障 2006/8/29 10:37:25
华为Display interface的显示信息详解 2006/8/28 13:01:16
配置思科三层交换的综合案例 2006/8/9 17:07:03
Catalyst 4006交换机的配置实例 2006/8/9 17:01:46
网络路由安全攻防对策分析及实践 2006/8/8 18:55:12
核心网络设备配置及参数如何备份 2006/8/8 18:53:00
配置cisco vpn client使用scep从ios router ca获取证书 2006/8/4 7:46:25
NAT+DHCP+HSRP+ACL+NTP配置实例 2006/8/4 7:02:10
解决在DHCP环境下私自指定IP和私自搭建DHCP服务器的方法 2006/8/4 7:00:32
用ACL构建防火墙体系 2006/8/2 14:43:20
Cisco 网际操作系统(IOS)命名规范(图) 2006/8/2 14:33:02
Cisco实战:配置三层交换的综合案例 2006/8/2 14:30:15
网络故障处理手册 2006/7/25 14:09:43
设置交换机span以进行侦听 2006/7/22 17:24:20
交换机升级排障 2006/7/18 17:57:24
Cisco配置手记 2006/7/17 10:08:27
ASA 5520配置例子 2006/7/14 9:47:04
思科路由器全局、接口、协议调试 2006/7/14 9:45:18
Cisco路由器故障诊断技术(重新编辑) 2006/7/14 9:42:38
关于IP-MAC绑定的交换机设置 2006/7/14 9:41:11
如何使用Cisco IOS文件系统命令 2006/7/13 8:14:53
rate-limit 使用方法 2006/7/11 14:50:13
用Xmodem的方式升级IOS 2006/7/10 14:27:22
Cisco交换机POST过程排错 2006/7/4 19:51:10
交换机 VLAN配置基础及实例 2006/7/4 19:48:33
轻松玩转Cisco路由器密码 2006/7/4 19:22:38
路由器默认密码 2006/6/28 23:05:49
路由器交换机配置信息及口令的清除 2006/6/28 23:01:47
用snort和空IP做一个安全的log纪录服务器 2006/6/17 11:09:10
工作中处理交换机频繁吊死故障实例 2006/6/13 8:41:14
在Cisco交换机上实现隔离访问 2006/6/13 8:36:02
多VLAN环境下DHCP服务的实现 2006/6/12 9:12:24
路由器网络接口字段详细解析 2006/6/12 9:09:43
小议TCP的MSS(最大分段)以及MTU 2006/6/9 21:06:48
一些有关网络的故障案例 2006/6/9 20:36:48
入侵检测系统逃避技术和对策的介绍 2006/6/7 9:25:12
网络流量监控的常用方法 2006/6/3 12:47:41
MPLS-VPN的最佳解决方案 2006/6/3 12:43:30
MPLS VPN 路由器与交换机选购指南 2006/5/30 14:27:52
思科路由器常用配置命令大全(A-X) 2006/5/29 9:21:21
TRUNK”的三个意思,不要混淆 2006/5/29 9:19:29
NetFlow交换及其在网络管理中的应用 2006/5/28 17:22:00
网络安全讲座之八:审计结果 2006/5/24 19:46:24
网络安全讲座之七:IDS系统 2006/5/24 19:45:52
网络安全讲座之六:侦察与工具 2006/5/24 19:43:53
Cisco VPN连接配置实例 2006/5/24 11:36:31
网络专业人士笔记 2006/5/22 10:06:48
用Cisco产品和功能构建安全的网络 2006/5/10 10:37:05
三层MPLS VPN及其故障处理 2006/5/8 19:45:11
路由器网络服务安全配置 2006/5/8 19:37:22
vsftp配置大全 2006/5/6 18:17:32
防黑全攻略——端口扫描技术 2006/4/30 13:24:46
在Cisco设备上实现IOS DHCP Server的功能 2006/4/30 12:31:15
RFC2328 OSPF V2 中文版 2006/4/27 20:40:32
透视网络管理技术 (网络管理、网络维护) 2006/4/6 20:01:31
负载均衡技术的三种实现方法 2006/4/6 19:53:21
基于路由器的网络诊断技术 2006/4/6 19:35:16
网络故障诊断初探 2006/4/6 19:27:33
网络分析监听技术之原理、应用与防范 2006/4/6 19:22:39
向P2P通信宣战(关于封BT下载软件) 2006/4/4 8:07:19
边界网关协议版本4(BGP-4) RFC1771 2006/3/30 22:30:28
故障检测检查表 2006/3/30 22:09:03
基于MPLS的流量工程要求(RFC2702) 2006/3/30 21:57:05
MPLS标记栈编码(RFC3032) 2006/3/30 21:54:27
IP VPN的框架体系(RFC2764) 2006/3/30 21:52:32
BGP团体属性(RFC1997) 2006/3/30 21:51:35
BGP路由反射(RFC2796) 2006/3/30 21:51:06
BGP MPLS VPNs(RFC2547) 2006/3/30 21:50:22
典型局域网多VLAN配置实例 2006/3/28 13:12:03
利用Catalyst交换机防范蠕虫病毒 2006/3/28 13:00:21
cisco四种类型的网络防火墙技术汇总 2006/3/20 12:59:53
在Cisco交换机上实现隔离访问 2006/3/20 12:55:26
让路由器远离字典DoS攻击 2006/3/8 11:21:00
策略路由概览 2006/3/8 11:15:41
802.1x:老根发新芽 2006/3/8 10:55:52
配置示例:Catalyst与 CatOS 交换机之间的 ISL/802.1q 中继 2006/3/7 9:32:13
用route map实现多ISP Internet接入工程实例 2006/3/6 8:39:09
配置三层交换的综合事例 2006/3/6 8:36:39
Cisco交换机集群技术 2006/3/1 8:39:10
排除路由故障 2006/3/1 8:37:26
访问控制列表使用原则 2006/3/1 8:34:49
常用品牌交换机端口镜像(Port Mirroring)配置 2006/2/23 14:08:02
Catalyst3550的三层交换与VLAN 2006/2/14 15:24:44
Cisco产品采用的网络协议总结 2006/1/12 14:15:24
Cisco Catalyst 2950 配置-实现端口与IP的绑定 2006/1/9 8:56:17
auto secure命令的使用 2006/1/4 13:48:11
用Cisco产品和功能构建安全的网络 2006/1/4 13:46:58
Cisco Catalyst 2950 配置-实现端口与IP的绑定 2005/12/25 14:51:46
关于IP-MAC绑定的交换机设置 2005/12/13 14:48:09
Cisco IOS访问列表的应用 2005/11/26 20:17:04
Cisco IOS进程调试 2005/11/26 20:15:38
掌握Cisco IOS测试命令的多种用法 2005/11/26 20:13:12
Cisco IOS命名规则 2005/11/26 20:11:25
Configuring Dynamic VLANs 2005/11/24 14:05:15
Catalyst5500交换机 VLAN设置 2005/11/24 10:25:33
思科IOS 12.3新特性 2005/11/21 9:32:14
《网络基础学习之二十》路由器的配置 2005/11/11 10:03:00
《网络基础学习之十九》路由器的硬件连接 2005/11/11 10:01:42
《网络基础学习之十八》主要路由器技术 2005/11/11 10:00:42
《网络基础学习之十七》路由器原理、分类和选购 2005/11/11 9:59:28
《网络基础学习之十六》路由器基础 2005/11/11 9:58:20
《网络基础学习之十五》交换机VLAN的配置 2005/11/11 9:57:10
《网络基础学习之十四》交换机配置全接触 2005/11/11 9:56:00
《网络基础学习之九》集线器的安装与连接 2005/11/11 9:48:54
《网络基础学习之六》初识网络体系结构与协议 2005/11/11 9:42:59
VPN实例配置方案-中文注解 2005/11/5 21:42:09
IPSEC 安全架构、应用及展望 2005/11/5 20:58:28
用ACL构建防火墙体系 2005/11/4 11:16:35
华为路由器与CISCO路由器在配置上的差别 2005/11/3 14:40:32
以太网络建立多个VLAN典型案例 2005/11/3 14:32:24
系统入侵者攻击企业或敏感数据网络方法白皮书 2005/10/11 10:52:53
AAA之配置授权 2005/9/20 15:20:29
Cisco ios 软件的安装升级方法 2005/9/20 14:09:04
VPN 配置之一:vpn access server 2005/9/7 16:33:42
Cisco 路由器 VPN典型配置 2005/9/7 16:08:09
负载均衡技术全攻略 2005/8/19 8:33:25
思科认证的36个热门考点 2005/8/11 14:16:05
网络使用的学习总结 2005/8/10 8:27:09
一块网卡绑定多IP与多网卡使用一个IP 2005/8/8 9:38:37
如何利用Catalyst交换机及时发现、追踪和缓解蠕虫病毒的入侵? 2005/8/4 13:31:23
CISCO交换机的数据监控 2005/8/4 13:00:36
在Catalyst 2948G-L3交换机上使用BVI配置IP上行链路重定向功能 2005/8/4 12:58:24
Cisco交换机实现端口安全的方法及事项 2005/8/4 12:54:23
Cisco路由器的备份配置方法 2005/8/4 12:53:32
路由选择原理 2005/8/4 12:49:14
How to Determine Which Switch and Port You are Connected To 2005/7/28 8:34:13
基于路由器网络诊断步骤和故障排除技巧 2005/7/25 10:13:25
利用Catalyst交换机防范蠕虫病毒的入侵 2005/7/8 8:32:43
3种方法封锁BT下载 2005/6/28 10:26:26
CCNP-CIT中文笔记 完整版 2005/6/24 15:31:49
用NBAR来防止红色代码(Code Red)和尼姆达(Nimda)蠕虫病毒 2005/6/22 10:13:20
细讲解第三层交换技术 2005/6/22 8:16:10
路由器(Router)原理介绍 2005/6/22 7:58:05
交换机(Switch)工作原理 2005/6/22 7:57:16
网络流量监控器mrtg全攻略 2005/6/17 15:03:36
流量检测的几种方案 2005/6/17 14:59:54
教你识别思科交换机型号 2005/6/11 21:49:53
多个网卡绑定一个IP地址(bonding) 2005/6/10 21:18:12
如何删除IOS--CISCO IFS简介 2005/6/10 21:05:56
软件vpn与硬件的优势对比 2005/6/3 12:14:03
把linux配置成pix 的日志主机 2005/6/3 12:07:51
通俗易懂的《路由和交换》 2004/11/19 9:24:31
CCNA考试命令集 2004/11/9 10:47:49
如何配置Cisco PIX防火墙 2004/11/9 10:11:50
Cisco常见配置 2004/11/9 10:04:39
各种交换机的镜像配置(cicsoc、华为、3com、Avaya、Intel) 2004/11/9 9:55:40
多个网卡绑定一个IP地址(bonding) 2004/10/19 8:41:07
系统安全名词列表(2) 2004/10/8 9:40:16
系统安全名词列表(1) 2004/10/8 9:38:02
华为、Intel与Cisco的交换机产品使用感受 2004/9/13 8:29:36
配置三层交换的综合范例 2004/9/1 11:20:39
怎样在Cisco设备上实现IOS DHCP Server的功能 2004/9/1 11:19:27
show controller e1(带注释) 2004/8/29 12:32:50
常见的CatcOs错误消息在Cisco Catalyst 交换机 2004/8/29 12:29:00
配置和排除以太网10/100/1000Mb Half/Full双工自动协商故障 2004/8/29 12:23:23
CISCO的快速转发 2004/8/29 12:19:05
4000 6500交换引擎配置方法. 2004/8/29 12:04:24
29&3548配置方法 2004/8/29 12:02:51
网络流量监控器mrtg全攻略 2004/8/21 10:14:35
CISCO交换机的数据监控 2004/8/19 15:07:34
深入浅出了解交换机是怎么工作的 2004/8/16 8:21:07
让路由器成为你防范的堡垒 2004/8/13 12:54:21
Cisco路由器及交换机安全加固 2004/8/13 12:51:44
Cisco路由器的安全配置简易方案 2004/8/10 12:28:09
Cisco 路由配置语句汇总 2004/8/10 12:26:42
CCNA专业词汇全集 2004/8/10 7:50:25
计算机端口介绍[详细列表] 2004/8/9 8:02:50
路由器NAT功能配置简介(知识点讲解,bsci必考) 2004/7/27 17:11:46
CISCO网络安全 2004/7/26 8:42:25
根据ip地址查交换机端口 2004/7/23 10:16:41
路由器测试的类型和方法 2004/7/23 10:04:30
CIT中文笔记 2004/7/15 11:52:42
Cisco路由器及交换机安全加固 2004/7/14 16:21:36
交换机口令恢复的步骤 2004/7/9 10:09:20
三层MPLS VPN及其故障处理 2004/7/1 13:08:35
Cisco路由器的安全配置简易方案 2004/6/10 16:47:41
CISCO路由器基于时间的访问列表的应用 2004/6/10 16:44:06
cisco 未公开的命令 2004/6/7 8:00:17
根据IP查端口 2004/6/1 8:50:32
CISCO部分命令全集 2004/5/27 14:03:51
Cisco路由器故障诊断技术 2004/5/26 14:16:19
使用路由器作流量检测的几个手段 2004/4/9 13:17:44
用xmodem重新快速灌IOS- 2004/2/27 14:01:52
CCIE之建立详细的故障检测检查表 2004/2/26 8:59:12
网络端口及其详解分页 2004/2/17 9:03:12
100分钟教你配CISCO RIP 2004/2/11 8:18:25
在接入服务器上使用Cisco IOS DHCP服务器 2004/2/4 8:31:10
Cisco路由器由Windows 2000 CA中心登记证书 2004/2/4 8:30:02
如何升级软件 图像在Catalyst 交换机第三层模块 2004/2/4 8:27:28
安全的log纪录服务器 2004/1/24 19:17:43
CCNP路由部分精华 2004/1/6 11:10:54
-- E1知识点总结 -- 2004/1/6 10:30:00
LINUX新手入门及安装配置faq200(下) 2003/12/31 20:54:57
用route map实现多ISP Internet接入工程实例 2003/12/31 9:19:10
cisco3640路由器设置(祥) 2003/12/27 20:43:07
在CISCO设备上用FTP传IOS文件 2003/12/27 1:31:14
SSH在Cisco设备上设置实例 2003/12/20 23:29:24
Cisco路由器故障诊断技术 2003/12/2 10:37:30
用 Linux 打造路由器 2003/11/25 9:55:06
switch命令大全 2003/11/25 9:06:50
组播协议和组播路由 2003/11/19 10:41:40
Cisco路由器的安全配置简易方案 2003/11/11 8:05:48
IS-IS路由协议学习总结 2003/11/4 9:53:23
局域网交换机维护 2003/11/3 8:45:18
通过设置Cisco路由器防止分布式D.O.S攻击手段的细节 2003/10/30 16:56:20
CatOS下定义VLAN 2003/10/23 14:54:21
Cisco路由器是怎样被攻陷的------SolarWinds2002的简单使用 2003/10/23 10:42:37
Switching 命令大全 2003/10/13 17:59:51
路由器故障解决 2003/9/17 8:26:49
关于路由器cpu利用率过高的解决 2003/9/9 10:43:07
网络层访问权限控制技术 ACL详解 2003/9/9 8:49:02
CISCO 技术大集合 2003/9/8 7:46:34
SSH实现Cisco路由器登录 2003/9/8 7:39:57
最佳的75个安全工具 2003/9/5 15:18:38
某大型企业局域网安全解决方案 2003/9/2 9:14:09
常见端口表汇总 2003/9/1 10:31:24
新版CCNA 640-801考试IOS命令大全(ZT) 2003/8/27 17:39:13
Catalyst5500交换机 VLAN设置 2003/8/26 10:54:04
局域网实现VLAN实例 2003/8/15 10:37:16
Redhat advance server 2.1集群的安装与管理 2003/8/12 8:21:31
双机热备的全面配置示例 2003/8/6 14:45:05
用 Linux 打造路由器 2003/8/5 7:33:33
Cisco 路由配置语句汇总 2003/7/31 9:08:50
网络词汇大全 2003/7/31 8:45:22
思科产品常见问题一百问 2003/7/30 14:17:30
系统安全名词列表 2003/7/29 10:27:02
4006交换机(IOS版)简明配置维护手册 2003/7/28 18:02:12
CISCO配置命令大全 2003/7/28 17:58:33
基于路由器的网络诊断 2003/7/28 17:57:02
CISCO交换机概览 2003/7/28 15:14:40
Cisco路由器的安全配置简易方案 2003/7/19 19:08:47
Cisco 路由配置语句汇总 2003/7/14 16:59:32
网络工程师必懂的专业术语 2003/7/14 16:54:43
网络流量监控器mrtg全攻略 2003/7/14 9:37:34
Switching 命令大全-转 2003/7/13 19:06:01
路由器故障解决 2003/7/13 19:05:03
[精华手册]CISCO路由器配置手册 2003/7/13 19:01:40
虚拟局域网(VLAN)路由实例 2003/7/13 19:00:04
XX校校园网实现(VLAN及策略路由的实现) 2003/7/13 17:53:32
转载cisco3524的管理vlan配置 2003/7/11 22:16:09
在win2000中使用mrtg进行实时流量监测 2003/7/11 22:14:10
路由的中文笔记 2003/7/8 12:22:30
Cisco路由器的安全配置简易方案 2003/7/2 9:03:54
电脑书籍下载网站集锦 2003/6/27 8:18:43
局域网中代理服务器、路由器的配置案例 2003/3/23 21:47:36
某大型企业局域网安全解决方案 2003/3/17 22:44:09
某大型局域网安全解决方案 2003/2/21 22:13:18
理解防火墙及防火墙实例系列: 第一部分 防火墙基本类型、概念以及各类防火墙的主要优缺点 2003/1/12 15:45:24


感性空间
设计&运维
网络技术
休闲娱乐
NetFilter
linux&Unix
网络安全
程序空间
软件考试
RFC&ISO
规划&规范
虚拟&存储
Apple技巧
云计算&大数据



文章搜索



站内搜索