所属分类: 网络技术 整理: FengNet.Com 更新日期:2004/11/9 10:47:49 阅读次数:7142

CCNA考试命令集


CCNA考试命令集

CNAP (Cisco网络技术学校院教程)第三、四学期
(第二版)
第1章OSI参考模型和路由
1.5.8 IP路由先择配置任务
1、IP地址配置
Router# term ip <netmask-format>
Router(config-if)# term ip <netmask-format>
2、动态路由选择配置
Router(config)# router <rip | igrp | eigrp | ospf>
Router(config-router)# network <network-number>
3、RIP
Router(config)# router rip

第2章 局域网交换
2.5 生成树协议
Router# show spantree
第5章 路由先择协议:IGRP
5.6 了解IGRP的有关*作
5.6.2 创建IGRP路由选择过程
Router(config)# router igrp <autonomous-system>
Router(config-router)# network <network-number>
Router(config)# no router igrp <autonomous-system>
5.6.3 提高IGRP的稳定性
Router(config-router)# timers basic <更改的igrp发送更新消息的时间间隔> <过期时间,常为3倍于更新时间> <过期后保留的最短时间,常设为0> <过期后保留的最长时间,常4倍或多或5倍于更新时间>
(例:Router(config-router)# timers basic 15 45 0 60,其默认的设置为Router(config-router)# timers basic 90 270 0 450)
Router(config-router)# no metric holddown
(注:使用holddown命令,可以使旧的路由被去除后,新增加的路由立即生效)
5.6.6 最大跳数
Router(config-router)# metric maximum-hop <最大跳数值0~255,默认为100)

第6章 访问控制列表
6.3 ACL配置任务
Router(config)# access-list <access-list-number> {permit | deny} <test-conditions>
Router(config-if)# {ip | ipx} access-group <access-list-number>
6.3.2 为每一个ACL分配唯一的表号
协议及其所允许的ACL表号的取值范围
协 议 ACL表号的取值范围
IP(Internet协议) 1~99
Extended IP(扩展Internet协议) 100~199

AppleTalk 600-699

IPX(互联网数据包交换) 800~899
Extended IPX(扩展互联网数据包交换) 900~999
IPX Service Advertising Protocol(IPX服务通告协议) 1000~1099
Router(config)# no access-list <access-list-number>
6.3.4 如何使用通配符any
Router(config)# access-list <access-list-number> {permit | deny} any
等同于:
Router(config)# access-list <access-list-number> {permit | deny} 0.0.0.0 255.255.255.255
6.3.5 如何使用通配符host
Router(config)# access-list <access-list-number> {permit | deny} host <ip-address>
(注:host <ip address>等同于<ip-address> 0.0.0.0)
6.4 标准访问控制列表
6.4.1 标准ACL的有关例子
Router(config)# access-list <access-list-number> {permit | deny} <source> [source-wildcard] [log]
Router(config)# no access-list <access-list-number>
Router(config-if)# ip access-group <access-list-number> [in | out]
(注:如果in和out都没有指定,那么缺省地被认为是out)
Router(config-if)# no ip access-group <access-list-number> [in | out]
Router# show access-list
6.4.2 标准ACL例子1:允许一个源的通信流量通过
Router(config)# access-list <access-list-number> permit <source> [source-wildcard]
(注:末尾一句access-list <access-list-number> deny 0.0.0.0 255.255.255.255通常省略不写)
Router(config)# interface <接口号>
Router(config-if)# ip access-group <access-list-number> out
6.4.3 标准ACL例子2:拒绝一个特定主机的通信流量通过
Router(config)# access-list <access-list-number> deny host <ip-address>
Router(config)# access-list <access-list-number> permit 0.0.0.0 255.255.255.255
Router(config)# interface <接口号>
Router(config-if)# ip access-group <access-list-number> out
6.4.4 标准ACL例子3:拒绝一个特定子网的通信流量
Router(config)# access-list <access-list-number> deny <子网号> <通配符掩码>
Router(config)# access-list <access-list-number> permit any
Router(config)# interface <接口号>
Router(config-if)# ip access-group <access-list-number> out
6.5 扩展访问控制列表
6.5.1 扩展ACL的有关例子
Router(config)# access-list <access-list-number> {permit | deny} <protocol> <source> [source-mask <destination> destination-mask] [operator operand] [established] [log]
(注:operator operand中分为lt---小于、gt---大于、eq---等于、neq---不等于和一个端口号)
Router(config-if)# ip access-group <access-list-number> [in | out]
6.5.2 扩展ACL例子1:拒绝FTP通信流量通过E0
Router(config)# access-list <access-list-number> deny tcp {<source> <source-mask>} {<destination> <destination-mask>} eq {21 | ftp}
Router(config)# access-list <access-list-number> permit ip {<source> <source-mask>} {<destination> <destination-mask>}
Router(config)# interface <接口号>
Router(config-if)# ip access-group <access-list-number>
6.5.2 扩展ACL例子2:只拒绝通过E0通信流量
Router(config)# access-list <access-list-number> deny tcp {<source> <source-mask>} any eq {23 | smtp}
Router(config)# access-list <access-list-number> permit ip any any
Router(config)# access-list <access-list-number> deny ip
Router(config)# interface <接口号>
Router(config-if)# ip access-group <access-list-number> out
6.6 使用命名访问控制列表
Router(config)# ip access-list {standard | extended} <name>
Router(config {std- | ext-}nacl)# {deny | permit} <source> [source-mask <destination> destination-mask] [log]
Router(config)# interface <接口号>
Router(config-if)# ip access-group <access-list-number> out
6.9 验证访问控制列表
Router# show access-lists
Router> show ip interface
Router# show ip interface

第7章 Novell IPX
7.3 IPX概述
Router# telnet <ipx地址>
Router-A# show protocols
Router-A# show ipx interface [[Ethernet | serial | asynchronous | dialer | Token Ring | FDDI | null | loopback | tunnel] <unit>]
7.4 Novell封装
7.4.1 Cisco封装的命名情况
Novell与Cisco封装的命名对比
Novell IPX的命名 Cisco IOS的命名
Ethernet_802.3 Novell-ether

Ethernet_802.2 sap
Token-Ring
FDDI_802.2

Ethernet _SNAP snap
Token-Ring _SNAP
FDDI_SNAP

Ethernet _II arpa

FDDI _RAW Novell _fddi
7.5 使用RIP进行Novell路由选择
Router(config)# ipx routing

Router(config)# ipx routing [node]
(注:对于串口必须指定node,node是一具48位的MAC,用4个点分十六进制的数:xxxx . xxxx . xxxx)
Router(config-router)# ipx maximum-paths <paths>
(注:开启负载均分的线路数1~512,缺省为1)
Router(config)# no ipx routing
Router(config)# ipx route eigrp
Router(config-router)# ipx network {network-number | all}
7.6 服务通告协议(SAP)
Number Sap Service
4 NetWare文件服务器
7 打印服务器
24 远程桥接服务器(路由器)
7.8 Novell IPX配置任务
7.8.1 Novell IPX全局配置
Router(config)# ipx routing
Router(config-router)# ipx maximum-paths <1~512>
(注:开启负载均分的线路数1~512,缺省为1)
7.8.2 给接口分配IPX网络号
命 令 命令描述
Ipx routing [node] 为IPX选择路由选择,并开始启动IPX RIP
Ipx maximum-paths <1~512> 允许通往目的地的计量标准值相等的几条并行路径采用负载均分,并行路径的最大数目被限制一个指定的范围之内
Interface Ethernet <接口号 | 子接口号> 表示要进入接口或子接口,进行相应的配置
Encapsulation <与novell相对协议> 可选择的协议有:Novell-ether、sap、snap、arpa、Novell _fddi
Ipx network <network-number | all> 分配给接口或子接口一个网络号

7.8.3 验证IPX*作
IPX监视命令
命 令 描 述
Show ipx interface 显示IPX状态和有关参数
Show ipx route 显示路由选择表内容
Show ipx servers 显示IPX服务器列表
Show ipx traffic 显示数据包的数量和类型
IPX故障检修命令
命 令 描 述
Debug ipx routing activity 有关RIP消息更新数据包的信息
Debut ipx sap 有关SAP消息更新数据包的信息
Ping 显示有关一个特定节点能否响应网球请求的有关信息
7.9 监视IPX接口状态
Router# show ipx interface <接口类型> <接口号>
Router(config)# ipx delay <number>
(注:手动修改一个接口的tick延时,默认的LAN为1 tick, WAN为6 tick)
Router# show ipx interface 0
7.9.2 监视IPX路由选择表
Router# show ipx route
7.9.2 监视Novell IPX服务器
Router# show ip servers [ sorted {name | net | type}
(注:显示的排序方式,net是指按网络号,type为默认的按类型排序)
7.9.4 监视IPX通信流量
Router# show ipx traffic
7.9.5 ipx路由选择的故障检修
Router# debug ipx routing activity
7.9.6 IPX SAP的故障检修
Router# debug ipx sap
SAP的响应 描 述
0x1 普通查询
0x2 普通响应
0x3 GNS(接通最近服务器)查询
0x4 GNS(接通最近服务器)响应
7.9.8 特权IPX ping命令
Router# ping [ipx <network .node | host>]
字符 定义
! 每一个惊叹号表示从目的地址成功的接收一个应答
. 表示网络服务器在等待从目的地址接收应答时间的超时
U 接收到了一个目的地不可到达错误的PDU(协议数据单元)
C 接收到了一个经历了拥塞的数据包
I 用户终端测试
? 不知道的数据包类型
& 超过寿命的数据包
中断 Ctrl + Shift + 6 + X 或 Ctrl + Shift + X
Router# ping
(注:为特权下ping的扩展)
第11章 PPP
11.3 PPP会话的建立过程
Router# show interface
(注:可以用来检查LCP和NCP的状态)
Router(config-if)# encapsulation ppp
11.4 PPP验证
Router# username <远端路由器名> password <与远端相同的口令>
Router# configure terminal
Router(config)# interface <要配置的接口>
Router(config-if)# encapsulation ppp
Router(config-if)# ppp authentication {chap | chap pap | pap chap |pap}3
/*在Cisco IOS 11.1或更高的版本中,PAP默认下不再被使用,如要使用需作以下配置*/
Router(config-if)# ppp pap sent-username <username> password <password>
11.4.2 配置CHAP验证
Router(config-if)# ppp chap hostname <hostname>
(注:此用于多对一的连接,并要求所有路由器用同一个名字)
Router(config-if)# ppp chap password <secret>
(注:只用密码验证的方法用于路由器向验证主机发送,对于端对端的路由则不能使用)

第12章 ISDN
12.7 ISDN配置任务
说明:
1、 对于TE1线路,用BRI接口
2、 对于TE2线路,可用“BRI接口”+“外接的ISDN终端适配器”,也可用“SERIAL接口”。
12.7.1 配置ISDN BRI
Router(config)# interface bri <number>
12.7.2 定义交换类型
Router(config)# isdn switch-type <switch-type>
(注:全局模式下的配置将在所有端口都生效,也可以在单个BRI接口下配置)
Router(config-if)# isdn switch-type {basic-ltr6 | basic-5ess | basic-dms100 | basic-net3 | basic-nil | basic-nwnet3 | basic-nznet3 | basic-ts013 | ntt | vn2 | vn3}
12.7.3 定义SPID
Router(config)# interface bri <number>
Router(config-if)# isdn spid1 <spid-number 1> [ldn 1]
(注:LDN的指定使得些B信道可以同时收发数据)
Router(config-if)# isdn spid2 <spid-number 2> [ldn 2]
12.7.4 BRI配置实例
Router(config)# dialer-list <dialer-list-number> protocol <ptotocol> permit
Router(config)# isdn switch-type <switch-type>
或(Router(config-if)# isdn switch-type <switch-type>)
Router(config)# interface bri <interface-number>
Router(config-if)# dialer-group <dialer-list-number>
Router(config-if)# dialer wait-for-carrier time <time>
Router(config-if)# dialer idle-timeout <timeout>
Router(config-if)# isdn spid1 <spid-number 1> [ldn 1]
Router(config-if)# isdn spid2 <spid-number 2> [ldn 2]
Router(config-if)# dialer map ip <ip-address> name <远端路由器名> <telephoto-number>
命令/参数 描 述
Isdn switch-type 指定与路由器连接的ISP商的交换机类型
dialer-list <dialer-list-number> protocol <ptotocol> permit 建立的拨号访问列表,一般是允许IP包发起ISDN呼叫
interface bri <interface-number> 进入ISDN接口,继续进行相关的配置
dialer-group <dialer-list-number> 在BRI接口上应用dialer-list <dialer-list-number>,使其生效
dialer wait-for-carrier time 指定在呼叫发起后等待服务提供商响应的最大时间
dialer idle-timeout 指定路由器在空闲多小秒后终止ISDN连接
12.7.5 验证BRI的*作
Router# show isdn status
12.7.6 按需拨号请求路由先择
12.8.1 验证DDR
命 令 描 述
Ping / telnet 当ping或者telnet一个远端站点时,或者有其它的流量时,会触发一个连接。这时路由器会在链路状态消息中向控制台发送一个变化消息。
Show dialer 可以得到配置了DDR的接口的全部诊断信息,例如:拨号成功的次数以及每个B信道的空闲时间和固定空闲时间。当前的呼叫信息也能得到,比如呼叫的长度和当前与接口连接的设备的号码及名字。
Shw isdn active 当使用ISDN时可以使用该命令。它会得到当前的ISDN呼叫以及该呼叫的号码。
Show isdn status 可以得到ISDN连接的统计信息。
Show ip route 显示路由器已知的路由,包括静态和动态路由
12.8.2 DDR调试*作
命 令 描 述
Debug q921 检查是否连接到了一个ISDN交换机
Debug dialer 显示诸如接口在拨什么号码之类的信息
Clear interface 清除当前的呼叫。在查找问题时,有时这个命令会很有用,它会清除历史信息以查明当前成功和失败的呼叫次数。使用这个命令要小心,。它有时需要在本地和远端路由器上都清除呼叫
Router# debug isdn q921
Router# clear interface bri <interface-number>

Router> show status
Router# show status

第13章 帧中继
13.6 基本帧中继的配置
Router(config)# interface serial <接口号>
Router(config-if)# no shutdown
Router(config-if)# ip address <ip-address> <net-mask>
Router(config-if)# encapsulation frame-relay [cisco | IETF]
Router(config-if)# frame-relay lmi-type {ansi | cisco | q933a}
(注:此条是11.2版本(不包括11.2版本)以前的配置,
Router(config-if)# bandwidth <kilobits>
/*如果路由器不支持逆向ARP,可用下面的命令使它支持。---缺省下,是支持逆向ARP的*/
Router(config-if)# frame-relay inverse-arp [IP | IPX | AppleTalk | DECnet | VINES | XNS] [dlci]
13.6.1 验证帧中继的有关*作
命 令 描 述
Show interface serial 显示组播的DLCI的相关信息。这里的DLCI被用在采用帧中继配置的串行接口上,而LMI DLCI则用在相应的LMI上
Show frame-relay pvc 显示每个已配置连接的状态信息和流量统计。这个命令也用来查看路由器接收到的BECN和FECN数据包的数量
Show frame-relay map 显示跟本地路由器相连的远端目的设置的网络层地址信息和相应的DLCI值
Show frame-relay lmi 显示LMI流量统计情况。例如:它显示本地路由器和帧中继交换机之间交换的状态消息的数量
13.6.2 检验线路是否处于连通状态
Router# show interface serial <接口号>
13.6.3 检验帧中继映射是否成功
Router# show frame-relay map
13.6.4 检验到中心站点路由器的连通性
Router# ping <ip-address>
13.6.5 配置帧中继连接的串行接口
Router(config)# interface serial <接口号>
Router(config-if)# encapsulation frame-relay [cisco | IETF]
Router(config-if)# no shutdown
13.6.6 验证帧中继的配置情况
Router(config)# show frame-relay pvc
Router(config)# show interface serial <接口号>
Router(config)# line console 0
Router(config-line)# exec-timeout <timeout>
(注:用于设定一间隔的超时时间)
Router(config#) line vty 0 4
Router(config-line)# login
Router(config-line)# password <line-access>
13.6.7 配置子接口
Router(config-if)# interface serial <number.subinterface-number> {multipoint | point-to-point}
(注:subinterface-number取值范围为1~4,294,967,293 )
Router(config-if)# ip unnumbered <interface>
(注:推建用环回接口)
Router(config-if)# frame-relay interface-dlci <dlci-number>
13.6.8 配置可选的命令
Router(config-if)# frame-relay map <protocol> <protocol-address> <dlci> [broadcast] [ietf | cisco | payload-compress packet-by-packet]
Router(config-if)# keepalive <number>
(注:PVC维持的时间,默认为10秒;通常比ISP商的帧中继交换机设定的时间短2~3秒)

第14章 网络管理(第二部分)
14.4 排除网络故障
14.4.2 排除技术的过程
C:\windows\> ping 127.0.0.1
14.4.4 软件工具
C:\windows\> ping [-t] [-a] [-n] [-l] [-f] [-i] [-r] <destination>
-t 一直ping,直到被中断
-a Ping该地址并将其解析成主机名
-n 指定ping的次数
-l 指定数据包的长度;发送指定长度的echo数据包
-f 向网关发送“不要分段”的命令
-i 根据发送“不要分段”的命令
-r 根据ttl值设定数据包的TTL字段
Destination 为ping指定远程的主机,既可以是域名又可以是IP地址
C:\windows\> tracert [-d] [-h maximum _hops] [-j host-list] [-w timeout] <target _name>
-d 不将IP地址解析成主机名
-h Max _hops指定了最大跟踪跳数
-j Hop-list指定了有限源路由
-w 指定了响应的超时时间,单位是毫秒
C:\windows\> telnet <远程主机名 | IP地址>
C:\windows\> netstat [-a] [-e] [-n] [-s] [-p proto] [-r] [interval]
-a 显示所有连接和处于监听状态的接口(服务器端的连接通常不显示)
-c 显示所有的以太网统计数据。这个选项可以跟-s选项一起使用
-n 用数字的形式显示地址和端口号
-p proto 显示proto指定协议的连接。Proto的取值可以是tcp或udp。如果配合-s选项显示每个协议的统计数据,proto的取值可以是tcp、udp或者ip
-r 显示路由表的内容
-s 显示每个协议的统计数据。默认显示TCP、UDP和IP的统计数据。利用-p选项可以指定只显示其中一部分
Interval 每隔inteval秒重复显示指定的统计数据。按CTRL+C终止显示。如果不指定 interval,netstat会将当前的信息显示一次
C:\windows\> arp [-a | -g] [inet _addr] [-N [if_addr]]
C:\windows\> arp [-d] [inet _addr] [if _addr]
C:\windows\> arp [-s] [inet _addr] [ether _addr] [if _addr]
-a or –g 显示当前ARP缓存中的所有内容
-d 删除inet _addr指定的地址映射
-s 添加一个静态地址映射到缓存中
-N 显示指定物理地址的ARP地址映射
Inet _addr 用点分十进制的形式指定IP地址
If _addr 缓存地址映射需要变更的IP地址
Ether _addr 用连字符分隔的16进制的形式显示MAC地址
C:\windows\> winipcfg
C:\windows\> ipconfig [/all | /renew [adapter] | [/release [adapter]]
/all 显示有关适配器的所有信息
/renew 如果不指定适配器,则更新所有在本地适配器的DHCP租用信息
/release 释放DHCP租用信息使该适配器的TCP/IP功能失效

第16章 CCNA认证考试复习
16.7 虚拟局域网(VLAN)的优点
16.7.2 路由选择和VLANs
Router(config)# router rip
Router(config-if)# network <网络号>

Router# configure terminal
Router(config)# interface ehternet 0/0
Router(config-if)# no shutdown
Router(config-if)# exit
Router(config)# interface Ethernet 0/0.1
Router(config-subif)# ip address <ip-address> <net-mask>
Router(config-subif)# encapsulation isl <vlan号-1>
Router(config-subif)# no ip redirects {recommended}
Router(config)# interface Ethernet 0/0.2
Router(config-subif)# ip address <ip-address> <net-mask>
Router(config-subif)# encapsulation isl <vlan号-2>
Router(config-subif)# no ip redirects {recommended}
第17章 路由器命令行界面(CLI)
17.2 路由器用户界面概述
Router con0 is now available.
Press RETURN to get started.
User Access Verification
Password:
Router> enable
Password:
Router#
Router# disable
Router>
Router>exit
To log out of the router, type exit
17.2.1 用户模式命令列表
/*进入方式*/
Password:
Router> ?
命令 描述
Access-enable 创建一条临时的访问控制列表条目
Atmsig 执行有关ATM信令的命令
Cd 改变妆当前的设备
Clear 将变量清空
Connect 打开一个终端连接
Dir 列出给定设备上的文件
Disable 退出特模式
Disconnect 关闭一个已经存在的网络连接
Enable 进入特许模式
Exit 退出EXEC
Help 获得关于IOS交互式帮助系统的描述
Lat 打开一个LAT连接
Lock 锁定终端
Login 用特定的用户登录
Logout 退出EXEC
Mrinfo 向组播路由器询问邻居和版本的信息
Mstat 显示多次组播路由跟踪的统计信息
Mtrace 跟踪从目的到源的反向组播路径
Name-connection 为已经存在的连接命名
Pad 打开一个X.29 PAD连接
Ping 发送echo消息
Ppp 启动IETF点到协议(ppp)
Pwd 显示当前的设备
Resume 继续一个活动的连接
Rlogin 打开一个rlogin连接
Show 显示运行系统的信息
Slip 启动串行线路IP协议(SLIP)
Systat 显示有关终端连接的信息
telnet 打开一个telnet连接
Terminal 设置终端连接的参数
Tn3270 打开一个TN3270连接
Traceroute 启动到目的地的路由跟踪
Tunnel 打开一个隧道(tunnel)连接
Where 显示所有地活动连接
X3 在PAD上设置X.3参数
Xremote 进入Xremote模式
17.2.2 特许模式命令列表
/*进入方式*/
Password:
Router> enable
Password:
Router# ?
(注:以下红色为是特许模式与用户模式相重复的命令)
命令 描述
Access-enable 创建一条临时的访问控制列表条目
Access-template 创建一条临时的访问控制列表条目
Appn 向APPN子系统发送一条命令
Atmsig 执行有关ATM信令的命令
Bfe 设置手工紧急模式
Calendar 管理硬件的日志
Cd 改变妆当前的设备
Clear 将变量清空
Clock 管理系统的时钟
Cmt 启动和停止FDDI连接管理
Configure 进入全局配置模式
Connect 打开一个终端连接
Copy 拷贝配置或映像数据
Debug 使用调试功能(与unduebug相反)
Delete 删除一个文件
Dir 列出给定设备上的文件
Disable 退出特模式
Disconnect 关闭一个已经存在的网络连接
Enable 进入特许模式
Erase 擦除闪存(Flash)或存放配置文件的存储器中的内容
Exit 退出EXEC
Format 格式化某个设备
Help 获得关于IOS交互式帮助系统的描述
Lat 打开一个LAT连接
Lock 锁定终端
Login 用特定的用户登录
Logout 退出EXEC
Mbranch 沿树枝向下跟踪组播路由
Mrbranch 沿树枝向上跟踪反向的组播路由
Mrinfo 向组播路由器询问邻居和版本的信息
Mstat 显示多次组播路由跟踪的统计信息
Mtrace 跟踪从目的到源的反向组播路径
Name-connection 为已经存在的连接命名
Nica 启动/停止NCIA服务器
Pad 打开一个X.29 PAD连接
Ping 发送echo消息
Ppp 启动IETF点到协议(ppp)
Pwd 显示当前的设备
Reload 关机并执行冷启动
Resume 继续一个活动的连接
Rlogin 打开一个rlogin连接
Rsh 执行一个远程命令
Sdlc 发送SDLC测试帧
Send 在tty连接上发送消息
Setup 启动setup命令配置工具
Show 显示运行系统的信息
Slip 启动串行线路IP协议(SLIP)
Squeeze 挤压某个设备
Start-chat 在一个连接上启动一个聊天脚本
Systat 显示有关终端连接的信息
Tarp 目标有关终端连接的信息
telnet 打开一个telnet连接
Terminal 设置终端连接的参数

Tn3270 打开一个TN3270连接
Traceroute 启动到目的地的路由跟踪
Tunnel 打开一个隧道(tunnel)连接
Undebug 停止调试功能(与duebug相反)
Verify 检查某个Flash文件的校验和
Where 显示所有地活动连接
Write 将当前运行的配置文件写入存储器、网络或终端
X3 在PAD上设置X.3参数
Xremote 进入Xremote模式
17.3 使用路由器的帮助功能
Router# clok
Translating ”clok”
% Unknown command or computer name,or unable to find computer address
Router# cl?
Clear clock
Router# clock
% Incomplete command.
Router# clock ?
Set Set the time and date
Router# clock set
% Incomplete command.
Router# clock set ?
Current time (hh : mm : ss)
Router# clock set 19:56:00
% Incomplete command.
Router# clock set 19:56:00 ?
<1-31> Day of the month
Month Month of the year
Router# clock set 19:56:00 04 8
^
% Invalid input detected at the “^” marker
Router# clock set 19:56:00 04 August
% Incomplete command.
Router# clock set 19:56:00 04 August ?
<1993-2035> Year
Router# clock set 19:56:00 04 August 2002 ?
<cr>
Router# clock set 19:56:00 04 August 2002
(完)
17.4 使用IOS的编辑命令
命令 描述
Ctrl + A 移至命令行开头
Ctrl + E 移至命令行末尾
Ctrl + F 前移一个字符
Ctrl + B 后移一个字符

Esc + B 前移一个单词
Esc + F 后移一个单词
17.5 使用IOS的命令历史功能
命令 描述
Ctrl + P 或 ↑(向上箭头) 重用前一条命令
Ctrl + N 或 ↓(向下箭头) 重用下一条命令

Show history 显示命令缓冲区的内容
Terminal history [size number-of line] 设置命令缓冲区的大小
No terminal editing 禁用高级编辑特性
Terminal editing 重新启用高级编辑特性
Tab 完成命令行

Terminal history size [0-256] 设置历史缓冲区中的大小(默认10条)
History size [0-256] 设置历史缓冲区中的大小(默认10条)
第18章 路由器组件
18.3 使用路由器状态命令检查路由器的状态
命令 描述
Show version 显示系统的硬件配置、软件版本、配置文件的名称和来源、启动映象的信息以及最近一次系统重动的原因

Show flash 显示闪存设备的信息

Show processes 显示有关活动进程的信息
Show processes cpu 显示CPU活动进程的信息

Show memory 显示有关路由器内存的统计信息,包括内存空闲的统计信息
Show stacks 监视进程和终端例程所使用的堆栈
Show buffers 显示有关路由器缓冲空间统计信息

Show startup-config Cisco IOS 13.0以后版本,用于显示备份的配置文件
Show config Cisco IOS 13.0以前版本,用于显示备份的配置文件

Show running-config Cisco IOS 13.0以后版本,用于显示活动的配置文件
Write terminal Cisco IOS 13.0以前版本,用于显示活动的配置文件

Show protocols 显示已经配置的协议。该命令能显示所配置的任何一种3层(网络层)协议的状态

Show interface 显示路由器上进行了配置的所有端口的统计信息

Show arp 显示路由器的IP到MAC(接口的)地址映射

18.4.1 Showing CDP Neighbor所获得的各项信息
Router# show cdp neighbors
显示的信息:
Devie identifiers(设备标识) 路由器所配置的用户名、域名
Address list(地址列表) 每个协议对一个地址,至少用于一个SNMP的地址
Port identifier(端口标识) 如:E0、S0
Capabilities list(功能列表) 例如:是否既是源路由器网桥又是路由器的信息
Version(版本) 与show version获得的信息相同
Platform(Platform) 设备的硬件平台,如:CISCO 7000
18.4.2 CDP的一个配置实例
Router (config-if)# cdp enable
Router (config-if)# cdp disable
Router# show cdp interface
18.4.3 Showing CDP Neighbors
Router# show cdp neighbors
Router# show cdp neighbors detail
Router# show cdp interface
Router# show interface
18.5 基本网络测试
18.5.1 用Telnet命令测试应用层
Router> telnet <远端CISCO设备名,例如:Router110>

Router> connect <远端CISCO设备名,例如:Router110>

Router> <直接输入远端CISCO设备名,例如:Router110>

Router> <直接输入远端CISCO设备IP地址>
/*Resume a Session(enter session number orname)*/
Router110> show session
1* Router110
2 Router
Router110> 2
Router>
Router> show session
1 Router110
2* Router
Router>1
Router110>
/*End a session*/
Router110> exit

Router110> logout

Ctrl + shift + 6 + x
18.5.2 用ping命令测试网络层
Router> ping <远端CISCO设备名>
Router> ping <ip地址>
Router# ping <远端CISCO设备名>
Router# ping <ip地址>
Router> ping ipx <ipx地址>
Router# ping ipx <ipx地址>
Router# ping
(注:不加参数可用于ping的扩展)
18.5.3 用trace命令测试网络层
Router> Trace <远端CISCO设备名>
Router> Trace ip <IP地址>
Router# Trace <远端CISCO设备名>
Router# Trace ip <IP地址>
18.5.4 用show ip route命令测试网络层
Router> show ip route
Router# show ip route
18.5.5 使用show interfaces serial命令测试物理层和数据链路层
Router> show interface serial<接口号>
Router# show interface serial<接口号>
18.5.6 Show interfaces和clear counters
Router> show interface
Router# show interface
Router# clear counters
18.5.7 用debug命令查实时的网络通信
Router# terminal monitor
(注:在Telnet端打开终端监控,使debug输出到Telnet会话窗)
Router# dubug broadcast
Router# dubug <相应的参数>
Router# undebug all
Router# no debug all
第19章 路由器启动和设置
19.3 与路由器启动相关的命令
Router# show startup-config
Router# show config
Router# show running-config
Router# write term
Router# erase startup-config
Router# write erase
Router# reload
Router# setup
第20章 路由器配置(一)
20.2 *作IOS11.x版本的配置文件
命令 描述
Configure terminal 从控制台终端手工配置路由器

Copy tftp running-config 从网络中的TFTP服务器上加载配置文件
Configure network Cisco IOS 13.0以前版本,现在由Copy tftp running-config命令替换
Copy startup-config running-config 从NVRAM中加载配置文件(多用于口令恢复)
Configure memory Cisco IOS 13.0以前版本,现在由Copy startup-config running-config命令替换
Show running-config 显示RAM中的当前配置
Write terminal Cisco IOS 13.0以前版本,现在由show running-config 命令替换

Copy running-config tftp 将RAM中的当前配置保存到网络中的TFTP服务器上
Write network Cisco IOS 13.0以前版本,现在由Copy running-config tftp命令替换
Copy running-config startup-config 将RAM中的当前配置保存到NVRAM中
Write memory Cisco IOS 13.0以前版本,现在由Copy running-config startup-config命令替换
Show startup-config 显示NVRAM中保存的配置的内容
Show config Cisco IOS 13.0以前版本,现在由show startup-config 命令替换

Erase startup-config 清空NVRAM的内容
Write erase Cisco IOS 13.0以前版本,现在由erase startup-config 命令替换
20.3 路由器的配置模式
配置模式 提示符
用户EXEC模式 Router>
特许EXEC模式 Router#
全局配置模式 Router(config)#
Interface Router(config-if)#
Subinterface Router(config-subif)#
Controller Router(config-controller)#
Map-list Router(config-map-list)#
Map-class Router(config-map-class)#
Line Router(config-line)#
Router Router(config-router)#
20.3.1 全局配置模式
/*特许EXEC模式下的configure命令*/
Router con0 is now available.
Press RETURN to get started.
User Access Verification
Password:
Router>
Router> enable
Password:
Router#
Router# configure terminal
Router(config)#
Router(config)#interface Ethernet 0/0
Router(config-if)#
Router(config-if)# exit
Router(config)#
Router(config)# exit
Router#
Router# disable
Router>
Router> exit
Press RETURN to get started.
或用快速的退出方法:
Router(config-if)# end
(注:end和Ctrl + Z的作用一样)
Router#
Router# exit
Press RETURN to get started.
20.3.2 配置路由协议
Router# configure terminal
Router(config)# router <路由协议>
Router(config-router)# (command)
Router(config-router)#
20.3.3 配置某个接口*/
Router# configure terminal
Router(config)# interface <端口类型> <端口号>

Router(config)# interface <端口类型> <模块所在的插槽号 / 端口号>
Router(config-if)# no shutdown
Router(config-if)#
20.3.4 配置特定的接口
Router(config)# interface serial 1/0
Router(config-if)# no shutdown
Router(config-if)# bandwidth 56
Router(config-if)# clock rate 56000
Router(config-if)#
Router(config-if)# int & 0.1 point-to point
Router(config-if)# int & 0.2 point-to point
/*Cisco 4000系列路由器*/
Router(config)# interface Ethernet 1/0
Router(config-if)# media-type 10baset
Router(config-if)#
20.4 配置方法
20.4.3 配置口令的方法
Router(config)# line console 0
Router(config-line)# login
Router(config-line)# password <口令>
Router(config)# line vty 0 4
Router(config-line)# login
Router(config-line)# password <口令>
Router(config)# enable password <口令>
Router(config)# enable secret <口令>
/*启动加密服务,为所有的口令加密*/
Router(config)# service password-encryption
Router(config)# no service password-encryption
20.4.4 路由器标识配置
/*路由器名称*/
Router(config)# hostname <路由器名称,如:Tokyo>
Tokyo#
/*登录标题*/
Router(config)# banner motd #
<欢迎信息,如:Welcome!!!> #
Router(config)#
/*接口描述*/
Router(config)# interface Ethernet 0
Router(config-if)# description <接口描述信息>
第21章 IOS映象
21.2 (用boot system命令)定位Cisco IOS软件
1、先从此启动
Router# configure terminal
Router(config)# boot system flash <IOS_ filename>
Router(config)# boot system tftp <IOS_ filename> tftp_address
Router(config)# boot system rom
Router(config)# end
Router# copy running-config startup-config
2、NVROM中没有boot system命令语句时,从flash中取得缺省的Cisco IOS软件。
3、Flash为空时,从TFTP服务器获获得缺省的Cisco IOS软件

21.2.1 配置寄存器的值
Router# configure terminal
Router(config)# config-register <0x102~0x10F>
config-register的值:
值 描述
0x100 使用ROM monitor 模式(用b命令手启动)
0x101 自动从ROM中启动(中路由器没有Flash时的缺省情况)
0x102~0x10F 执行NVRAM中的boot system命令(有Flash时,0x102缺省值)

21.2.2 show version命令
Router> show version
Router# show version
(用于查看启动映象文件的位置及名称、配置寄存器的值)

21.2.4 为使用TFTP作备
Router# ping <TFTP服务器地址>
Router# show flash

21.3 IOS命名规则
示例 硬件平台 特性 运行的位置及压缩状态
Cpa25-cg-l CiscoPro 2500 (cpa 2500) 通信服务器/远程接收服务器和ISDN(cg) 可重新定位,未压缩(l)
Igs-inr-l Cisco ICG ,2500和3xxx(igs) IP子集,Novell IPX和IBM(IBM base option)(inr) 可重新定位,未压缩(l)
C4500-aj-m Cisco 4500和4700 (c4500) APPN和用于低端/中等规模的企业子集(aj) RAM,未压缩(m)
Gs7-k-mz Cisco 7000和7010 (gs7) 用于高端的企业特性(k) RAM,未压缩(mz)

21.4 创建备份软件映象
Router# ping <TFTP服务器地址>
Router# show flash
Router# copy flash tftp

21.5 copy tftp flash命令
Router# ping <TFTP服务器地址>
Router# copy tfpt flash
第22章 路由器配置(二)
22.3 口令恢复
22.3.1 口令恢复技术1
/*针对Cisco 2500、3000、7000系列路由器*/
1、 Router> show version
(注:查看并记录“配置寄存器的的设置”值,通常是0x2102或0x102)
2、 重新开机,按BREAK、Ctrl + Break、Alt + Break等进入 ”>” 提示符下:
>o/r {0x42 | 0x41}
值 描述
0x42 从Flash中启动,不加载配置文件startup-config.(此为最好的默认设置)
0x41 Flash丢失时用,但下一步时你只能查看、清除配置文件,不能改口令。
>i
(注:此命令为重新启动路由器)
3、 在开机进入SETUP时,回答NO或按Ctrl + C;进行下一步*作:
Router>
Router> enable
Router#
Router# copy startup-config running-config
Router# configure terminal
Router(config)# enable password <新口令>
Router(config)# enable secret <新口令>
Router(config)# exit
Router# copy running-config startup-config
Router# configure terminal
Router(config)# config-register <show version中记录的值,通常为0x2102>
Router(config)# exit
Router# reload

22.3.2 口令恢复技术2
/*针对Cisco 1003、4500系列路由器*/
1、 Router> show version
(注:查看并记录“配置寄存器的的设置”值,通常是0x2102或0x102)
2、 重新开机,在60秒内按BREAK、Ctrl + Break、Alt + Break等进入”rommon>”提示符下:
Rommon> confreg
………….
Do you wish to change configuration [y/n]: yes
Ignore system config[y/n]: yes
Change boot characteristics[y/n]: yes
……………..
(注:其它的均回答NO,然后进入“boot:”提示符下)
Boot: {2 | 1}
值 描述
2 从Flash中启动,不加载配置文件startup-config.(此为最好的默认设置)
1 Flash丢失时用,但下一步时你只能查看、清除配置文件,不能改口令。
Do you wish to change configuration [y/n]: no
(注:回答NO后,系统又返回到”rommon>”提示符下)
Rommon> reset
(注:此命令为重新启动路由器)
3、 在开机进入SETUP时,回答NO或按Ctrl + C;进行下一步*作:
Router>
Router> enable
Router#
Router# copy startup-config running-config
Router# configure terminal
Router(config)# enable password <新口令>
Router(config)# enable secret <新口令>
Router(config)# exit
Router# copy running-config startup-config
Router# configure terminal
Router(config)# config-register <show version中记录的值,通常为0x2102>
Router(config)# exit
Router# reload
第24章 IP寻址
24.3 IP地址配置
Router# term ip <netmask-fromat>
(注:全局模式下的配置,对所有的接口都起作用)
命令级别 命令 用途
Router(config-if)# Ip address <ip-address> <subnet_mask> 为接口指定地址和子网掩码:启动IP处理
Router(config-if)# Term ip <netmask-format> {bitcount | decimal | hexadecimal} 为当前会话指定网络掩码的格式
Router(config-if)# Ip <netmask-format>{bitcount | decimal | hexadecimal} 为访问路由器的某条线路设定网络掩码的格式

24.3.1 ip host命令
Router(config)# ip host <name> [tcp-port-number] <address {address}>
(注:建立类于建立DNS服务器)

24.3.2
Router(config)# ip name-server <server-address1 [server-address2~6]>
(注:类似于在客户端指定DNS服务器地址,但指定的DNS服务器最多为6个)

24.3.3 如何在路由器上启动和停止DNS
Router(config)# ip domain-lookup
(注:默认下是启动的)
Router(config)# no ip domain-lookup
(注:此为关闭DNS服务)

24.3.4 显示主机名
Router# show hosts

24.4 验证地址配置
Router# Telnet {DNS主机名 | IP地址}
Router# ping {DNS主机名 | IP地址}
字符 定义
! 成功接收回送应答
. 等待数据包应答超时
U 目的地不可到达错误
C 数据包遇到拥塞
I Ping被中断(例如:Ctrl + Shift + 6 + X)
? 数据包类型未知
& 超过数据包生存时间(TTL)
Router# trace {DNS主机名 | IP地址}
响应 定义
!H 路由器接收到探测数据包,但没有转发,通常是由访问控制列表造成的
P 协议不可达
N 网络不可达
U 端口不可达
* 超时
Router# ping
(注:后面不加参数,用于ping的扩展模式)
Router# trace
(注:后面不加参数,用于trace的扩展模式)
第26章 路由选择协议
26.2.3 ip route命令
Router(config)# ip route <目录网络或子网号> [子网掩码] <下一路由器IP地址 | 从本地出口的地址> [管理距离0~255,默认为1]
(注:静态地址配置)

26.2.4 ip default-network命令
Router(config)# ip default-network <目标网络号>
(注:配合路由协使用,用其中的一个动态路由号作默认路由配置)
Router(config)# ip route 0.0.0.0 0.0.0.0 <下一路由器IP地址 | 从本地出口的地址>
(注:只有一个公网地址时,在出口路由器上的配置)

26.3 内部路由选择协议
26.3.4 使用router和network命令
Router(config)# router <路由协议rip | igrp | eigrp | ospf | is-is等> [自主系统号]
Router(config-router)# network <直接相连的要用此路由协议的网络号>
Router(config-router)# network <直接相连的要用此路由协议的网络号>
。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。

26.4 路由信息协议RIP
Router(config)# router rip
Router(config-router)# network <直接相连的要用rip协议的有类别网络号>
Router# show ip protocols
Router# show ip route
Router# debug ip rip

26.5 内部网关路由协议IGRP
Router(config)# router igrp <自主系统号>
Router(config-router)# network <直接相连的要用igrp协议的有类别网络号>
Router# show ip interface
Router# show ip protocols
Router# show ip route
Router# debug ip rip
第27章 排除网络故障
27.3排除网络故障的一个总体模型
Router# ping <有故障的主机 | 有故障的IP地址>
Router# show ip route
Router# show interface <有故障的接口>
Router# show run

27.4 IP的故故障排除
27.4.3 检查可用的路由
Router# show ip route <有故障的IP地址>
27.4.4 跟踪路由(Tracing the Route)
SUN-A> traceroute <有故障的主机 | 有故障的IP地址>
C:\windows\> winipcfg
C:\windows\> ipconfig
C:\windows\> ipconfig / all
C:\windows\> tracert <有故障的主机 | 有故障的IP地址>
27.4.5 使用扩展的ping来跟踪连接性
Router# ping

27.5 其它可能的故障
27.5.1 一个地十解析(ARP)的故障
Router# show arp
Router# show interface <有故障的接口>
C:\windows\> arp -a
SUN-A> arp –a
27.5.2 验证终端系统的路由表
C:\windows\> netstat –rn
C:\windows\> route –f add 0.0.0.0 mask 0.0.0.0 <需要添加入的网关地址>
C:\windows\> route [–f ] [[print | add | delete | change] [destination] [mask netmask] [gateway]]
C:\windows\> route add <ip地址> mask <网络掩码> <网关ip地址>
C:\windows\> route delete <ip地址> mask <网络掩码> <网关ip地址>
C:\windows\> nbtstat <相应的参数>
SUN-A> netstat -rn
附录B:命令汇总
命令 描述 章
Access-enable 创建一条临时的访问控制列表条目 17
Access-template 创建一条临时的访问控制列表条目 17
Appn 向APPN子系统发送一条命令 17
Atmsig 执行有关ATM信令的命令 17
B 手动引导*作系统 21
Bandwidth 设置接口的带宽 20
Banner motd 指定日期信息标语 20
Bfe 设置手工紧急模式 17
Boot system 指定路由器启动时加载的系统映象 21
Calendar 管理硬件的日志 17
Cd 改变妆当前的设备 17
Cdp enable 允许接口运行CDP协议 18
Clear 将变量清空 17
Clear counters 消除接口计数器 18
Clock 管理系统的时钟 17
Clock rate 设置串口硬件接口连接时钟速率,如:网络接口模块、处理器能接收的速率 20
Cmt 启动和停止FDDI连接管理 17
Config-register 修改配置寄存器设置 21
Configure 进入全局配置模式 17,18,19
Configure memory 从NVRAM加载配置信息 20
Configure terminal 从终端进行手动配置 20,21
Connect 打开一个终端连接 17
Copy 拷贝配置或映像数据 17
Copy startup-config running-config 从NVRAM加载配置信息 21
Copy flash ftp 备份系统映象文件到TFTP服务器 21
Copy running-config startup-config 将RAM中的当前配置存储到NVRAM 20,21
Copy running-config tftp 将RAM中的当前配置存储到网络TFTP服务器上 20
Copy tftp flash 从TFTP服务器上下载新映象到Flash 21
Copy tftp running-config 从TFTP服务器上下载配置文件 20
Debug 使用调试功能(与unduebug相反) 17
26
Delete 删除一个文件 17
Dir 列出给定设备上的文件 17
Disable 退出特模式 17
Disconnect 关闭一个已经存在的网络连接 17
Enable 进入特许模式 17
Enable password 设置本地口令控制不同特权级别的访问 20
Enable secret 为enable password命令定义额外一层的安全性 20
Erase 擦除闪存(Flash)或存放配置文件的存储器中的内容 17
Erase startup-config 删除NVRAM中的内容 19,20
Exit 退出EXEC 17,20
Format 格式化某个设备 17
Help 获得关于IOS交互式帮助系统的描述 17
History 查看历史记录 17
Interface 配置接口类型和进入接口配置模式 20
Ip address 设置一个接口地址和子网掩码并开始IP处理 24
Ip default-network 建立一条缺省路由 26
Ip domain-lookup 允许路由器缺省使用DNS 24
Ip host 定义静态主机名到IP地址映射 24
Ip name-server 指定至多6个进行名字-地址解析的服务器地址 24
Ip route 建立一条静态路由 26
Lat 打开一个LAT连接 17
Line 确定一个特定的线路和开始线路配置 20
Lock 锁定终端 17
Login 用特定的用户登录 17,20
Logout 退出EXEC 17
Media-type 定义介质类型 20
Mbranch 沿树枝向下跟踪组播路由 17
Mrbranch 沿树枝向上跟踪反向的组播路由 17
Mrinfo 向组播路由器询问邻居和版本的信息 17
Mstat 显示多次组播路由跟踪的统计信息 17
Mtrace 跟踪从目的到源的反向组播路径 17
Name-connection 为已经存在的连接命名 17
Nica 启动/停止NCIA服务器 17
Network 指定一个和路由器直接相连的网络地址段 26
No shutdown 打开一个关闭的接口 20
Pad 打开一个X.29 PAD连接 17
Ping 发送echo消息 17,23,24
Ppp 启动IETF点到协议(ppp) 17
Pwd 显示当前的设备 17
Reload 关机并执行冷启动 17,19,21
Resume 继续一个活动的连接 17
Rlogin 打开一个rlogin连接 17
Router 由第一项的IP路由协议作为路由器进程,例如:router rip是选择RIP作为路由协议 20,26
Rsh 执行一个远程命令 17
Sdlc 发送SDLC测试帧 17
Send 在tty连接上发送消息 17
Service password-encryption 对所有的口令进行加密 20
Setup 启动setup命令配置工具 17,19,26
Show 显示运行系统的信息 17
Show arp 显示路由器的IP到MAC(接口的)地址映射 18
Show buffers 显示有关路由器缓冲空间统计信息 18
Show cdp entry 显示CDP表中所列相邻设备的信息 18
Show cdp interface 显示打开的CDP接口信息 18
Show cdp neighbors 显示CDP查找进程的结果 18
Show config Cisco IOS 13.0以前版本,现在由show startup-config 命令替换 18
Show flash 显示闪存的布局和内容信息 18,21
Show hosts 显示主机名和地址的缓存列表 24
Show interface 显示路由器上进行了配置的所有端口的统计信息 18
Show ip interface 列出接口的状态和全局参数 26
Show ip protocols 显示活动路由协议进程的参数和当前状态 26
Show ip route 显示IP路由表的信息 18,26
Show memory 显示有关路由器内存的统计信息,包括空闲内存的大小 18
Show processes 显示有关活动进程的信息 18
Show protocols 显示已经配置的协议。该命令能显示所配置的任何一种3层(网络层)协议的状态 18
Show running-config 显示RAM中当前的配置信息 18,19,20,21
Show stacks 监控和中断程序对堆栈的使用,并显示上次重启原因 18
Show startup-config 显示NVRAM中备份的启动配置文件 18,19,20,21
Show version 显示系统的硬件配置、软件版本、配置文件的名称和来源、引导映象的信息 18,21
Shutdown 关闭一个接口 20
Slip 启动串行线路IP协议(SLIP) 17
Squeeze 挤压某个设备 17
Start-chat 在一个连接上启动一个聊天脚本 17
Systat 显示有关终端连接的信息 17
Tarp 目标有关终端连接的信息 17
telnet 打开一个telnet连接 13,17
Terminal 设置终端连接的参数 17
Term ip 指定当前会话的网络掩码的格式 24
Trace 跟踪IP路由 18,24
Tn3270 打开一个TN3270连接 17
Traceroute 启动到目的地的路由跟踪 17
Tunnel 打开一个隧道(tunnel)连接 17
Undebug 停止调试功能(与duebug相反) 17
Verify 检查某个Flash文件的校验和 17
Where 显示所有地活动连接 17
Which-route OSI路由表查找和显示结果 17
Write Cisco IOS 13.0以前版本,用于将运行的配置文件信息写入内存、网络或终端 17
Write terminal Cisco IOS 13.0以前版本,现在由show running-config 命令替换 18,19,20
Write erase Cisco IOS 13.0以前版本,现在由erase startup-config 命令替换 18,19,20
Write memory Cisco IOS 13.0以前版本,现在由copy startup-config running-config命令替换 18,19,20
X3 在PAD上设置X.3参数 17
Xremote 进入Xremote模式 17
附录C:命令小结
命令 说明 章
Access-group 把访问控制列表(ACL)应用到接口上 6
Access-list 定义一个标准的IP ACL 6
Clear interface 重新启动接口上的硬件逻辑 12
Debug dialer 显示接口在拨什么号及诸如此类的信息 12
Debug ipx routing activity 显示关于路由选择协议(RIP)更新数据包的信息 7
Debug ipx sap 显示关于SAP(业务通告协议)更新数据包的信息 7
Debug isdn q921 显示在路由器D信道ISDN接口上发生的数据链路层(第2层)的访问过程 12
Debug ppp 显示在实施PPP中发生的业务和交换的信息 9
Deny 为一个已经命名IP ACL设置条件 6
Dialer-group 通过对属于一个特定拨号组的接口进行配置来控制访问 12
Dialer idle-timeout 规定线路断开前的空闲时间的长度 12
Dialer-list protocol 定义一个数字数据接收器DDR拨号表以通过协议或ACL与协议的组合来控制拨号 12
Dialer map 设置一个串行接口来呼叫一个或多个地点 12
Dialer wait-for-carrier-time 规定花多长时间等待一个载体 12
Enable password 确定一个密码以防止对路由器非授权的访问 13
Encapsulation frame-relay 启动帧中继封装 13
Encapsulation Novell-ether 规定在网络段上使用的Novell独一无二的格式 7
Encapsulation ppp 把PPP设置为由串口或ISDN接口使用的封装方法 9,11,12
Encapsulation sap 规定在网络段上使用的以太网802.2格式Cisco的验证方式是sap 7
End 退出配置模式 13
Exec-timeout 配置EXEC命令解释器在检测到用户输入前所等待的时间 13
Exit 退出所有配置模式或者关闭一个激活的终端和终止一个EXEC 13
Frame-relay local-dlci 为使用帧中继封装的串行线路启动本地管理接口(LMI) 13
Hostname 使用一个主机名来配置路由器,该主机名以提示符或者缺省文件名的方式使用 13
Interface 设置接口类型并且输入接口配置模式 6,7,9,12
Interface serial 选择执接口类型且输入接口配置模式 13
Ip access-group 控制对一个接口的访问 6
Ip address 设定接口的网络逻辑地址 1,6,13
Ip unnumbered 在为给一个接口分配一个明确的IP地址的情况下,在串口上启动互联网协议(IP)的处理过程 13
Ipx delay 设置点计数 7
Ipx ipxwan 在串口上启动IPXWAN协议 7
Ipx maximum-paths 当转发数据包时设置Cisco IOS软件使用的等价路径的数量 7
Ipx network 在一个特定接口上启动互联网数据包交换(IPX)的路由选择并且选择封装的类型(用帧封装) 7,13
Ipx router 规定使用的路由选择协议 7
Ipx routing 启动IPX路由选择协议 7
Ipx sap-interval 在较慢的链路上设置较不频繁的SAP(业务广告协议)更新 7
Ipx type-20-input-checks 限制对IPX20类数据包广播的传播和接收 7
Isdn spid1 在路由器上规定已经由ISDN业务供应商为B1信道分配的业务简介号(SPID) 12
Isdn spid2 在路由器上规定已经由ISDN业务供应商为B2信道分配的业务简介号(SPID) 12
Isdn switch-type 规定了在ISDN接口上的中央办公区的交换机的类型 12
Keeplive 为使用帧中继封装的串行线路启动LMI(本地管理接口)机制 13
Line console 设置控制台端口线路 13
Line vty 为远程控制台访问规定一个虚拟终端 13
Login 为终端会话登录过程中启动密码检查 13
Metric Holddown 把新的IGRP路由选择信息与正在使用的IGRP路由选择信息隔离一段时间
Network 把一个基于NIC的地址分配给一个与它直接相连的路由器把网络与一个IGRP的路由选择的过程联系起来在IPX路由器配置模式下,在网络上启动加强的IGRP 1,5,7
Network-number 为一个直接连接的网络进行规定 1
Permit 为一个已命名的IP ACL设置条件 6
Ping 反ICMP响应请求的数据包发送到网络上的另一个节点检查主机的可达性和网络的连通性对网络基本的连通性进行诊断 1,7,12,13
Ppp authentication 启动Challenge握手鉴权协议(CHAP)或者密码验证协议(PAP)或者将两者都启动,并且对在接口上选择的CHAP和PAP验证的顺序进行规定 11,12
Ppp chap hostname 当用CHAP进行身份验证时,创建一批好象是同一台主机的拨号路由器 11
Ppp chap password 设置一个密码,该密码被发送到对路由器进行身份验证的主机,该命令对进入路由器的用户名/密码的数量进行了限制 11
Ppp pat sent-username 对一个接口启动远程PAP支持,并且在PAP对同等层请求数据包验证过程中使用sent-username和password 11
Protocol 对一个IP路由选择协议进行定义,该协议可以是RIP、IGRP、OSPF,还可以是EIGRP 1
Router igrp 启动一个IGRP的路由选择过程 5
Router rip 选择rip作为路由先择过程 1
Show access-lists 显示当前所有的ACL的内容 6
Show dialer 显示为DDR(数字数据接收器)设置的串行接口的一般诊断信息 12
Show frame-relay lmi 显示关于本地管理接口(LMI)的统计信息 13
Show frame-relay map 显示关于连接的当前映射入口和信息 13
Show frame-relay pvc 显示关于帧中继接口的永久虚电路(pvc)的统计信息 13
Show interface 显示设置在路由器和访问服务器上所有接口的统计信息 9,11,12
Show interface serial 显示关于一个串口信息 13
Show ip interface 列出一个接口的IP信息和状态的小结 6
Show ip route 显示路由器选择表的内容 12
Show ipx interface 显示Cisco IOS软件设置的IPX接口的状态以及每个接口中的参数 7
Show ipx route 显示IPX路由选择表的内容 7
Show ipx servers 显示服务器列表 7
Show ipx traffic 显示数据包的数量和类型 7
Show isdn active 显示当前呼叫的信息,包括被叫号码、建立连接前所花费的时间、在呼叫间使用的自动化*作控制(AOC)收费单元是否在呼叫期间和呼叫结束时提供AOC信息 12
Show isdn status 显示所有ISDN接口的状态、或者一个特定的数字信号链路(DSL)的状态或者一个特定ISDN接口的状态 12
Show protocols 显示设置的协议 7
Show spantree 显示关于虚拟局域网(VLAN)的生成树信息 2
Show status 显示ISDN线路和两个B信道的当前状态 12
Term ip netmask-format 规定了在show命令输出中网络掩码显示的格式 1
Timers basic 控制着IGRP以多少时间间隔发送更新信息 5
Username password 规定了在CHAP和PAP呼叫者身份验证过程中使用的密码 11

--------------------------------------------------------------------------------

相关文章
Linux运维工程师的十个基本技能点 2015/9/21 9:40:09
思科站点大集合 2006/10/31 8:26:52
Cisco常见配置 2004/11/9 10:04:39
CCNA专业词汇全集 2004/8/10 7:50:25
CISCO路由器基于时间的访问列表的应用 2004/6/10 16:44:06
新版CCNA 640-801考试IOS命令大全(ZT) 2003/8/27 17:39:13


感性空间
设计&运维
网络技术
休闲娱乐
NetFilter
linux&Unix
网络安全
程序空间
软件考试
RFC&ISO
规划&规范
虚拟&存储
Apple技巧
云计算&大数据



文章搜索



站内搜索